(risolto) samsung sp2004c - sata - kernel 2.6.X

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
nixxon
Linux 0.x
Linux 0.x
Messaggi: 72
Iscritto il: sab ott 09, 2004 0:00

(risolto) samsung sp2004c - sata - kernel 2.6.X

Messaggioda nixxon » mar nov 21, 2006 21:47

ciao a tutti, ho un problema che mi sta portando all'esaurimento informatico... :cry:

ho comprato da un mesetto un hp-compaq, ed oggi mi sono deciso ad installarci su la slackware 11. l'hd è un samsung sp2004c, il mio problema è che se installo la slackware 11 con kernel ata.i 2.4.33 va tutto ok, ma io ho necissità di passare al 2.6.17.

ho seguito la procedura su s4d ma quando do:

mkinitrd -c -k 2.6.17.13 -m libata:ata_piix:jbd:ext3 -f ext3 -r /dev/sda6

mi esce un errore, non trova libata e ata_piix eppure ho fatto una installazione full. mi potreste aiutare?
Ultima modifica di nixxon il mer nov 22, 2006 11:46, modificato 1 volta in totale.

Avatar utente
nicop
Linux 2.x
Linux 2.x
Messaggi: 232
Iscritto il: mer gen 18, 2006 11:21
Nome Cognome: Nicola Palmieri
Slackware: 12.0
Kernel: 2.6.21.5
Desktop: Gnome Slacky
Località: San Martino In P. (Cb)
Contatta:

Messaggioda nicop » mar nov 21, 2006 22:10

è un hard disk SATA???il problema sembra essere dovuto al fatto che nn c'è il supporto al controller dell'hard disk...in pratica devi solo ricompilare il kernel e tutto torno apposto...ciaoo

nixxon
Linux 0.x
Linux 0.x
Messaggi: 72
Iscritto il: sab ott 09, 2004 0:00

Messaggioda nixxon » mar nov 21, 2006 22:15

nicop ha scritto:è un hard disk SATA???il problema sembra essere dovuto al fatto che nn c'è il supporto al controller dell'hard disk...in pratica devi solo ricompilare il kernel e tutto torno apposto...ciaoo


si l'hd è sata (http://www.samsung.com/Products/HardDis ... P2004C.asp)

mi puoi spiegare che vuol dire"nn c'è il supporto al controller dell'hard disk"..? :cry:

scusami ma sono proprio a terra...

quando ricompilo il kernel cosa devo inserire per abilitare il supporto al controller dell'hard disk?
Ultima modifica di nixxon il mar nov 21, 2006 22:18, modificato 1 volta in totale.

nixxon
Linux 0.x
Linux 0.x
Messaggi: 72
Iscritto il: sab ott 09, 2004 0:00

Messaggioda nixxon » mar nov 21, 2006 22:16

nicop ha scritto:è un hard disk SATA???il problema sembra essere dovuto al fatto che nn c'è il supporto al controller dell'hard disk...in pratica devi solo ricompilare il kernel e tutto torno apposto...ciaoo


si l'hd è sata (http://www.samsung.com/Products/HardDis ... P2004C.asp)

mi puoi spiegare che vuol dire"nn c'è il supporto al controller dell'hard disk"..? :cry:

scusami ma sono proprio a terra...

quando ricompilo il kernel cosa devo inserire per abilitare il supporto al controller dell'hard disk?

Avatar utente
waka_jawaka
Linux 3.x
Linux 3.x
Messaggi: 781
Iscritto il: mer ago 10, 2005 0:00
Nome Cognome: Alberto Palillo
Kernel: 2.6.35
Desktop: KDE 4.5
Distribuzione: Archlinux

Messaggioda waka_jawaka » mer nov 22, 2006 10:55

Nel kernel devi abilitare il supporto al controller SATA (via, intel ecc), il chip sulla mobo. Riconosciuto questo, gestisci tranquillamente qualunque marca di hd.

nixxon
Linux 0.x
Linux 0.x
Messaggi: 72
Iscritto il: sab ott 09, 2004 0:00

Messaggioda nixxon » mer nov 22, 2006 11:46

waka_jawaka ha scritto:Nel kernel devi abilitare il supporto al controller SATA (via, intel ecc), il chip sulla mobo. Riconosciuto questo, gestisci tranquillamente qualunque marca di hd.


grazie al tuo aiuto ho risolto felicemente :p