esaurimento da wireless..

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
nixxon
Linux 0.x
Linux 0.x
Messaggi: 72
Iscritto il: sab ott 09, 2004 0:00

esaurimento da wireless..

Messaggioda nixxon » ven feb 12, 2010 21:26

10 giorni fa installai la slackware 12.2 configurando la connessione wireless con codifica wpa. Tutto funzionava bene.
Da allora ho solo aumentato la ram del mio portatile da 512mb a 2gb ed installato gnome..

Ora sono 2 giorni che la rete va, non va, si blocca.. un disastro. Gli stessi errori li ho anche se mi collego wireless senza crittografia..

i miei file di configurazione sono:

wpa_supplicant.conf

Codice: Seleziona tutto

# This line enables the use of wpa_cli which is used by rc.wireless
# if possible (to check for successful association)
ctrl_interface=/var/run/wpa_supplicant
# By default, only root (group 0) may use wpa_cli
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1

# WPA protected network, supply your own ESSID and WPAPSK here:
network={
  scan_ssid=0
  ssid="osiris"
  proto=WPA
  key_mgmt=WPA-PSK
  pairwise=CCMP TKIP
  group=CCMP TKIP WEP104 WEP40
  psk=ce1e470006264398bccabcc9a1c0363d1ff3b1eddf379e1f75da3cf5719aba68
}

# Plaintext connection (no WPA, no IEEE 802.1X),
# nice for hotel/airport types of WiFi network.
network={
  key_mgmt=NONE
  priority=0
}

---
rc.inet1.conf

Codice: Seleziona tutto

 /etc/rc.d/rc.inet1.conf
#
# This file contains the configuration settings for network interfaces.
# If USE_DHCP[interface] is set to "yes", this overrides any other settings.
# If you don't have an interface, leave the settings null ("").

# You can configure network interfaces other than eth0,eth1... by setting
# IFNAME[interface] to the interface's name. If IFNAME[interface] is unset
# or empty, it is assumed you're configuring eth<interface>.

# Several other parameters are available, the end of this file contains a
# comprehensive set of examples.

# =============================================================================

# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="yes"
DHCP_HOSTNAME[0]=""

# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

# Config information for eth2:
IPADDR[2]=""
NETMASK[2]=""
USE_DHCP[2]=""
DHCP_HOSTNAME[2]=""

# Config information for eth3:
IPADDR[3]=""
NETMASK[3]=""
USE_DHCP[3]=""
DHCP_HOSTNAME[3]=""

# Default gateway IP address:
GATEWAY=""

# Change this to "yes" for debugging output to stdout.  Unfortunately,
# /sbin/hotplug seems to disable stdout so you'll only see debugging output
# when rc.inet1 is called directly.
DEBUG_ETH_UP="no"

## Example config information for wlan0.  Uncomment the lines you need and fill
## in your info.  (You may not need all of these for your wireless network)
IFNAME[4]="wlan0"
IPADDR[4]=""
NETMASK[4]=""
USE_DHCP[4]="yes"
#DHCP_HOSTNAME[4]="icculus-wireless"
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
WLAN_ESSID[4]=osiris
#WLAN_MODE[4]=Managed
##WLAN_RATE[4]="54M auto"
##WLAN_CHANNEL[4]="auto"
##WLAN_KEY[4]="D5AD1F04ACF048EC2D0B1C80C7"
##WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=96389dc66eaf7e6efd5b5523ae43c7925ff4df2f8b7099495192d44a774fda16"
WLAN_WPA[4]="wpa_supplicant"
WLAN_WPADRIVER[4]="wext"
#WLAN_WPADRIVER[4]="ndiswrapper"

## Some examples of additional network parameters that you can use.
## Config information for wlan0:
#IFNAME[4]="wlan0"              # Use a different interface name nstead of
                                # the default 'eth4'
#HWADDR[4]="00:01:23:45:67:89"  # Overrule the card's hardware MAC address
#MTU[4]=""                      # The default MTU is 1500, but you might need
                                # 1360 when you use NAT'ed IPSec traffic.
#DHCP_KEEPRESOLV[4]="yes"       # If you dont want /etc/resolv.conf overwritten
#DHCP_KEEPNTP[4]="yes"          # If you don't want ntp.conf overwritten
#DHCP_KEEPGW[4]="yes"           # If you don't want the DHCP server to change
                                # your default gateway
#DHCP_IPADDR[4]=""              # Request a specific IP address from the DHCP
                                # server
#WLAN_ESSID[4]=DARKSTAR         # Here, you can override _any_ parameter
                                # defined in rc.wireless.conf, by prepending
                                # 'WLAN_' to the parameter's name. Useful for
                                # those with multiple wireless interfaces.
#WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=thekey"
                                # Some drivers require a private ioctl to be
                                # set through the iwpriv command. If more than
                                # one is required, you can place them in the
                                # IWPRIV parameter (separated with the pipe (|)
                                # character, see the example).

in particolare non capisco perchè ho questi errori:


Codice: Seleziona tutto

root@darkstar:~# /etc/rc.d/rc.inet1 restart
/sbin/dhcpcd: not running
Polling for DHCP server on interface eth0:
Broadcasting DHCP_DISCOVER
timed out waiting for a valid DHCP server response
/etc/rc.d/rc.inet1:  wlan0 information: 'Any ESSID'
Error for wireless request "Set Nickname" (8B1C) :
    SET failed on device wlan0 ; Operation not supported.
Polling for DHCP server on interface wlan0:
Broadcasting DHCP_DISCOVER
broadcastAddr option is missing in DHCP server response. Assuming 192.168.1.255
dhcpIPaddrLeaseTime=86400 in DHCP server response.
dhcpT1value is missing in DHCP server response. Assuming 43200 sec
dhcpT2value is missing in DHCP server response. Assuming 75600 sec
DHCP_OFFER received from  (192.168.1.1)
Broadcasting DHCP_REQUEST for 192.168.1.2
dhcpIPaddrLeaseTime=86400 in DHCP server response.
dhcpT1value is missing in DHCP server response. Assuming 43200 sec
dhcpT2value is missing in DHCP server response. Assuming 75600 sec
DHCP_ACK received from  (192.168.1.1)
Broadcasting ARPOP_REQUEST for 192.168.1.2
root@darkstar:~#

root@darkstar:~# ping http://www.google.it
PING http://www.l.google.com (209.85.135.103) 56(84) bytes of data.
64 bytes from mu-in-f103.1e100.net (209.85.135.103): icmp_seq=1 ttl=53 t
ime=109 ms
64 bytes from mu-in-f103.1e100.net (209.85.135.103): icmp_seq=2 ttl=53 t
ime=435 ms
64 bytes from mu-in-f103.1e100.net (209.85.135.103): icmp_seq=3 ttl=53 t                           ime=315 ms
64 bytes from mu-in-f103.1e100.net (209.85.135.103): icmp_seq=4 ttl=53 t                           ime=79.8 ms
64 bytes from mu-in-f103.1e100.net (209.85.135.103): icmp_seq=5 ttl=53 t                           ime=602 ms
64 bytes from mu-in-f103.1e100.net (209.85.135.103): icmp_seq=6 ttl=53 t                           ime=1957 ms
64 bytes from 209.85.135.103: icmp_seq=7 ttl=53 time=1014 ms
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
^C
--- http://www.l.google.com ping statistics ---
25 packets transmitted, 7 received, 72% packet loss, time 56032ms
rtt min/avg/max/mdev = 79.872/645.082/1957.713/611.751 ms, pipe 2
root@darkstar:~#


root@darkstar:~# ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
64 bytes from 192.168.1.1: icmp_seq=1 ttl=64 time=1575 ms
64 bytes from 192.168.1.1: icmp_seq=2 ttl=64 time=1380 ms
64 bytes from 192.168.1.1: icmp_seq=3 ttl=64 time=990 ms
64 bytes from 192.168.1.1: icmp_seq=4 ttl=64 time=93.9 ms
64 bytes from 192.168.1.1: icmp_seq=5 ttl=64 time=436 ms
64 bytes from 192.168.1.1: icmp_seq=6 ttl=64 time=148 ms
64 bytes from 192.168.1.1: icmp_seq=7 ttl=64 time=50.6 ms
64 bytes from 192.168.1.1: icmp_seq=8 ttl=64 time=174 ms
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
^C
--- 192.168.1.1 ping statistics ---
24 packets transmitted, 8 received, 66% packet loss, time 42115ms
rtt min/avg/max/mdev = 50.657/606.364/1575.012/578.996 ms, pipe 2
root@darkstar:~#


preciso che uso una scheda pcmcia d-link dwl-g650 con chip atheros ar2414 che carica il modulo ath5k.

inutile dire che con xp funge tutto benone... :-k

any ideas?
Ultima modifica di nixxon il ven feb 12, 2010 22:08, modificato 2 volte in totale.

Avatar utente
slucky
Iper Master
Iper Master
Messaggi: 2412
Iscritto il: mar mag 01, 2007 15:30
Slackware: 14.2
Kernel: 4.11.3-smp
Desktop: xfce4
Distribuzione: freeBSD-12.0-Release

Re: esaurimento da wireless..

Messaggioda slucky » ven feb 12, 2010 21:52

qui dovresti mettere l'indirizzo del gateway:

# Default gateway IP address:
GATEWAY=""


e quando riavvii la rete, indica l'interfaccia usata:

/etc/rc.d/rc.inet1 wlan0_restart

sarebbe anche meglio che disattivi eth0 per evitare conflitti in dhcp con la scheda wi-fi:

# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]=""
DHCP_HOSTNAME[0]=""


infine, un consiglio, usa i tag code o Quote quando scrivi, onde evitare post chilometrici.... ;)

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom apr 17, 2005 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: esaurimento da wireless..

Messaggioda phobos3576 » ven feb 12, 2010 22:12

slucky ha scritto:infine, un consiglio, usa i tag code o Quote quando scrivi, onde evitare post chilometrici.... ;)


Inoltre, evita di pubblicare l'acces key della tua rete wireless; se guardi fuori dalla finestra, adesso ci sono un sacco di auto parcheggiate attorno a casa tua ...

:-' :-'

nixxon
Linux 0.x
Linux 0.x
Messaggi: 72
Iscritto il: sab ott 09, 2004 0:00

Re: esaurimento da wireless..

Messaggioda nixxon » ven feb 12, 2010 22:48

phobos3576 ha scritto:
slucky ha scritto:infine, un consiglio, usa i tag code o Quote quando scrivi, onde evitare post chilometrici.... ;)


Inoltre, evita di pubblicare l'acces key della tua rete wireless; se guardi fuori dalla finestra, adesso ci sono un sacco di auto parcheggiate attorno a casa tua ...

:-' :-'


se non risolvo il problema di connessione quelle auto non rimarranno a lungo.. :lol: piuttosto che errore è ping: sendmsg: No buffer space available ???? :-k

Avatar utente
slucky
Iper Master
Iper Master
Messaggi: 2412
Iscritto il: mar mag 01, 2007 15:30
Slackware: 14.2
Kernel: 4.11.3-smp
Desktop: xfce4
Distribuzione: freeBSD-12.0-Release

Re: esaurimento da wireless..

Messaggioda slucky » ven feb 12, 2010 23:31

se ancora non funziona, probabile che abbia a che fare proprio con la memoria, dai una lettura qui:

http://www.linuxquestions.org/questions ... le-334631/

Avatar utente
Ansa89
Iper Master
Iper Master
Messaggi: 2703
Iscritto il: mer ago 29, 2007 17:57
Nome Cognome: Stefano Ansaloni
Slackware: 14.2 64bit
Kernel: 4.9.61
Desktop: XFCE 4.12
Località: Modena
Contatta:

Re: esaurimento da wireless..

Messaggioda Ansa89 » sab feb 13, 2010 10:48

nixxon ha scritto:piuttosto che errore è ping: sendmsg: No buffer space available ????

Credo che per mandare i ping, il kernel usi le primitive sendmsg() e recvmsg(), le quali richiedono un buffer dove salvare i messaggi.
Se il ricevente non riinvia il messaggio svuotato, questo rimane nella coda, saturandola e quindi i lkernel manda un errore di buffer pieno.

Non sono sicuro di quello che ho scritto, è solo un'ipotesi. Probabilmente tra un po' arriverà qualcuno che ne sa di più e chiarirà tutto ;) .

nixxon
Linux 0.x
Linux 0.x
Messaggi: 72
Iscritto il: sab ott 09, 2004 0:00

Re: esaurimento da wireless..

Messaggioda nixxon » sab feb 13, 2010 15:08

Ansa89 ha scritto:
nixxon ha scritto:piuttosto che errore è ping: sendmsg: No buffer space available ????

Credo che per mandare i ping, il kernel usi le primitive sendmsg() e recvmsg(), le quali richiedono un buffer dove salvare i messaggi.
Se il ricevente non riinvia il messaggio svuotato, questo rimane nella coda, saturandola e quindi i lkernel manda un errore di buffer pieno.

Non sono sicuro di quello che ho scritto, è solo un'ipotesi. Probabilmente tra un po' arriverà qualcuno che ne sa di più e chiarirà tutto ;) .



la cosa mi preoccupa molto... :-k non ho idea di come risolvere.

Avatar utente
Ansa89
Iper Master
Iper Master
Messaggi: 2703
Iscritto il: mer ago 29, 2007 17:57
Nome Cognome: Stefano Ansaloni
Slackware: 14.2 64bit
Kernel: 4.9.61
Desktop: XFCE 4.12
Località: Modena
Contatta:

Re: esaurimento da wireless..

Messaggioda Ansa89 » sab feb 13, 2010 15:15

Non c'è niente da preoccuparsi, il sistema delle code di messaggi è ben implementato dal kernel.
Per risolvere il problema dovresti limitare i ping, oppure aumentare il buffer della coda di messaggi.

nixxon
Linux 0.x
Linux 0.x
Messaggi: 72
Iscritto il: sab ott 09, 2004 0:00

Re: esaurimento da wireless..

Messaggioda nixxon » sab feb 13, 2010 15:58

slucky ha scritto:se ancora non funziona, probabile che abbia a che fare proprio con la memoria, dai una lettura qui:

http://www.linuxquestions.org/questions ... le-334631/


ho provato a dare echo 83886080 > /proc/sys/net/core/wmem_max la connessione effettivamente non cade ma navigare con firefox è di una lentezza esasperante..sembra quasi di usare una connessione 33k

nixxon
Linux 0.x
Linux 0.x
Messaggi: 72
Iscritto il: sab ott 09, 2004 0:00

Re: esaurimento da wireless..

Messaggioda nixxon » sab feb 13, 2010 16:00

Ansa89 ha scritto:Non c'è niente da preoccuparsi, il sistema delle code di messaggi è ben implementato dal kernel.
Per risolvere il problema dovresti limitare i ping, oppure aumentare il buffer della coda di messaggi.


però non capisco perchè appena installata la 12.2 andava una meraviglia e poi è sorto questo problema.. :( come si aumenta il buffer della coda di messaggi? perchè a me da questo errore ed altri no? da cosa può dipendere?

Avatar utente
Ansa89
Iper Master
Iper Master
Messaggi: 2703
Iscritto il: mer ago 29, 2007 17:57
Nome Cognome: Stefano Ansaloni
Slackware: 14.2 64bit
Kernel: 4.9.61
Desktop: XFCE 4.12
Località: Modena
Contatta:

Re: esaurimento da wireless..

Messaggioda Ansa89 » sab feb 13, 2010 16:11

Ripeto che non sono sicuro di ciò che ho detto e non so neanche se si può aumentare quel buffer.

Avatar utente
conraid
Staff
Staff
Messaggi: 13305
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: esaurimento da wireless..

Messaggioda conraid » sab feb 13, 2010 17:36

tcp_wmem

per maggiori informazioni guarda in PATH_SORGENTI_KERNEL/Documentation/networking/ip-sysctl.txt