Pagina 1 di 1

abiword non si avvia

Inviato: dom mar 03, 2013 20:16
da SlackNewbie
Salve a tutti!! Sono nuovo di slackware e avrei bisogno di una spiegazione.Ho installato il pacchetto di abiword tuttavia quando cerco di avviare il programma non succede nulla.
Come mai?? devo installare tutte le dipendenze? Grazie a chiunque mi risponda (non so se sono nella sezione giusta, mi scuso anticipatamente).

Re: abiword non si avvia

Inviato: dom mar 03, 2013 20:38
da targzeta
Lancia il programma da un terminale e poi postaci l'output.

Emanuele

Re: abiword non si avvia

Inviato: dom mar 03, 2013 20:48
da SlackNewbie
Scusa l'ignoranza potresti spiegarmi gentilmente cosa intendi per avviare il programma da terminale?
Comunque ho risolto installando tutte le dipendenze, adesso il programma si avvia.Ma ogni qualvolta voglio installare un programma che ha delle dipendenze,è necessario installare anche quest'ultime?

Re: abiword non si avvia

Inviato: dom mar 03, 2013 21:42
da targzeta
Certo, se si chiamano dipendenza ci sarà un motivo, no :)

Emanuele

Re: abiword non si avvia

Inviato: lun mar 04, 2013 12:34
da hashbang
SlackNewbie ha scritto:Scusa l'ignoranza potresti spiegarmi gentilmente cosa intendi per avviare il programma da terminale?
Apri un emulatore di terminale (es, Konsole, xterm, rxvt ecc.) e scrivi il nome dell'eseguibile.

In questo caso:
Dopo aver aperto un emulatore di terminale, digiti

Codice: Seleziona tutto

$ abiword

dai "invio" e controlli l'output. Se c'è un errore, l'emulatore lo riporterà nell'output dell'applicazione avviata.


AGGIUNTA: Il simbolo "$" indica che lo avvierai da utente normale e non da root (amministratore). Nel terminale ti basta scrivere "abiword".

Re: abiword non si avvia

Inviato: lun mar 04, 2013 13:47
da SlackNewbie
Innanzitutto vi ringrazio per le risposte chiare e concise.Però ho ancora un dubbio,se una delle dipendenze,nel mio caso del pacchetto di abiword, ha altre dipendenze,devo installare anche queste??Sarebbe una catena infinita.....Scusate la manifesta ignoranza :)

Re: abiword non si avvia

Inviato: lun mar 04, 2013 14:12
da hashbang
Sì.

Se un pacchetto W ha come dipendenza X che, a sua volta, richiede Y e Z. Allora oltre ad installare il pacchetto W, dovrai installare X, Y e Z.


SlackNewbie ha scritto:Sarebbe una catena infinita.....
Comunque sono pochi i casi di software con un elevato numero di dipendenze e sottodipendenze.
Sono tipiche di GNOME e qualche software specifico.

Nella maggiorparte dei casi te la cavi con poco.

Re: abiword non si avvia

Inviato: lun mar 04, 2013 15:31
da SlackNewbie
Tutto chiaro :D !! Ringrazio tutti; credo di essere diventato un cliente affezionato di questo forum. Posso esporre un altro dubbio?? Ho installato slackware 14 su macchina virtuale ed ho notato che l'ora è indietro;come procedere per sistemarla?? Inoltre ho i programmi che sono installati di default su slackware (come DE uso xfce) in inglese, come posso metterli in italiano??

Re: abiword non si avvia

Inviato: lun mar 04, 2013 15:34
da hashbang
SlackNewbie ha scritto:Tutto chiaro :D !! Ringrazio tutti; credo di essere diventato un cliente affezionato di questo forum. Posso esporre un altro dubbio?? Ho installato slackware 14 su macchina virtuale ed ho notato che l'ora è indietro;come procedere per sistemarla?? Inoltre ho i programmi che sono installati di default su slackware (come DE uso xfce) in inglese, come posso metterli in italiano??
Tecnicamente dovresti aprire un nuovo topic per ognuno di questi argomenti.

Comunque sia, stavolta risponderò qui.
Problema 1 "ora indietro")

Codice: Seleziona tutto

$ sudo ntpdate time.ien.it


Problema 2)

Codice: Seleziona tutto

$ sudo vi /etc/profile.d/lang.sh
$ sudo vi /etc/profile.d/lang.csh


E cambia en_US in it_IT

PS: se non ti piace vi, puoi usare nano che è un editor più easy-to-use.

Re: abiword non si avvia

Inviato: lun mar 04, 2013 15:59
da SlackNewbie
Fantastico ha funzionato :D !!! Grazie mille hashbang
Mi scuso per aver posto cosi tante domande nello stesso topic :oops: e che ho tanti dubbi da chiarire......