IRDA - toshiba satellite 1900-303

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
omino
Linux 0.x
Linux 0.x
Messaggi: 73
Iscritto il: dom mar 20, 2005 0:00
Contatta:

IRDA - toshiba satellite 1900-303

Messaggioda omino » dom mar 20, 2005 15:56

Salve a tutti, sono nuovo di qui e sono un newbie. <BR>Giorni fa, passando in edicola, vidi Linux-pro con allegata la Slackware 10.1 (due cd + un terzo cd di manualistica)... non ho resistito ed eccomi qua. <BR>L´ho installata sul mio portatile: Toshiba Satellite 1900-303. <BR>Premetto che mi collego ad internet tramite un cellulare Siemens S55 attraverso la porta ad infrarossi. <BR>Ora mi si presenta un problema: come fare per far vedere alla Slackware 10.1 la porta ad infrarossi? Spero tanto di risolvere la cosa al più presto. <BR>Grazie mille a tutti coloro che mi risponderanno. <BR>Ciao. :-D <br>

pennega
Linux 3.x
Linux 3.x
Messaggi: 607
Iscritto il: dom lug 04, 2004 0:00
Contatta:

IRDA - toshiba satellite 1900-303

Messaggioda pennega » dom mar 20, 2005 20:41

ti posto l´indirizzo di una guida che ho seguito...comunque ti devi scaricare dallarete gli irda-tool reperibili da <!-- BBCode Start --><A HREF="http://irda.sourceforge.net/" TARGET="_blank">qui</A><!-- BBCode End --> <BR> <BR>la guida la trovi invece qui <a href="http://ale.shouldshave.org/t630_linux.it.html#software" target="_blank" target="_new">http://ale.shouldshave.org/t630_linux.it.html#software</a> <BR> <BR>se i serve altro chiedi pure.... <BR> <BR>controlla nel dios che tipo di irda hai se FIR oSIR <BR><br>

pennega
Linux 3.x
Linux 3.x
Messaggi: 607
Iscritto il: dom lug 04, 2004 0:00
Contatta:

IRDA - toshiba satellite 1900-303

Messaggioda pennega » dom mar 20, 2005 20:46

ti posto l´indirizzo di una guida che ho seguito...comunque ti devi scaricare dallarete gli irda-tool reperibili da <!-- BBCode Start --><A HREF="http://irda.sourceforge.net/" TARGET="_blank">qui</A><!-- BBCode End --> <BR> <BR>la guida la trovi invece qui <a href="http://ale.shouldshave.org/t630_linux.it.html#software" target="_blank" target="_new">http://ale.shouldshave.org/t630_linux.it.html#software</a> <BR> <BR>se i serve altro chiedi pure.... <BR> <BR>controlla nel dios che tipo di irda hai se FIR oSIR <BR><br>

Avatar utente
omino
Linux 0.x
Linux 0.x
Messaggi: 73
Iscritto il: dom mar 20, 2005 0:00
Contatta:

IRDA - toshiba satellite 1900-303

Messaggioda omino » lun mar 21, 2005 17:35

Eccomi di nuovo qui. <BR>Gli infrarossi sono di tipo FIR <BR>Ho installato le IRDA-UTILS seguento il link che mi hai fornito; <BR>non so se l´installazione sia andata a buon termine... come faccio a verificare che il collegamento funziona? ho provato a mettere il cellulare di fronte alla porta, ma nn avviene alcuna notifica di collegamento. C´è qualche altra operazione che debbo effettuare? Moduli da aggiungere? file di configurazione da modificare? Grazie ancora. <BR>Ciao. :-D <br>

nixxon
Linux 0.x
Linux 0.x
Messaggi: 72
Iscritto il: sab ott 09, 2004 0:00

IRDA - toshiba satellite 1900-303

Messaggioda nixxon » lun mar 21, 2005 23:30

Scusami se sono OT ma sul toshiba usando la slack 10.1 riesci ad ascolatre mp3, cd-audio e musica in genere? hai problemi con alsa?<br>

Avatar utente
omino
Linux 0.x
Linux 0.x
Messaggi: 73
Iscritto il: dom mar 20, 2005 0:00
Contatta:

IRDA - toshiba satellite 1900-303

Messaggioda omino » lun mar 21, 2005 23:46

Si, con alsa non sento nulla. <BR>Ora provo così: <BR> <BR> lsmod | grep sound ***per trovare il nome del modulo*** <BR>modprobe "nome del modulo" <BR><BR><BR>[ Questo Messaggio è stato Modificato da: omino il 21-03-2005 23:48 ]<br>

Avatar utente
omino
Linux 0.x
Linux 0.x
Messaggi: 73
Iscritto il: dom mar 20, 2005 0:00
Contatta:

IRDA - toshiba satellite 1900-303

Messaggioda omino » mar mar 22, 2005 0:10

Ho provato. però non funzia :( <BR>pian piano vedrò di farlo funzionare... per ora è prioritaria la porta ad infrarossi. Spero sappiate come fare. Argh! Temo che prima di comprendere come far funzionare il tutto: diventerò vecchio! <BR>Grazie ancora. <BR>Ciao. :) <BR> <BR>http://www.ominodelbuio.altervista.org <BR><BR><BR>[ Questo Messaggio è stato Modificato da: omino il 22-03-2005 00:41 ]<br>

Avatar utente
omino
Linux 0.x
Linux 0.x
Messaggi: 73
Iscritto il: dom mar 20, 2005 0:00
Contatta:

IRDA - toshiba satellite 1900-303

Messaggioda omino » mar mar 22, 2005 23:45

Oi.. c´è qualche anima pia che sa darmi un aiutino? <BR>Grazie grazie. Ciao. :) <BR><BR><BR>[ Questo Messaggio è stato Modificato da: omino il 22-03-2005 23:47 ]<br>

pennega
Linux 3.x
Linux 3.x
Messaggi: 607
Iscritto il: dom lug 04, 2004 0:00
Contatta:

IRDA - toshiba satellite 1900-303

Messaggioda pennega » mer mar 23, 2005 20:57

ho perso un pò di vista la discussione... <BR> <BR>alloa se hai una FIR devi installare anche smcinit che trovi su <BR> <BR>http://sourceforge.net/projects/irda/ <BR> <BR>e poi devi dare da root questi comandi <BR> <BR>/usr/local/sbin/smcinit <BR>modprobe smsc-ircc2 <BR> <BR>poi attivi la porta <BR> <BR>irattach irda0 -s <BR>ifconfig irda0 up <BR>modprobe ircomm <BR>modprobe ircomm-tty <BR> <BR>a questo punto dovresti trovare in /dev/ dei dispositivi del tipo ircomm0 ecc.. questa è la tua porta infrarossi.... <BR>sicuramente così non riuscirai ad userla da utente quindi dai un bel <BR> <BR>chmod 666 /dev/ircomm0 <BR> <BR>poi atttivi la porta infrarossi del cel e lo metti davanti a quella del pc e usa <BR> <BR>irdadump <BR> <BR>x vedere se cel e pc comunicano.... <BR> <BR>la mia infrared è diversa dalla tua... la mia è SIR ... <BR>comunque dovrebbe funzionale lo stesso <BR><BR><BR>[ Questo Messaggio è stato Modificato da: pennega il 23-03-2005 21:02 ]<br>

Avatar utente
omino
Linux 0.x
Linux 0.x
Messaggi: 73
Iscritto il: dom mar 20, 2005 0:00
Contatta:

IRDA - toshiba satellite 1900-303

Messaggioda omino » mer mar 23, 2005 22:57

Mm, purtroppo arrivo fin qui: <BR>modprobe smsc-ircc2 <BR>e poi mi dice che nn trova il modulo :( sai il perchè? <BR>Grazie ancora per tutte le info. :)<br>

pennega
Linux 3.x
Linux 3.x
Messaggi: 607
Iscritto il: dom lug 04, 2004 0:00
Contatta:

IRDA - toshiba satellite 1900-303

Messaggioda pennega » gio mar 24, 2005 8:02

probabilmente non hai compilato il kernel con tutti i moduli che ti servono... <BR>dai questo comando <BR> <BR>less /usr/src/linux-2.6.7/.config |grep IR <BR> <BR>leggi tra le righe dovresti trovare qualcosa del tipo <BR> <BR>CONFIG_IRDA=y <BR>CONFIG_IRLAN=m <BR>CONFIG_IRNET=m <BR>CONFIG_IRCOMM=m <BR>CONFIG_IRDA_ULTRA=y <BR>CONFIG_IRDA_CACHE_LAST_LSAP=y <BR>CONFIG_IRDA_FAST_RR=y <BR>CONFIG_IRDA_DEBUG=y <BR># SIR device drivers <BR>CONFIG_IRTTY_SIR=m <BR>CONFIG_GIRBIL_DONGLE=m <BR># Old SIR device drivers <BR>CONFIG_IRPORT_SIR=m <BR># FIR device drivers <BR>CONFIG_USB_IRDA=m <BR>CONFIG_SIGMATEL_FIR=m <BR>CONFIG_NSC_FIR=m <BR>CONFIG_WINBOND_FIR=m <BR>CONFIG_TOSHIBA_FIR=m <BR>CONFIG_SMC_IRCC_FIR=m <BR>CONFIG_ALI_FIR=m <BR>CONFIG_VLSI_FIR=m <BR>CONFIG_VIA_FIR=m <BR> <BR> <BR>se non gli trovi devi ricompilare il kernel ed includere questi moduli.... <BR> <BR><br>

Avatar utente
omino
Linux 0.x
Linux 0.x
Messaggi: 73
Iscritto il: dom mar 20, 2005 0:00
Contatta:

IRDA - toshiba satellite 1900-303

Messaggioda omino » ven mar 25, 2005 19:06

Accipicchia! Ho ricompilato il kernel... non so se ho dimenticato qualcosa. Questo è quello che ho: <BR> <BR>root@darkstar:~# less /usr/src/linux/.config |grep IR <BR># CONFIG_PCI_GODIRECT is not set <BR>CONFIG_PCI_DIRECT=y <BR>CONFIG_IP_NF_IRC=m <BR>CONFIG_IP_NF_TARGET_MIRROR=m <BR>CONFIG_IP_NF_TARGET_REDIRECT=m <BR>CONFIG_IP_NF_NAT_IRC=m <BR>CONFIG_IDEPCI_SHARE_IRQ=y <BR># CONFIG_AIC7XXX_BUILD_FIRMWARE is not set <BR># CONFIG_AIC79XX_BUILD_FIRMWARE is not set <BR>CONFIG_SCSI_QLOGIC_FC_FIRMWARE=y <BR>CONFIG_ADAPTEC_STARFIRE=m <BR>CONFIG_AIRONET4500=m <BR>CONFIG_AIRONET4500_NONCS=m <BR>CONFIG_AIRONET4500_PNP=y <BR>CONFIG_AIRONET4500_PCI=y <BR># CONFIG_AIRONET4500_ISA is not set <BR># CONFIG_AIRONET4500_I365 is not set <BR>CONFIG_AIRONET4500_PROC=m <BR>CONFIG_AIRO=m <BR>CONFIG_AIRO_CS=m <BR>CONFIG_NET_WIRELESS=y <BR>CONFIG_PCMCIA_XIRC2PS=m <BR>CONFIG_PCMCIA_XIRCOM=m <BR>CONFIG_PCMCIA_XIRTULIP=m <BR>CONFIG_AIRONET4500_CS=m <BR>CONFIG_IRDA=y <BR>CONFIG_IRLAN=m <BR>CONFIG_IRNET=y <BR>CONFIG_IRCOMM=y <BR># CONFIG_IRDA_ULTRA is not set <BR>CONFIG_IRDA_CACHE_LAST_LSAP=y <BR>CONFIG_IRDA_FAST_RR=y <BR># CONFIG_IRDA_DEBUG is not set <BR>CONFIG_IRTTY_SIR=m <BR>CONFIG_IRPORT_SIR=m <BR>CONFIG_GIRBIL_DONGLE=m <BR>CONFIG_USB_IRDA=m <BR>CONFIG_NSC_FIR=m <BR>CONFIG_WINBOND_FIR=m <BR>CONFIG_TOSHIBA_FIR=y <BR>CONFIG_SMC_IRCC_FIR=y <BR>CONFIG_ALI_FIR=m <BR>CONFIG_VLSI_FIR=m <BR>CONFIG_VIA_IRCC_FIR=m <BR>CONFIG_SERIAL_SHARE_IRQ=y <BR># CONFIG_SERIAL_DETECT_IRQ is not set <BR>CONFIG_ACQUIRE_WDT=m <BR>CONFIG_RADIO_MAXIRADIO=m <BR>CONFIG_RADIO_MIROPCM20=m <BR>CONFIG_RADIO_MIROPCM20_RDS=m <BR># CONFIG_NFS_DIRECTIO is not set <BR># CONFIG_FB_VIRTUAL is not set <BR>CONFIG_USB_SERIAL_IR=m <BR>CONFIG_USB_SERIAL_XIRCOM=m <BR>root@darkstar:~# <BR> <BR>però irdadump ancora non funziona!!! Spero di nn doverlo ricompilare di nuovo. Come ti sembra? Grazie ancora. <BR>Bye. :)<br>

pennega
Linux 3.x
Linux 3.x
Messaggi: 607
Iscritto il: dom lug 04, 2004 0:00
Contatta:

IRDA - toshiba satellite 1900-303

Messaggioda pennega » sab mar 26, 2005 13:00

non ti carica il modulo xchè non c´è... l´hai compilato staticamente nel kernel... <BR> <BR>CONFIG_SMC_IRCC_FIR=y <BR> <BR>invece al poso della Y ci deve essere una M... <BR> <BR>se hai voglia di ricompilare te lo consiglio...in caso controlla anche gli altri xchè ho visto che moltri altri suportigli hai messi statici... <BR> <BR><br>

Avatar utente
omino
Linux 0.x
Linux 0.x
Messaggi: 73
Iscritto il: dom mar 20, 2005 0:00
Contatta:

IRDA - toshiba satellite 1900-303

Messaggioda omino » sab mar 26, 2005 20:45

Evviva!!! Grazie mille!!! Ho ricompilato di nuovo il kernel.... <BR>ho eseguito le tue istruzioni ed ora facendo irdadump lo vedo che comunica. :) <BR>Ora mi si affaccia un piccolo (spero) problemino: volevo modificare il permesso di ircomm0 (dentro /dev) tramite chmod 666 - come da te suggerito - solo che, oimè, nella directory /dev non c´è neppure un file che inizia per ir* <BR>ho anche provato a fare un find su / <BR>cercando ircomm0 (ma nn lo trova da nessuna parte). <BR>Scusa per le tante domande; grazie ancora. <BR>Ciao. :)<br>

pennega
Linux 3.x
Linux 3.x
Messaggi: 607
Iscritto il: dom lug 04, 2004 0:00
Contatta:

IRDA - toshiba satellite 1900-303

Messaggioda pennega » dom mar 27, 2005 8:22

a me il device lo crea quando crarico il modulo <BR> <BR>modprobe ircomm-tty <BR> <BR>controlla sempre in /dev o posta il risultatp di <BR> <BR>ls /dev <BR> <BR>magari visto che la tua IRDA è FIR e non SIR il dev prende un altro nome...magari lo puoi trovare anche con <BR> <BR>dmesg...<br>