samba - slackware - windows98

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
nixxon
Linux 0.x
Linux 0.x
Messaggi: 72
Iscritto il: sab ott 09, 2004 0:00

samba - slackware - windows98

Messaggioda nixxon » dom lug 24, 2005 16:28

ciao, vorrei fare una rete tra slack10.1 e windows98 utilizzando samba. ho letto diverse guide trovate con google (in italiano inglese e spagnolo)ma non ci ho capito nulla, ognuno diceva cose diverse. c'è qualcuno che lo ha già fatto la stessa cosa? per favore se mi potete aiutare possibilmente con un supporto passo passo perchè sono entrato nel pallone e non sto capendo + niente. :roll:

Avatar utente
DaNiMoTh
Linux 3.x
Linux 3.x
Messaggi: 941
Iscritto il: mar nov 30, 2004 0:00
Località: irc.syrolnet.org /// #slackware
Contatta:

Messaggioda DaNiMoTh » dom lug 24, 2005 18:56

Beh, se è vero che hai letto così tante guide ( cosa che dubito :P) cosa c'è che non hai capito nella mia? ( Ah, è nella sezione Howto --> Networking di questo sito )


CIaooOoOOO :)

nixxon
Linux 0.x
Linux 0.x
Messaggi: 72
Iscritto il: sab ott 09, 2004 0:00

Messaggioda nixxon » dom lug 24, 2005 19:21

invece l'ho letta e stampata... e sinceramente l'ho trovata difficile. non ho capito qual è il smb.conf da mettere e poi il carattere piccolo mi ha fatto venire il mal di testa :roll: colpa mia cercavo una guida + semplice.

Avatar utente
DaNiMoTh
Linux 3.x
Linux 3.x
Messaggi: 941
Iscritto il: mar nov 30, 2004 0:00
Località: irc.syrolnet.org /// #slackware
Contatta:

Messaggioda DaNiMoTh » dom lug 24, 2005 21:54

[dani@myhost ~]$find /etc | grep smb.conf
/etc/samba/smb.conf


Tah-dah


:wink:

nixxon
Linux 0.x
Linux 0.x
Messaggi: 72
Iscritto il: sab ott 09, 2004 0:00

Messaggioda nixxon » dom lug 24, 2005 22:50

eccolo, è configurato bene?

# Samba config file created using SWAT
# from 127.0.0.1 (127.0.0.1)
# Date: 2005/07/24 22:40:53

# Global parameters
[global]
workgroup = OSIRIS
netbios name = SATELLITE
security = SHARE
smb passwd file = /etc/smbpasswd
log file = /usr/local/samba/var/log.%m
max log size = 50
wins server = 193.168.1.3
hosts allow = 192.168.1., 192.168.2., 127., localhost

[homes]
comment = Home Directories
read only = No
create mask = 0750
browseable = No

[tmp]
comment = Spazio per file temporanei
path = /tmp
read only = No
guest ok = Yes

[public]
comment = Public ftp
path = /home/ftp
write list = @ftp
read only = No
guest ok = Yes

e ora?

Avatar utente
DaNiMoTh
Linux 3.x
Linux 3.x
Messaggi: 941
Iscritto il: mar nov 30, 2004 0:00
Località: irc.syrolnet.org /// #slackware
Contatta:

Messaggioda DaNiMoTh » lun lug 25, 2005 13:15

Fai partire samba con

# nmbd start && smbd start

nixxon
Linux 0.x
Linux 0.x
Messaggi: 72
Iscritto il: sab ott 09, 2004 0:00

Messaggioda nixxon » mar lug 26, 2005 8:21

fatto.. ma non va.. ho modificato anche il registro del win 98 per via delle password criptate (era veramente necessario?) ora che riavvio i demini samba non ho capito che cosa si deve fare.. :(

nixxon
Linux 0.x
Linux 0.x
Messaggi: 72
Iscritto il: sab ott 09, 2004 0:00

Messaggioda nixxon » ven lug 29, 2005 14:10

grazie a tutti per l'aiuto e scusate se ho postato un problema difficilissimo e sconosciuto a molti...

Avatar utente
useless
Staff
Staff
Messaggi: 3896
Iscritto il: dom ott 12, 2003 0:00
Località: A place where the streets have no name
Contatta:

Messaggioda useless » ven lug 29, 2005 14:53

il file delle password mi puzza un po', non dovrebbe essere in /etc/samba/private?
x restartare samba: /etc/rc.d/rc.samba restart
ora devi creare gli utenti che vuoi abbiano accesso, con smbpasswd -a nomeutente, poi da windows apri le risorse di rete e dovresti trovare le tue condivisioni, dopo il login con username e password impostati.

nixxon
Linux 0.x
Linux 0.x
Messaggi: 72
Iscritto il: sab ott 09, 2004 0:00

Messaggioda nixxon » dom lug 31, 2005 18:36

ho fatto come hai detto ed ora è tutto ok :P era proprio quello che sbagliavo :P