Repository 32bit  Forum
Repository 64bit  Wiki

problemi con php e mysql (lungo)

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

problemi con php e mysql (lungo)

Messaggioda scibilo » lun ott 06, 2003 19:17

salve a tutti, <BR>ho problemi con mysql e php. <BR>Ho letto non so piu´ quanti tutorial, thread etc., ma non ho trovato niente che faccia al caso mio. <BR> <BR>Dunque, nella mia slack e´ gia´ installato apache, php e mysql aggiornati con swaret, quindi io non sono intervenuto minimamente nella loro configurazione e indicazione dei vari path; apache funziona regolarmente. <BR> <BR>Primo problema: ho messo in /var/www/htdocs un semplice file info.php, ma quando lo richiamo dal browser invece di mostrarmi la classica pagina di php, mi chiede di scaricarla; ho aggiunto in /etc/apache/httpd.conf dei riferimenti per i moduli di php, ma questa volta all´avvio del server mi da errore perche´ non riesce a trovare i moduli. <BR> <BR>Secondo problema: devo aver pasticciato un po´ con i permessi e installazione mysql_install_db perche´ non mi permette l´accesso. <BR> <BR>Cosa devo fare? Dovrei reinstallare apache, php e mysql? <BR> <BR>Spero di essere stato abbastanza chiaro <BR> <BR>grazie <BR>Ciao <BR><br>
scibilo
Linux 2.0
Linux 2.0
 
Messaggi: 111
Iscritto il: ven set 19, 2003 23:00

problemi con php e mysql (lungo)

Messaggioda Loris » lun ott 06, 2003 20:13

Per attivare il supporto php, devi decommentare la riga Include /etc/apache/mod_php.conf che trovi in fondo al file /etc/apache/httpd.conf, fai ripartire apachectl e riprovi con il file info.php<br>
"Ho una testa piuttosto balzana e comunque non sono quello che credete" - Roger Keith Barrett
Avatar utente
Loris
Admin
Admin
 
Messaggi: 7593
Iscritto il: dom mar 30, 2003 23:00
Località: Gradisca D'Isonzo
Nome Cognome: Loris Vincenzi
Slackware: 14.1
Kernel: 3.10.17
Desktop: Kde 4.10.5

problemi con php e mysql (lungo)

Messaggioda scibilo » mar ott 07, 2003 7:41

grazie mille, <BR>adesso php funzina correttamente :-) <BR>ciao<br>
scibilo
Linux 2.0
Linux 2.0
 
Messaggi: 111
Iscritto il: ven set 19, 2003 23:00

problemi con php e mysql (lungo)

Messaggioda wario » mar ott 07, 2003 20:29

cancella la directory mysql che corrisponde al tuo database mysql, poi rilancio lo script install_db<br>
wario
Linux 1.0
Linux 1.0
 
Messaggi: 36
Iscritto il: mer set 10, 2003 23:00


Torna a Slackware

Chi c’è in linea

Visitano il forum: Google [Bot] e 5 ospiti