Visibilita' del PC con BlueZ [Risolto]

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
punish3r
Linux 1.x
Linux 1.x
Messaggi: 107
Iscritto il: ven feb 04, 2005 0:00
Località: Orvieto
Contatta:

Visibilita' del PC con BlueZ [Risolto]

Messaggioda punish3r » mar gen 23, 2007 14:16

Ciao a tutti.
Come posso rendere visibile da una ricerca bluetooth un PC con installato Bluez e un adattatore usb per bluetooth?
Sapete il comando ?

Grazie :)
Ultima modifica di punish3r il lun feb 19, 2007 17:48, modificato 1 volta in totale.

Avatar utente
whites11
Linux 4.x
Linux 4.x
Messaggi: 1147
Iscritto il: ven set 30, 2005 13:54
Località: Udine

Messaggioda whites11 » mar gen 23, 2007 15:16

devi impostare a "enable" l'opzione iscan nel file /etc/bluetooth/hcid.conf

Avatar utente
l1q1d
Master
Master
Messaggi: 1862
Iscritto il: lun feb 21, 2005 0:00
Località: In uno spazio n-dimesionale
Contatta:

Messaggioda l1q1d » mar gen 23, 2007 16:39

hai seguito il mio how-to su wikislack sul bluetooth? c`e` una parte dello script di avvio fatta proprio per quello!!

Avatar utente
punish3r
Linux 1.x
Linux 1.x
Messaggi: 107
Iscritto il: ven feb 04, 2005 0:00
Località: Orvieto
Contatta:

Messaggioda punish3r » mar gen 23, 2007 19:53

grazie :)

Avatar utente
lennynero
Linux 3.x
Linux 3.x
Messaggi: 607
Iscritto il: lun mag 03, 2004 0:00
Nome Cognome: Luigi Picaro
Slackware: 14.2-x64
Kernel: 4.4.14
Desktop: xfce-4.12
Località: Salerno
Contatta:

Messaggioda lennynero » sab mar 10, 2007 20:56

raga ho installato tutti i pacchetti di bluez e kdebluetooth, ma quando do modprobe bluez o modprobe bluetooth non trova i moduli...

Avatar utente
whites11
Linux 4.x
Linux 4.x
Messaggi: 1147
Iscritto il: ven set 30, 2005 13:54
Località: Udine

Messaggioda whites11 » dom mar 11, 2007 13:55

modprobe è un comando che serve a caricare i moduli del kernel, che non sono inclusi nei pacchetti che tu dici, ma nel kernel appunto.
se non hai un sistema di caricamento dei moduli kernel automatico, allora dai un bel

Codice: Seleziona tutto

modprobe -l | grep bluetooth

così vedrai quali moduli hai disponibili sul tuo sistema

Avatar utente
lennynero
Linux 3.x
Linux 3.x
Messaggi: 607
Iscritto il: lun mag 03, 2004 0:00
Nome Cognome: Luigi Picaro
Slackware: 14.2-x64
Kernel: 4.4.14
Desktop: xfce-4.12
Località: Salerno
Contatta:

Messaggioda lennynero » dom mar 11, 2007 15:32

il punto è: xke io i moduli bluetooth e bluez nel kernel non li ho(non li trovo..?!?!?)?

Avatar utente
whites11
Linux 4.x
Linux 4.x
Messaggi: 1147
Iscritto il: ven set 30, 2005 13:54
Località: Udine

Messaggioda whites11 » dom mar 11, 2007 20:43

cioè il comando da me suggerito non ti torna alcun risultato?
hai un kernel compilato da te?
forse hai i moduli bluetooth messi come built-in nel kernel (dunque non serve caricarli, sono sempre caricati).
fai questa prova:

Codice: Seleziona tutto

su
hcid
sdpd

fai partire kdebluetoothd e provi a cercare il cellulare...magari va...

Avatar utente
lennynero
Linux 3.x
Linux 3.x
Messaggi: 607
Iscritto il: lun mag 03, 2004 0:00
Nome Cognome: Luigi Picaro
Slackware: 14.2-x64
Kernel: 4.4.14
Desktop: xfce-4.12
Località: Salerno
Contatta:

Messaggioda lennynero » lun mar 12, 2007 3:26

in effetti bluetooth era bluit-in l'ho messo come modulo, ora carica tutto, anche sdpd, anche se succede una cosa strana: all'avvio di kde appare un messaggio che dice che il server sdp non è partito dopo un pò scompare e in effetti il sevrer è paritto(anche xke nei files di confi si imposta il suo avvio...)

comunque a me adesso kdebluetoothd parte ma ha qualche problema(forse correlato al messaggio di sdp) l'icona in basso(la k) rimane bloccata e comunque non riesco a cercare il cell; comunque il modulo bluez non lo riesco a trovare nel kernel.

Avatar utente
d4z_c0nf
Packager
Packager
Messaggi: 1296
Iscritto il: mar mar 14, 2006 18:07
Nome Cognome: Rocco Aliberti
Slackware: 14.2-current64
Kernel: 4.14.73
Desktop: awesomeWM
Località: Pinerolo

Messaggioda d4z_c0nf » lun mar 12, 2007 9:36

lennynero ha scritto:in effetti bluetooth era bluit-in l'ho messo come modulo, ora carica tutto, anche sdpd, anche se succede una cosa strana: all'avvio di kde appare un messaggio che dice che il server sdp non è partito dopo un pò scompare e in effetti il sevrer è paritto(anche xke nei files di confi si imposta il suo avvio...)

comunque a me adesso kdebluetoothd parte ma ha qualche problema(forse correlato al messaggio di sdp) l'icona in basso(la k) rimane bloccata e comunque non riesco a cercare il cell; comunque il modulo bluez non lo riesco a trovare nel kernel.


scusa, potresti spiegarti un po' meglio...?!?