Problema Varicad con kernel 2.6.36

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
enzo.bak
Linux 1.x
Linux 1.x
Messaggi: 144
Iscritto il: lun apr 28, 2008 17:58
Località: Reggio Calabria

Problema Varicad con kernel 2.6.36

Messaggioda enzo.bak » mer nov 17, 2010 17:35

Ciao a tutti!
Ho un Aspire One con su una Slackware 12.2
Upgrado (quasi) regolarmente il kernel alle ultime versioni, curando però per sicurezza di lasciare qualche versione più vecchia.
Mi è successo di sperimentare che, con l'ultima versione del kernel, ovvero la 2.6.36, il programma Varicad (la versione che trovate nel repository della 12.2) non funziona più. Peggio, lanciandola, dopo avere visualizzato la schermata del programma, blocca completamente il computer. Ovvero non funziona più la tastiera, CTRL-ALT-ESC, il mouse, il caps-lock per intenderci, e l'unica maniera per uscirne è lo spegnimento brutale.
A parità di condizioni, lanciando il kernel 2.6.33, tutto funziona regolarmente.
Ho provato a ricompilare il 2.6.36 con il .config della 2.6.33 facendo un make oldconfig, ma il problema non si risolve.
Poichè non uso Varicad tutti i giorni :-) non so da che versione del kernel ha cominciato a presentare il problema, ovvero se versioni antecedenti la 2.6.36 e seguenti la 2.6.33 funzionino...

Comunque, nel frattempo posso usare il vecchio kernel se proprio devo usare Varicad, ma chiedo agli utenti del Forum:
Potreste, gentilmente, chi ha installato il Varicad, verificare se anche a voi presenta lo stesso problema?
Grazie mille, saluti a tutti,
Enzo.

enzo.bak
Linux 1.x
Linux 1.x
Messaggi: 144
Iscritto il: lun apr 28, 2008 17:58
Località: Reggio Calabria

Re: Problema Varicad con kernel 2.6.36

Messaggioda enzo.bak » gio nov 18, 2010 8:15

Aggiornamento:
Ho effettuato il "downgrade" alla 2.6.35.8
Tutto invariato con una eccezione: il puntatore del mouse continua a funzionare. Per il resto come prima.
Prossimo esperimento con la 2.6.34.7

Avatar utente
414N
Iper Master
Iper Master
Messaggi: 2899
Iscritto il: mer feb 13, 2008 16:19
Slackware: 14.2
Kernel: 4.4.19
Desktop: KDE4
Località: Bulagna
Contatta:

Re: Problema Varicad con kernel 2.6.36

Messaggioda 414N » gio nov 18, 2010 9:36

Per caso stai progettando qualcosa in 3D con Varicad?
Mi viene da pensare che il tuo server X su Slackware 12.2 possa avere problemi con i moduli DRM dei kernel più recenti, se non hai aggiornato anche mesa o i driver proprietari della scheda video...

enzo.bak
Linux 1.x
Linux 1.x
Messaggi: 144
Iscritto il: lun apr 28, 2008 17:58
Località: Reggio Calabria

Re: Problema Varicad con kernel 2.6.36

Messaggioda enzo.bak » gio nov 18, 2010 11:28

Per caso stai progettando qualcosa in 3D con Varicad?

No, anche se mi piacerebbe (tempo permettendo) impararne l'uso in 3D.
Allo stato attuale lo utilizzo per convertire qualche disegno passatomi da qualche collega in formato dwg (tipicamente Autocad), in formato dxf per poterlo aprire con QCad.
Ho fatto la prova con il kernel 2.6.34.7 e funziona regolarmente.
Quindi il problema sta a valle di questa versione.
Riguardo la tua ipotesi, non ho aggiornato nè mesa, nè i driver proprietari.
Ma, a meno che mesa non faccia parte della 12.2, riguardo i driver proprietari per la scheda video non ne ho mai installati, sia per evitare questo genere di problemi, sia per il fatto che la scheda video dell'Aspire One, con tutto il rispetto per questo eccezionale netbook, è quella che è!
Grazie dell'interessamento, vi terrò aggiornati sugli "sviluppi".

enzo.bak
Linux 1.x
Linux 1.x
Messaggi: 144
Iscritto il: lun apr 28, 2008 17:58
Località: Reggio Calabria

Re: Problema Varicad con kernel 2.6.36

Messaggioda enzo.bak » lun gen 10, 2011 17:06

Ho risolto il problema: posto la soluzione nel caso possa tornare utile a qualcun altro.
Ringrazio anzitutto 414N per i suoi suggerimenti: effettivamente il problema era proprio nelle librerie Mesa.
Non riuscendo a compilare la nuova versione delle stesse per uno strano problema, riscontrato anche da altri, con le librerie "talloc", alla fine ho seguito questa procedura:
1) Ho scaricato il package della 13.1 delle librerie Mesa. (formato txz)
2) Dopo avere installato la suite "xz" ho convertito, con uno script trovato in rete, il package dal nuovo formato "txz" al vecchio "tgz".
3) Ho effettuato, ovviamente da root, un removepkg della vecchia versione ed un installpkg della nuova.
Ho incrociato le dita, ho lanciato Varicad e... Olè, funziona di nuovo!

Avatar utente
414N
Iper Master
Iper Master
Messaggi: 2899
Iscritto il: mer feb 13, 2008 16:19
Slackware: 14.2
Kernel: 4.4.19
Desktop: KDE4
Località: Bulagna
Contatta:

Re: Problema Varicad con kernel 2.6.36

Messaggioda 414N » lun gen 10, 2011 17:19

Sono contento che ti funzioni.
Probabilmente l'errore di compilazione che citi è dovuto alla versione di GCC inclusa in Slackware 12.2.
Occhio a non adottare questa procedura estensivamente, perché rischi di andare incontro ad incompatibilità varie ed eventuali ;)