kernel 2.6.38 - Strano errore

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
enzo.bak
Linux 1.x
Linux 1.x
Messaggi: 144
Iscritto il: lun apr 28, 2008 17:58
Località: Reggio Calabria

kernel 2.6.38 - Strano errore

Messaggioda enzo.bak » gio mar 17, 2011 10:10

Upgradando dal precedente 2.6.37.3 all'attuale 2.6.38, senza introdurre alcuna modifica alla configurazione precedente (make oldconfig) ottengo un kernel regolare fino al login (testuale). Quando però lancio il server grafico con startx dopo alcuni secondi il sistema si blocca con lampeggio del led "Caps-lock".
Occorre spegnere brutalmente per uscire e, al successivo riavvio, vengono segnalati moltissimi errori (fortunatamente poi corretti) sia sul file system della partizione dove risiede il S.O. (per inciso SSD), che su eventuali schede SD montate in precedenza (al login testuale).
La versione di Slackware è la 12.2, con KDE 3.5
Ho rifatto 2 volte la compilazione (preceduta anche dal make clean) ma il difetto permane. Sono perciò tornato al 2.6.37.3.
Qualcun altro ha avuto problemi con questo nuovo kernel?
Saluti, Enzo.

Avatar utente
conraid
Staff
Staff
Messaggi: 13303
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: kernel 2.6.38 - Strano errore

Messaggioda conraid » gio mar 17, 2011 10:26

Io ho avuto uno strano errore durante lo spegnimento, messaggi a video con blocco del sistema. Tempo fa ebbi problemi simili al caricamento del sistema, ma venne fuori che era colpa di udev.

http://www.linuxquestions.org/questions ... en-852843/
http://www.edgrochowski.com/photos-lq/k ... -28-10.png

Ora sinceramente non so se è colpa del kernel o di qualche aggiornamento, per adesso è successo una sola volta.

Se a te succede sempre e sempre nello stesso punto devi provare a fare qualche debug. Parti con altri driver video, ricompilali, etc...

enzo.bak
Linux 1.x
Linux 1.x
Messaggi: 144
Iscritto il: lun apr 28, 2008 17:58
Località: Reggio Calabria

Re: kernel 2.6.38 - Strano errore

Messaggioda enzo.bak » gio mar 17, 2011 11:03

La macchina funzionava (e funziona) regolarmente con il 2.6.37.3
Ho preso l'abitudine (tempo permettendo) di upgradare il kernel alla versione immediatamente più recente in maniera da evitare che, upgradando a distanza di parecchie versioni, sia sempre più difficile riuscire a stabilire quale possa essere la novità introdotta che ha causato problemi.
Dovrei sicuramente esaminare meglio il comportamento della 2.6.38 sotto shell testuale ma, francamente, visto il tipo di problema (danni al file system), preferisco evitare questo genere di problematica sulla macchina con la quale lavoro.:-)
Conto di proseguire gli "studi" su altre macchine di prova...

Mario Vanoni
Iper Master
Iper Master
Messaggi: 3174
Iscritto il: lun set 03, 2007 21:20
Nome Cognome: Mario Vanoni
Slackware: 12.2
Kernel: 3.0.4 statico
Desktop: fluxbox/seamonkey
Località: Cuasso al Monte (VA)

Re: kernel 2.6.38 - Strano errore

Messaggioda Mario Vanoni » gio mar 17, 2011 16:35

Thread parallelo, vedi
Ricompilazione kernel: varie.

enzo.bak
Linux 1.x
Linux 1.x
Messaggi: 144
Iscritto il: lun apr 28, 2008 17:58
Località: Reggio Calabria

Re: kernel 2.6.38 - Strano errore

Messaggioda enzo.bak » ven mar 18, 2011 10:33

Poichè, come già detto in precedenza, la macchina (un Aspire One) utilizza un SSD, alquanto lento, ho voluto effettuare la prova di lanciare il server X (startx), non già subito dopo il login testuale, bensì dopo qualche minuto, per permettere al sistema di potere svolgere eventuali attività in sospeso con la SSD, cosa certamente vera in quanto dopo una decina di secondi dal login noto sempre una successiva attività del led corrispondente all'hard disk per una trentina di secondi.
Bene, il blocco della macchina con lampeggio del "Caps-lock" è avvenuto ugualmente ma, almeno, il successivo riavvio, pur segnalando giustamente la non corretta chiusura del file system, non ha rilevato errori.
Quindi, posso ragionevolmente supporre che il responsabile del problema sia il comparto grafico del kernel, che però non ho variato in alcun modo dalla precedente compilazione. Darò un'occhiata con "make menuconfig" se siano state introdotte novità di rilievo nelle sezioni video....

enzo.bak
Linux 1.x
Linux 1.x
Messaggi: 144
Iscritto il: lun apr 28, 2008 17:58
Località: Reggio Calabria

Re: kernel 2.6.38 - Strano errore

Messaggioda enzo.bak » sab mar 19, 2011 9:10

Thread parallelo, vedi
Ricompilazione kernel: varie.

Ho controllato quella opzione: di default è disabilitata. Abilitandola, si ottengono nuovamente gli errori sulla SSD, in ogni caso.
Per le opzioni video, ho provato a disabilitare il supporto per il framebuffer, ma il risultato è stato uguale.
Per ora mi tengo alla larga da questo kernel, nel frattempo provo con la 2.6.37.4 se va bene o se il cambiamento (ne dubito comunque) sia avvenuto là.

Avatar utente
robbybby
Linux 4.x
Linux 4.x
Messaggi: 1223
Iscritto il: sab dic 16, 2006 10:48
Slackware: 13.1 / 64 bit
Kernel: 3.3.x
Desktop: KDE 4.4.5
Località: Fra Trantor e Terminus

Re: kernel 2.6.38 - Strano errore

Messaggioda robbybby » sab mar 19, 2011 19:13

Che scheda video hai? E che driver video stai usando?

enzo.bak
Linux 1.x
Linux 1.x
Messaggi: 144
Iscritto il: lun apr 28, 2008 17:58
Località: Reggio Calabria

Re: kernel 2.6.38 - Strano errore

Messaggioda enzo.bak » sab mar 19, 2011 20:56

Che scheda video hai? E che driver video stai usando?

Quella integrata nell'Aspire One (ZG5), ovvero, dando un lspci:
Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphic Controller (rev 03)
che, nel precedente (e successivo) kernel ho configurato come
Intel 440LX/BX/GX, I8xx and E7x05 chipset support per quanto riguarda l'AGP support
ed invece come:
Intel 830M, 845G, 852GM, 855GM, 865G (i915 driver)
per il Direct Rendering Manager.

Ho sempre usato queste impostazioni sin dal 2.6.27 senza problemi.
Potrei fare qualche prova (a proposito, col 2.6.37.4 va tutto bene) anche se non mi spiego cosa ci sia di così "innovativo" nel 2.6.38, nelle sezioni video, da provocare questi difetti.
Ciao, Enzo.

Avatar utente
robbybby
Linux 4.x
Linux 4.x
Messaggi: 1223
Iscritto il: sab dic 16, 2006 10:48
Slackware: 13.1 / 64 bit
Kernel: 3.3.x
Desktop: KDE 4.4.5
Località: Fra Trantor e Terminus

Re: kernel 2.6.38 - Strano errore

Messaggioda robbybby » dom mar 20, 2011 20:48

Nel 2.6.38 è comparsa qualche opzione in più nella gestione della memoria, mi sembra qualcosa tipo la possibilità di compattare l'heap, o qualcosa del genere. Io proverei a dare un'occhiata a quello.
Sto usando il kernel 2.6.38 sul Slackware 13.1, con scheda nVidia da due, o tre giorni e, almeno finora, non ho avuto problemi. Ho gli effetti 3D di KDE attivati, e lo screensaver OpenGL, ch eogni tanto parte, senza problemi.

enzo.bak
Linux 1.x
Linux 1.x
Messaggi: 144
Iscritto il: lun apr 28, 2008 17:58
Località: Reggio Calabria

Re: kernel 2.6.38 - Strano errore

Messaggioda enzo.bak » lun mar 21, 2011 10:51

Nel 2.6.38 è comparsa qualche opzione in più nella gestione della memoria, mi sembra qualcosa tipo la possibilità di compattare l'heap, o qualcosa del genere. Io proverei a dare un'occhiata a quello.

Ho controllato, ma è disabilitata in quanto, facendo il make oldconfig, tutte le nuove opzioni vengono proposte nella forma meno "pericolosa".
Sto usando il kernel 2.6.38 sul Slackware 13.1

Poichè sono con la 12.2, ho il KDE 3.5. Unica prova che mi resta sarebbe provare il 2.6.38 su un'altra macchina "gemella" in cui però ho aggiornato, in maniera forzosa, le libreria MESA a quelle della 13.1, per precedenti problemi con Varicad...

Avatar utente
robbybby
Linux 4.x
Linux 4.x
Messaggi: 1223
Iscritto il: sab dic 16, 2006 10:48
Slackware: 13.1 / 64 bit
Kernel: 3.3.x
Desktop: KDE 4.4.5
Località: Fra Trantor e Terminus

Re: kernel 2.6.38 - Strano errore

Messaggioda robbybby » dom mar 27, 2011 22:31

enzo.bak ha scritto:Intel 830M, 845G, 852GM, 855GM, 865G (i915 driver)
per il Direct Rendering Manager.

E' uscito or ora il 2.6.38.2 che corregge due bug nel DRM per l'i915. Magari risolve il tuo problema.

enzo.bak
Linux 1.x
Linux 1.x
Messaggi: 144
Iscritto il: lun apr 28, 2008 17:58
Località: Reggio Calabria

Re: kernel 2.6.38 - Strano errore

Messaggioda enzo.bak » lun mar 28, 2011 19:12

Grazie della dritta!
Appena possibile farò la prova...
Per adesso, sono dovuto addirittura tornare al 2.6.34.8 per indagare su un subdolo problema rilevato (saltuarie sconnessioni) e con questa versione risolto. Appena il 2.6.37.x sarà (per me) nuovamente 100% ok passerò ai test con il 2.6.38.x!

Mario Vanoni
Iper Master
Iper Master
Messaggi: 3174
Iscritto il: lun set 03, 2007 21:20
Nome Cognome: Mario Vanoni
Slackware: 12.2
Kernel: 3.0.4 statico
Desktop: fluxbox/seamonkey
Località: Cuasso al Monte (VA)

Re: kernel 2.6.38 - Strano errore

Messaggioda Mario Vanoni » lun mar 28, 2011 21:23

Offtopic: kernel 2.6.38, 2.6.38.1 e 2.6.38.2
3 schermi Samsung BX2440 con prese DVI e VGA
2 macchine con scheda nvidia DVI
1 macchina con on-board intel VGA

i 3 kernel sulle macchine DVI sono perfetti

sulla macchina VGA il 2.6.38 e` perfetto
con i kernel 2.6.38.1 e 2.6.38.2 shell perfetta
X parte perfetto, ma uscendo da X, schermo non piu` usabile,
come se ogni segno si espandesse a "- - - - - ..." con \n multipli,
necessario un Ctrl-Alt-Del

la macchina VGA e` da cambiare presto con una DVI,
quindi posto solo per segnalare uno strano errore