Avvio netbook

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
-sf
Linux 2.x
Linux 2.x
Messaggi: 209
Iscritto il: ven lug 15, 2011 1:20
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE

Avvio netbook

Messaggioda -sf » mer lug 20, 2011 15:50

Ciao a tutti, mi ritrovo con un problema abbastanza singolare a cui non riesco venirne a capo...

Allora ho per le mani un netbook Acer di un amico a cui si è rotto l'HD.
Sostituito questo sono iniziati i problemi: per prima cosa all'avvio lo schermo resta nero (acceso, ma nero) come se non partisse nemmeno il bios.

Il netbook in questione ha una porta seriale per poter collegare un secondo monitor, pertanto ci siamo muniti di cavo e collegato il tutto; ora sullo schermo la schermata del bios parte, c'è la possibilità di modificare le varie impostazioni e riesce a fare il boot da chiavetta. Qui però arriva alla fine del boot ed è possibile utilizzare solo il terminale, "startx" sembra partire ma poi muore tutto.

Al di la dell'ambiente grafico che non parte (che è poi il meno), non capisco come mai anche la sola schermata del bios non viene visualizzata sullo schermo del netbook... Scheda video andata?

Qualche suggerimento?

Grazie!

Avatar utente
percoco2000
Linux 3.x
Linux 3.x
Messaggi: 630
Iscritto il: gio lug 15, 2004 0:00
Slackware: 12.2
Kernel: 2.6.27
Desktop: mate - fluxbox
Distribuzione: mint 13 / slackware
Località: Salerno

Re: Avvio netbook

Messaggioda percoco2000 » mer lug 20, 2011 18:37

Piu' che la scheda video e' probabile sia qualche problema del dispaly. Controlla bene i cavi.

Avatar utente
targzeta
Iper Master
Iper Master
Messaggi: 6538
Iscritto il: gio nov 03, 2005 14:05
Nome Cognome: Emanuele Tomasi
Slackware: 64-current
Kernel: latest stable
Desktop: IceWM
Località: Carpignano Sal. (LE) <-> Pisa

Re: Avvio netbook

Messaggioda targzeta » mer lug 20, 2011 19:20

Se non sbaglio gli Acer soffrono di questi problemi. Alla mia ragazza è successa la stessa cosa. L'unica cosa strana è che sia successo proprio in concomitanza con il cambio dell'HD.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà 

Bart
Staff
Staff
Messaggi: 4249
Iscritto il: lun ago 09, 2004 0:00
Località: Rimini

Re: Avvio netbook

Messaggioda Bart » mer lug 20, 2011 19:44

Se il problema fosse la scheda video non vedresti nulla nemmeno sul monitor collegato.

Akito
Linux 2.x
Linux 2.x
Messaggi: 285
Iscritto il: dom set 03, 2006 13:12
Nome Cognome: Alessandro Bianconi
Slackware: 13.1
Desktop: XFCE
Località: Limite sull'Arno (FI)

Re: Avvio netbook

Messaggioda Akito » mer lug 20, 2011 19:49

Non avrai rimontato/ricollegato qualcosa. Ormai ho perso il conto di quante volte ho aperto il mio Acer. Funziona sempre se non fosse per quel maledetto disco ssd che si è rivelato una vera schifezza (quello fornito con il netbook).

Offtopic: Domanda per la mia curiosità: come fa il netbook a capire che lo schermo è chiuso? Ricordo un vecchio portatile in cui c'era un vero e proprio bottoncino che potevo anche premere a mano. Sul mio non vedo niente di simile, immagino sia tutto interno.

Avatar utente
percoco2000
Linux 3.x
Linux 3.x
Messaggi: 630
Iscritto il: gio lug 15, 2004 0:00
Slackware: 12.2
Kernel: 2.6.27
Desktop: mate - fluxbox
Distribuzione: mint 13 / slackware
Località: Salerno

Re: Avvio netbook

Messaggioda percoco2000 » mer lug 20, 2011 21:18

Sul lato sinistro del monitor, vi e' un piccolo magnete che fa' chuidere un contatto "reed" all'interno della base.

Avatar utente
targzeta
Iper Master
Iper Master
Messaggi: 6538
Iscritto il: gio nov 03, 2005 14:05
Nome Cognome: Emanuele Tomasi
Slackware: 64-current
Kernel: latest stable
Desktop: IceWM
Località: Carpignano Sal. (LE) <-> Pisa

Re: Avvio netbook

Messaggioda targzeta » mer lug 20, 2011 21:31

Offtopic:
percoco2000 ha scritto:Sul lato sinistro del monitor, vi e' un piccolo magnete che fa' chuidere un contatto "reed" all'interno della base.

Siamo offtopic. Comunque in tutti quelli che ho smontato io ho sempre trovato il classico bottoncino che si preme alla chiusura del monitor. Interno se vuoi, ma sempre bottoncino era :)

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà 

Akito
Linux 2.x
Linux 2.x
Messaggi: 285
Iscritto il: dom set 03, 2006 13:12
Nome Cognome: Alessandro Bianconi
Slackware: 13.1
Desktop: XFCE
Località: Limite sull'Arno (FI)

Re: Avvio netbook

Messaggioda Akito » mer lug 20, 2011 23:10

Offtopic: Interessante!

Avatar utente
-sf
Linux 2.x
Linux 2.x
Messaggi: 209
Iscritto il: ven lug 15, 2011 1:20
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE

Re: Avvio netbook

Messaggioda -sf » gio lug 21, 2011 13:21

Quindi escludendo un problema di scheda video cosa potrei guardare?
Lo schermo in se si accende, ma rimane comunque nero senza dare segni di vita.

Un flash del bios potrebbe risolvere qualcosa? La macchina in questione ha gia qualche anno sulle spalle, forse Acer stessa ha rilasciato nuove versioni del bios.

Akito
Linux 2.x
Linux 2.x
Messaggi: 285
Iscritto il: dom set 03, 2006 13:12
Nome Cognome: Alessandro Bianconi
Slackware: 13.1
Desktop: XFCE
Località: Limite sull'Arno (FI)

Re: Avvio netbook

Messaggioda Akito » gio lug 21, 2011 14:57

Prima di aggiornare il bios proverei a togliere le modifiche fatte: proverei ad avviarlo senza disco e poi con quello vecchio. Il portatile di mio padre non riconosce dischi rigidi con dimensioni superiori ad un certo quantitativo di gb anche se va detto che sul forum di HP alcuni sostengono che dipenda non solo dal taglio, ma anche dal produttore/modello. Comunque nel mio caso il computer si avviava con il suo display, semplicemente non risultava collegato nessun disco rigido.

Tra le altre cose non capisco come tutto questo interessi startx. Prova a riportare qualche informazione in più, la prima cosa che mi viene in mente è qualche errore di configurazione.

Sul mio c'è un cavetto a nastro molto sottile che collega la scheda madre del netbook al display. Controlla il tuo collegamento.


Domanda: e' possibile controllare i due schermi senza che X sia avviato? Intendo spengerne uno ed accendere l'altro, ecc...non capisco perchè lo schermo del netbook rimanga attivo anche mentre stai usando l'altro (preciso che le poche volte in cui ho usato uno schermo in più sul portatile, X era avviato ed usavo l'utility xrandr). Non mi sembra del tutto offtopic.

Avatar utente
-sf
Linux 2.x
Linux 2.x
Messaggi: 209
Iscritto il: ven lug 15, 2011 1:20
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE

Re: Avvio netbook

Messaggioda -sf » gio lug 21, 2011 20:23

Il vecchio HD ha fatto il suo tempo, credo si sia rotto qualcosa all'interno...

Comunque al di la del tipo di disco la schermata iniziale del bios dovrebbe comunque comparire no?
Nel mio caso lo schermo del netbook si accende ma non compare nulla; se invece collego alla porta seriale un'altro monitor visualizzo la schermata del bios e posso modificare le solite cose.
Dal bios comunque l'hd viene rilevato.

Per il comando startx ho provato solo una volta con una live, ma x non partiva; anche in questo caso schermo nero e nessun errore (visualizzato).
Comunque per quello credo sia più un problema di x in quanto appena accendi il computer tutta la fase di boot è visibile e al login testuale tutto funziona correttamente.

Infine il cavetto l'ho controllato più volte: è ben inserito e fermo...

:-k

Akito
Linux 2.x
Linux 2.x
Messaggi: 285
Iscritto il: dom set 03, 2006 13:12
Nome Cognome: Alessandro Bianconi
Slackware: 13.1
Desktop: XFCE
Località: Limite sull'Arno (FI)

Re: Avvio netbook

Messaggioda Akito » ven lug 22, 2011 0:34

Comunque al di la del tipo di disco la schermata iniziale del bios dovrebbe comunque comparire no


Se è per questo allora anche il tuo display dovrebbe funzionare, no? Hai cambiato _solo_ il disco.
Io non ho idea del perchè non funzioni, dicevo solo che la cosa più naturale da fare e che io avrei fatto era far partire il netbook senza disco e/o con quello vecchio. Lo riporto a prima che si verificasse il problema. Se questa prova che contiene più speranza che logica fallisce (sempre più logica però che aggiornare il bios, a mio parere la giocherei proprio come ultima carta) allora inizio davvero a sospettare qualche guasto serio come diceva spina.

Per la storia di startx chiedevo come è possibile gestire gli schermi senza utility come xrandr altrimenti devi far partire X. Io non so come fare e qualcuno magari ti può aiutare. La mia idea era di forzare l'uso di uno dei due schermi e vedere cosa succede. Il fatto è che quando imposto solo quello esterno posso far spengere quello interno. Il tuo rimane acceso: io per curiosità proverei a forzare via software lo schermo a spengersi o a fare da clone per sapere cosa sta veramente facendo (o meglio cosa vorrei che stesse facendo).

Avatar utente
-sf
Linux 2.x
Linux 2.x
Messaggi: 209
Iscritto il: ven lug 15, 2011 1:20
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE

Re: Avvio netbook

Messaggioda -sf » mer lug 27, 2011 19:44

Allora sono finalmente riuscito a far girare una live di Slax usando un monitor esterno...

Funziona tutto, ma solo in modalità testuale: se avvio X il monitor esterno si spegne e quello del netbook rimane sempre spento. Tuttavia ho sentito il suono del login quindi credo che X si avvii, anche se io non visualizzo nulla... probabilmente andranno settati dei parametri particolari nei file di configurazione di X.

Il problema però persiste, se avvio il tutto senza collegare il monitor esterno lo schermo del netbook si accende ma rimane nero; se invece lo accendo con il cavo del monitor esterno inserito il netbook rimane spento del tutto (giustamente) e riesco a vedere tutto ma non ad avviare X (o almeno, X credo si avvii, ma lo schermo rimane spento).

A sto punto credo sia un problema di schermo del netbook, la scheda video dovrebbe essere ok visto che comunque la porta seriale funziona a dovere.

Che faccio?
Mi rimane solo portarlo in assistenza?

erio
Linux 4.x
Linux 4.x
Messaggi: 1202
Iscritto il: ven ott 09, 2009 19:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: Avvio netbook

Messaggioda erio » mer lug 27, 2011 20:31

dopo il log in prova a dare xconf e poi startx,tentare non nuoce.

Avatar utente
-sf
Linux 2.x
Linux 2.x
Messaggi: 209
Iscritto il: ven lug 15, 2011 1:20
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE

Re: Avvio netbook

Messaggioda -sf » gio lug 28, 2011 12:36

EDIT: sono riuscito a far partire X sul monitor esterno, ora funziona tutto perfettamente: hardware riconosciuto etc...

Tra l'altro ora lo schermo del netbook, pur avendo il monitor attaccato, si accende (prima si spegneva del tutto) ma rimane comunque su una schermata nera senza dare segni di vita.

A sto punto credo sia un problema di schermo...