[SOLVED] Mutt e blocco

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
Linpassion
Linux 2.x
Linux 2.x
Messaggi: 205
Iscritto il: mar ott 30, 2012 11:17
Slackware: 14.0
Kernel: 3.2.9-smp
Desktop: fluxbox

[SOLVED] Mutt e blocco

Messaggioda Linpassion » gio giu 09, 2016 18:51

Scrivo perche ho un altro problema con mutt, cioè quando compongo una mail piuttosto lunga, o con nano o con emacs, al termine della composizione mutt si blocca. O schemrmata bianche (se uso nano) o si blocca all'invio (se uso emacs).
Prima pensavo che fosse perche navigavo con la chiave, ma anche con l'adsl si ripropone il problema.
Questa è la mia configurazione per uno degli account

# Impostazione mailbox
set mbox_type = maildir
set mbox = "~/.mutt/posta-personale/inbox/"
set spoolfile = "~/.mutt/posta-personale/inbox/"
set folder = "~/.mutt/posta-personale/"
set record = "~/.mutt/posta-personale/sent/"
set postponed = "~/.mutt/posta-personale/postponed/"

# Impostazione intervallo di controllo posta
set check_new = yes
set timeout = 15
set mail_check = 60
set imap_keepalive = 300

# Impostazione SSL
set ssl_starttls=yes
set ssl_force_tls=yes
unset imap_passive
set imap_check_subscribed

# Credenziali di login
set from = account@gmail.com
set realname = "utente"
set use_from = yes
set envelope_from = yes

# Impostazioni IMAP
set imap_user = indirizzo gmail
set imap_pass = "password"
# Impostazioni SMTP
set smtp_url = smtp://account@smtp.gmail.com:587/
set smtp_pass = "password"

# Impostazioni percorsi
set folder = imaps://imap.gmail.com:993
set spoolfile = "+INBOX"
set record = "+[Gmail]/Posta inviata"
set postponed = "+[Gmail]/Bozze"


set header_cache = ~/.mutt/posta-personale/headers
set message_cachedir = ~/.mutt/posta-personale/chace/bodies
set certificate_file = ~/.mutt/pqosta-personale/certificates
set move = no

# Impostazione dell'editor di composizione mail
set editor = "emacs"

# Sincronizzazione con la ribrica abook
bind editor <space> noop
set query_command = "abook --mutt-query '%s'"
macro index a "|abook --add-email\n" 'aggiunge mittente ad abook'
macro pager a "|abook --add-email\n" 'aggiunge mittente ad abook'


# configurazione tasti di navigazione con le directory
# remote di Gmail
bind editor <space> noop
macro index <f1> "<change-folder>+INBOX<enter>" "Posta in arrivo"
macro index <f2> "<change-folder>+[Gmail]/Posta inviata<enter>" "Posta inviata"
macro index <f3> "<change-folder>+[Gmail]/Bozze<enter>" "Bozze"
macro index <f4> "<change-folder>+[Gmail]/Tutti i messaggi<enter>" "Tutti i messaggi"
macro index <f5> "<change-folder>+[Gmail]/Spam<enter>" "Spam"
macro index <f6> "<change-folder>+[Gmail]/Cestino<enter>" "Cestino"
macro index <f7> "<save-message>+[Gmail]/Cestino<enter><sync-mailbox>" "Sposta in cestino"

# Impostazione di colori
# Primo colore testo, secondo colore sfondo
color normal yellow black
## menu
color status yellow blue
color error red black
## messaggi segnati come D - cancellati
color index red black ~D
## messaggi letti segnati com R - da leggere
color index green black ~R


dal menu di fluxbox lo invoco cosi
[exec] (o- E-mail > personale) {xterm -geometry 100x30+30+30 -fn 10x20 -e mutt -F ~/.mutt/personale}

magari mi sfugge qualcosa
Ultima modifica di Linpassion il sab giu 18, 2016 8:34, modificato 1 volta in totale.

Avatar utente
conraid
Staff
Staff
Messaggi: 13296
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: Mutt e blocco

Messaggioda conraid » ven giu 10, 2016 10:34

Piuttosto lunga cosa intendi? Si blocca quindi tra il passaggio da editor a client?

Io uso vim, anzi neovim, come editor, e non ho avuto problemi, ma non ricordo quand'è che ho inviato mail "lunghe".

Prova neomutt se puoi, ha varie patch comprese nel codice.

Avatar utente
Linpassion
Linux 2.x
Linux 2.x
Messaggi: 205
Iscritto il: mar ott 30, 2012 11:17
Slackware: 14.0
Kernel: 3.2.9-smp
Desktop: fluxbox

Re: Mutt e blocco

Messaggioda Linpassion » ven giu 10, 2016 17:00

lunga nel senso di piu di 5 righe. se è un breve messaggio e veloce ne digitalizzare sicon nano che emacs nn da problemi. Ma se sono nell'editor di composizione piu di un minuto, una volta uscito salvando il contenunto in tmp, l'invio si blocca. provero come dici tu.

Avatar utente
Linpassion
Linux 2.x
Linux 2.x
Messaggi: 205
Iscritto il: mar ott 30, 2012 11:17
Slackware: 14.0
Kernel: 3.2.9-smp
Desktop: fluxbox

Re: Mutt e blocco

Messaggioda Linpassion » sab giu 11, 2016 8:59

ho provato con vim ma sempre uguale

Avatar utente
conraid
Staff
Staff
Messaggi: 13296
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: Mutt e blocco

Messaggioda conraid » sab giu 11, 2016 10:08

Io ho provato adesso con neomutt e funziona normalmente anche con mail lunga e durata più di un minuto. Non installato mutt normale in questo momento.

Però se il problema è il salvataggio il problema potrebbe essere altrove, prova ad impostare per esempio tmpdir in una directory della home, ma lo dico così per provare, non so come è configurato il tuo sistema. Poi magari prova da altro utente senza alcune impostazione personale e vedi che comportamento ha.

Nel bug report hai guardato?

Avatar utente
Linpassion
Linux 2.x
Linux 2.x
Messaggi: 205
Iscritto il: mar ott 30, 2012 11:17
Slackware: 14.0
Kernel: 3.2.9-smp
Desktop: fluxbox

Re: Mutt e blocco

Messaggioda Linpassion » mar giu 14, 2016 15:41

ho impostato una nuova temp dir e fatto il testo con un utente di prova. il problema permane. Se scrivo due righe, poi lascio aperto vim per qualche minuto e poi riprendo, salvato il messaggio all'invio mutt va in stalli.

Avatar utente
conraid
Staff
Staff
Messaggi: 13296
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: Mutt e blocco

Messaggioda conraid » mer giu 15, 2016 11:04

Ho provato ora, ho lasciato neovim aperto mentre componeva la mail per neomutt (io uso queste due versioni alternative, che sono lo stesso codice più alcune patch) mentre aggiornavo la current con slackpkg, al ritorno ho salvato ed inviato normalmente.

Avatar utente
Linpassion
Linux 2.x
Linux 2.x
Messaggi: 205
Iscritto il: mar ott 30, 2012 11:17
Slackware: 14.0
Kernel: 3.2.9-smp
Desktop: fluxbox

Re: Mutt e blocco

Messaggioda Linpassion » sab giu 18, 2016 8:33

Sembra che ho risolto! Bastava impostare imap_imapkeep alive a 90 oppure a 60. Utile per la risoluzone è stato andare sul canale #mutt di freenode.

Avatar utente
conraid
Staff
Staff
Messaggi: 13296
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: [SOLVED] Mutt e blocco

Messaggioda conraid » sab giu 18, 2016 8:42

Bene, buono a sapersi. Io ho 300, il default è 900, e come detto non sembrano esserci problemi.