Pagina 1 di 1

filezilla e errore in gnutls_priority_set_direct [RISOLTO]

Inviato: gio set 27, 2018 14:24
da conraid
Dopo l'ultimo aggiornamento in current con gnutls-3.6.4 ho questo errore quando accedo ad alcuni server

Codice: Seleziona tutto

Errore:   Errore GnuTLS -50 in gnutls_priority_set_direct: La richiesta non è valida.
Errore:   Non è stato possibile inizializzare TLS.
Errore:   Impossibile collegarsi al server


Impostando sftp va (se il server supporta la modalità), con gftp va anche in ftp.
Cosa può essere?
Cercando in rete ho trovato poco. La cosa che mi fa pensare è che hanno interotto il supporto a tls1.0, ma almeno un server so per certo che ha anche tls 1.1 e 1.2

Nella documentazione di proftpd vedo questo

Question: My FTPS client has trouble connecting to proftpd using SSL/TLS, with the following error appearing in the TLSLog:

mod_tls/2.1.2[9628]: TLS/TLS-C requested, starting TLS handshake
mod_tls/2.1.2[9628]: unable to accept TLS connection: received EOF that violates protocol
mod_tls/2.1.2[9628]: TLS/TLS-C negotiation failed on control channel

Is this a bug in mod_tls, in the client, or something else?

Answer: There might be several different causes for this error. It could be a bug in the OpenSSL library, in mod_tls, in the FTPS client, or it could be a transient network issue.

The usual culprit for the above error is an FTP-aware network device such as a NAT, router, or firewall between the client and the server. Such network devices "peek" into the FTP control connection in order to dynamically open the necessary ports for data transfers. However, this "peeking" fails once an SSL/TLS handshake starts on that same control connection, and when that happens, these network devices usually terminate the control connection, resulting in the EOF ("end of file") error reported.

Re: filezilla e errore in gnutls_priority_set_direct

Inviato: gio set 27, 2018 14:38
da conraid
Forse gftp va in chiaro senza tls, anche filezilla se disabilitp tls va.

Re: filezilla e errore in gnutls_priority_set_direct

Inviato: gio set 27, 2018 14:40
da conraid
Filezilla precompilato scaricato dal loro sito va, quindi è proprio problema di gnutls aggiornato :/

Naturalmente ho provato a ricompilarlo.

Re: filezilla e errore in gnutls_priority_set_direct

Inviato: gio set 27, 2018 17:36
da conraid
Vedo problemi simili al mio anche prima, e colpa della compilazione sembra

https://forum.filezilla-project.org/vie ... hp?t=26223

Re: filezilla e errore in gnutls_priority_set_direct

Inviato: gio set 27, 2018 17:59
da conraid
Ho reinstallato gnutls-3.6.3-1 (la 2 con la patch non ce l'ho, questa l'avevo in un iso fatta per qemu) e filezilla funziona :/

Re: filezilla e errore in gnutls_priority_set_direct

Inviato: gio set 27, 2018 18:43
da ponce
conraid ha scritto:Ho reinstallato gnutls-3.6.3-1 (la 2 con la patch non ce l'ho, questa l'avevo in un iso fatta per qemu) e filezilla funziona :/

questo mirror, segnalato da zerouno su LQ, ha anche tutti i vecchi pacchetti, come suggeriva probabilmente perche' non usano l'opzione --delete di rsync

http://slackmirror.cbpf.br/pub/slackwar ... 4-current/

Re: filezilla e errore in gnutls_priority_set_direct

Inviato: gio set 27, 2018 18:43
da conraid
Ho trovato un repository non aggiornato, e funziona anche con 3.6.3-2 con la patch ssl
https://mirror.math.princeton.edu/pub/s ... ackware/n/

Re: filezilla e errore in gnutls_priority_set_direct

Inviato: gio set 27, 2018 18:44
da conraid
ponce ha scritto:
conraid ha scritto:Ho reinstallato gnutls-3.6.3-1 (la 2 con la patch non ce l'ho, questa l'avevo in un iso fatta per qemu) e filezilla funziona :/

questo mirror, segnalato da zerouno su LQ, ha anche tutti i vecchi pacchetti, come suggeriva probabilmente perche' non usano l'opzione --delete di rsync

http://slackmirror.cbpf.br/pub/slackwar ... 4-current/


uh bello, come quello giapponese che c'era anni fa

Re: filezilla e errore in gnutls_priority_set_direct

Inviato: gio set 27, 2018 18:45
da conraid
Ora sto provando a fare un pacchetto statico, anche se è inutile, a quel punto uno prende il precompilato da loro.

Come potrei fare per usare solo gnutls statico?

Re: filezilla e errore in gnutls_priority_set_direct

Inviato: ven ott 19, 2018 19:32
da conraid
La 3.38.0-rc1 risolve il problema.