Pagina 6 di 8

Re: Slackyd: Rinascita!

Inviato: mer mag 18, 2011 15:43
da ZeroUno
io non applico nulla, lo lascio fare all'autore. Io propongo solamente e quando uscirà come release (1.0.1) allora pacchettizzerò (se qualcuno non lo fa prima di me).

Comunque quella che ho fatto è una bozza giusto per far capire cosa intendevo, e per toccare meno possibile il codice. Si può di sicuro far di meglio.

Re: Slackyd: Rinascita!

Inviato: mer mag 18, 2011 15:52
da shark1500
Sisi, infatti l'ho capito, poi ci guardero` meglio, ad ogni modo se ti senti in grado di fare la patch non ho alcun problema ad applicarla al codice su github con il tuo nome (se ti interessa)

Re: Slackyd: Rinascita!

Inviato: mer mag 18, 2011 18:07
da ZeroUno
Meglio una patch ben fatta che il mio nome da qualche parte.
Vedi la patch dell'md5 o quella del wget. Le originali le ho fatte io, ma quello che è rimasto dentro il codice di mio è solo l'idea, e ne sono contento perchè le parti che avevo scritto io era una accozzaglia disordinata (fondamentalmente non posso dire di conoscere il C come si deve; ma google si ;-), e mi posso vantare di conoscere bene il copia-incolla). E' stata rielaborata l'idea, riscritto il codice ed integrato nei punti più giusti e ordinati.

Re: Slackyd: Rinascita!

Inviato: gio mag 19, 2011 23:34
da Blallo
Ho riscontrato un errore: non scarica glibmm

Codice: Seleziona tutto

Download gtkmm-2.24.0-x86_64-1sl.txz [from slacky] ? [y/N] y
>> Required atkmm >= 2.22.4 [by gtkmm-2.24.0-x86_64-1sl.txz]
Download atkmm-2.22.4-x86_64-1sl.txz [from slacky] ? [y/n] y
** Warning: missing glibmm >= 2.27.99.2 required by atkmm
>> Required libsigc++ >= 2.2.9 [by atkmm-2.22.4-x86_64-1sl.txz]
Download libsigc++-2.2.9-x86_64-1sl.txz [from slacky] ? [y/n] y
>> Required cairomm >= 1.9.8 [by gtkmm-2.24.0-x86_64-1sl.txz]
Download cairomm-1.9.8-x86_64-1sl.txz [from slacky] ? [y/n] y
** Warning: missing glibmm >= 2.27.99.2 required by gtkmm
>> Required pangomm >= 2.28.1 [by gtkmm-2.24.0-x86_64-1sl.txz]
Download pangomm-2.28.1-x86_64-1sl.txz [from slacky] ? [y/n] y
** Warning: missing glibmm >= 2.27.99.2 required by pangomm

Problema di mirror o di slackyd?

Re: Slackyd: Rinascita!

Inviato: ven mag 20, 2011 10:21
da shark1500
Penso che sia un problema di mirror. Ho provato a scaricare le glibmm dal mirror della 13.1 e funziona perfettamente

Re: Slackyd: Rinascita!

Inviato: sab mag 28, 2011 21:49
da zoros
problema: ho installato alcuni txz della 13.1 per errore sulla 13.37 ... slackyd non mi scarica quelli nuovi, exempio

Codice: Seleziona tutto

bash-4.1# slackyd -l audacity

Installed packages "audacity": 1

 -> audacity-1.3.12_beta-i486-3sl

bash-4.1#


Codice: Seleziona tutto

bash-4.1# slackyd -g audacity

Searching audacity-1.3.13: found 1 package.

audacity-1.3.13-i486-3sl.txz [from slacky]

*** audacity-1.3.13-i486-3sl.txz: already installed (audacity-1.3.12_beta-i486-3sl).

All packages available are installed.



devo rimuovere quello installato e poi scarica ... sarebbe più comodo se scarica comunque, così si usa upgradepkg ...

Re: Slackyd: Rinascita!

Inviato: sab mag 28, 2011 22:34
da ZeroUno
Hai provato con il parametro -I ?

matteo@matteo:~$ slackyd -g slackyd

Searching slackyd: found 1 package.

slackyd-0.1.13.3beta-x86_64-1sl.txz [from slacky]

*** slackyd-0.1.13.3beta-x86_64-1sl.txz: already installed (slackyd-1.0-x86_64-1sl).

All packages available are installed.

matteo@matteo:~$ slackyd -I -g slackyd

Searching slackyd: found 1 package.

slackyd-0.1.13.3beta-x86_64-1sl.txz [from slacky]

Download slackyd-0.1.13.3beta-x86_64-1sl.txz [from slacky] ? [y/N]

Re: Slackyd: Rinascita!

Inviato: sab mag 28, 2011 23:04
da zoros
sì, funziona, ho messo 4 repository nel mio conf:

Codice: Seleziona tutto

bash-4.1# slackyd -I -g audacity

Searching audacity: found 4 packages.

audacity-1.3.9-i486-1sl.txz [from slacky1]
audacity-1.3.8-i486-1sl.tgz [from slacky2]
audacity-1.3.13-i486-3sl.txz [from slacky]
audacity-1.3.13-i486-1sl.txz [from slacky0]

Found 4 different version of audacity:
 --> audacity-1.3.9-i486-1sl.txz
 --> audacity-1.3.8-i486-1sl.tgz
 --> audacity-1.3.13-i486-3sl.txz
 --> audacity-1.3.13-i486-1sl.txz
Download audacity-1.3.9-i486-1sl.txz [from slacky1] ? [y/N] n
Download audacity-1.3.8-i486-1sl.tgz [from slacky2] ? [y/N] n
Download audacity-1.3.13-i486-3sl.txz [from slacky] ? [y/N] y

Downloading audacity-1.3.13-i486-3sl.txz. [Already downloaded]
* Verify md5 checksum: ok.

thanks ZeroUno

slackyd -h in effetti segnala lo switch -I ... mi sono fidato della pagina di help: http://slacky.eu/~dani/slackyd/ citata in home-community: http://www.slacky.eu/index.php?option=c ... 0&Itemid=1 ... che evidentemente è incompleta così come quella derivata nel wiki :(

Re: Slackyd: Rinascita!

Inviato: dom mag 29, 2011 0:19
da zoros
ripensandoci,

però sono comunque "insoddisfatto", nel mio post precedente:

Codice: Seleziona tutto

...
*** audacity-1.3.13-i486-3sl.txz: already installed (audacity-1.3.12_beta-i486-3sl)

slackyd mi dice che il pacchetto è già installato, malgrado la versione installata sia numericamente inferiore ... ciò crea confusione :roll: ...

Re: Slackyd: Rinascita!

Inviato: mer giu 08, 2011 13:42
da Loris
Cosa vi dice il comando?

Codice: Seleziona tutto

slackyd -g perl-tk

il pacchetto è presente nel repository ma non viene trovato :-k

Re: Slackyd: Rinascita!

Inviato: mer giu 08, 2011 13:52
da Blallo
anche io non lo trovo :(

Re: Slackyd: Rinascita!

Inviato: mer giu 08, 2011 15:12
da hashbang

Codice: Seleziona tutto

$ slackyd -g perl-tk

Searching perl-tk: found 1 package.

perl-tk-804.029-i486-3sl.txz [from slacky]

Download perl-tk-804.029-i486-3sl.txz [from slacky] ? [y/N]


A me lo trova.... :-k

Re: Slackyd: Rinascita!

Inviato: mer giu 08, 2011 15:16
da Blallo
ah, ma io sono su 64 bit...

Re: Slackyd: Rinascita!

Inviato: mer giu 08, 2011 16:49
da shark1500
Anche a me lo trova..loris, sei su 32bit?

Re: Slackyd: Rinascita!

Inviato: mer giu 08, 2011 21:18
da ZeroUno
ZeroUno ha scritto:

Codice: Seleziona tutto

diff -ur src-orig/func.c src/func.c
.....

# slackyd
Usage: ./slackyd <options> <package>

Options:
...
-t: Specify a path to download packages


# slackyd -t /tmp -g ssldump


Ho corretto la patch (un bug che non faceva identificare correttamente il path del pacchetto nella verifica dell'md5).
Allego anche lo slackbuild e il pacchetto per chi lo vuole provare.



Ma alla fine è stato più messo sotto github?

P.S: questo topic piuttosto che in "Programmazione" dovrebbe essere in "Packages"