Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] flash in blu (driver nvidia proprietari)

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: [RISOLTO] flash in blu (driver nvidia proprietari)

Messaggioda ZeroUno » ven feb 22, 2013 8:58

Oggi l'aggiornamento a current aggiorna X11

Dovrò ripacchettizzare nvidia si, ma nel frattempo chi fa l'upgrade si ricordi che deve rilanciare lo script di post-install di nvidia perchè alcune librerie vengono sovrascritte.

Codice: Seleziona tutto
# cd /
# bash /var/log/scripts/nvidia-linux-313.09-x86_64-1sl

(è tutto scritto in /usr/doc/nvidia-linux-*/NVIDIA.Slackware)
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4253
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: [RISOLTO] flash in blu (driver nvidia proprietari)

Messaggioda Trotto@81 » ven feb 22, 2013 14:49

Grazie per la gradita nota di servizio. :D
Avatar utente
Trotto@81
Iper Master
Iper Master
 
Messaggi: 2978
Iscritto il: ven giu 25, 2004 23:00
Località: Monasterace M. (RC)
Nome Cognome: Andrea
Slackware: Slackware64 14.1
Kernel: default
Desktop: KDE 4.10.5

Re: [RISOLTO] flash in blu (driver nvidia proprietari)

Messaggioda ZeroUno » ven feb 22, 2013 17:21

Problema con l'aggiornamento di X: viewtopic.php?f=1&t=36698&p=328897#p328897

A voi lo fa?
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4253
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: [RISOLTO] flash in blu (driver nvidia proprietari)

Messaggioda tornadomig » mer feb 27, 2013 21:11

@ZeroUno

ciao!

e' previsto un pacchetto compat32 per i 310.32? o conviene prendere i 310.09 dal tuo repo?

grazie! ;)
rm -rf / && rm -rf . && rm -rf *
Avatar utente
tornadomig
Linux 2.4
Linux 2.4
 
Messaggi: 481
Iscritto il: gio set 30, 2010 14:17
Nome Cognome: giorgio
Slackware: -current64&14.1
Kernel: 3.10.30
Desktop: KDE-4.11.5
Distribuzione: gentoo, funtoo, arch

Re: [RISOLTO] flash in blu (driver nvidia proprietari)

Messaggioda ZeroUno » gio feb 28, 2013 12:03

in verità aspettavo l'aggiornamento della serie 313 che è quella che sto usando.
Non ho molto tempo e sono in current. Dei compat uso ancora i 310.19 nonostante uso 313.09 a x64. In verità dovrei anche aggiornare il pacchetto compat32-libraries che è vecchio per current.
L'idea era quella di installare un chroot, ma non ho proprio tempo. Già è tanto che ho doppio kernel (quello di stable e quello di current).

Comunque dal changelog della 310.32 mi sembrava ci fosse non molto di importante, per questo non ho aggiornato. Il fatto è che dovevo fare un po' di variazioni allo slackbuild.
Mo' di penso.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4253
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: [RISOLTO] flash in blu (driver nvidia proprietari)

Messaggioda tornadomig » gio feb 28, 2013 14:15

@01

ok grazie, tienici aggiornati :thumbright:
rm -rf / && rm -rf . && rm -rf *
Avatar utente
tornadomig
Linux 2.4
Linux 2.4
 
Messaggi: 481
Iscritto il: gio set 30, 2010 14:17
Nome Cognome: giorgio
Slackware: -current64&14.1
Kernel: 3.10.30
Desktop: KDE-4.11.5
Distribuzione: gentoo, funtoo, arch

Re: [RISOLTO] flash in blu (driver nvidia proprietari)

Messaggioda ZeroUno » mer mar 27, 2013 15:46

Scusate l'assenza ma ultimamente sono un po' impegnato. Sto rifacendo il pacchetto (per current ma che dovrebbe funzionare anche per stable) perchè il precedente non compila (a meno di escamotage) su kernel >= 3.7.10
Stò facendo quello della 313.26 (non ho tempo di stare dietro a 2 versioni per ora).

Sto cercando di migliorarlo un po'. Ecco quello che ho fatto finora.

1) Ho praticamente riscritto NVIDIA.Slackware aggiungendo e ordinando diverse importanti note, solo che avrei bisogno di qualcuno che mi desse una mano con la traduzione che fa un po' schifetto, e magari anche sulla forma. Questo file da anche una indicazione di come è il pacchetto
Codice: Seleziona tutto
Slackware Notes:

This version of NVIDIA driver is taken from the original site:
NVIDIA-Linux-x86_64-313.26.run
or
NVIDIA-Linux-x86-313.26.run

The package contains only precompiled libraries so the package should works with
slackware current even if the package was built on a slackware 14.0 and
viceversa (but read the 'Kernel Module' section below)

This package does NOT install the vdpau module. You need it for some
multimedial feature.

You can choose to install libvdpau 0.5 or the nvidia-vdpau package (same
version of nvidia-linux package) that you may find in the same repository.

== SPECIAL NOTES ==

1. Kernel Module
1.1. Prebuilt module
1.2. Upgrading kernel
2. Conflicts
2.1. Upgrading slackware packages
2.2. Removing nvidia-linux driver
3. Xorg Configuration

==

1. KERNEL MODULE

   1.1. Prebuilt module

        The package should already contain the nvidia.ko kernel module.
        This module may be built for slackware current or slackware 14.0

        If kernel version does not match with the running kernel, the
        post-install script will recompile automatically a new kernel
        module.

   1.2. Upgrading kernel
       
        If you upgrade your kernel (recompiling it manually or upgrading
        Slackware to -current), you must to recompile the kernel
        module using the script
        /usr/share/nvidia-linux/makekernelmodule.sh

        You have two options:
        a) recompile it BEFORE reboot with the new kernel. You have to
           launch the script specifing the new kernel version:
           # KERNEL=3.8.4 /usr/share/nvidia-linux/makekernelmodule.sh
        b) recompile it AFTER reboot with the new kernel. You must boot
           system in runlevel 3, then build the module with:
           # /usr/share/nvidia-linux/makekernelmodule.sh
           and then load new module:
           # modprobe nvidia
           Now you can start the xorg (with startx or init 4)


2. Conflicts

   The nvidia drivers conflict, for libGL and libglx, with the preinstalled
   drivers (xorg-server and mesa packages) and some other mesa files. This
   may require special operation after upgrading slackware packages or
   after uninstalling nvidia-linux drivers.

   The nvidia-linux installer should backup libglx.so in
     /usr/lib/xorg/modules/extensions/libglx.so-prenvidia
     or
     /usr/lib64/xorg/modules/extensions/libglx.so-prenvidia

   2.1. Upgrading slackware packages
       
        If you are upgrading the mesa package or the xorg-server package
        (when you upgrade slackware), you MUST rerun the nvidia-linux
        postinstall script after the upgrade:
        # cd /
        # bash /var/log/scripts/nvidia-linux-3*

   2.2. Removing nvidia-linux driver

        If you want to remove the nvidia-linux package, you must to restore
        the conflicting files after removing nvidia-linux:
        # cd /usr/lib/xorg/modules/extensions/
        (or lib64)
        # mv libglx.so-prenvidia libglx.so
        # ldconfig

        don't forget to remove the xorg configuration (see below)

3. Xorg Configuration
   
   The nvidia-linux package contains a minimal Xorg configuration sufficient
   to start X in most nvidia cards.

   The configuration is in /etc/X11/xorg.d :
   - monitor-xorg.conf
   - nvidia-xorg.conf

   the base settings may not works with your card, so you need to configure
   it manually. You have two way:
   a) edit manually the configuration files
   b) configure xorg using the official tools:
         - remove the existent configuration
         - create a basic configuration with 'nvidia-xconfig' (that creates
           an /etc/X11/xorg.conf file)
         - start X

   After run X, you may launch 'nvidia-settings' to tune the configuration.
   This tool may create an /etc/X11/xorg.conf file for special configuration.
   In this case, remember to delete the /etc/X11/xorg.d/*.conf files.
   When you upgrade nvidia-linux package, you must re-delete the same files.

   Refer to the official documentation for specific configuration (that you
   can found in /usr/doc/nvidia-linux-3*


2) ora, se necessario e se possibile, il modulo kernel viene creato durante la fase di installazione (su questo però avrei bisogno di testing), perchè il modulo preinserito è compilato in current e per 3.8.4 (non ho una stable a disposizione), quindi chi lo installa su stable o su current successive necessiterà di sicuro del rebuild

3) lo script per fare il modulo kernel ora consente correttamente di compilare il modulo per versioni di kernel diverse da quella corrente. Per esempio oggi ho fatto l'aggiornamento di slackware e mi ha aggiornato il kernel. Ho dovuto compilare il modulo kernel PRIMA di riavviare, altrimenti avrei dovuto farlo in runlevel 3 ecc. Questo era consentito anche prima, ma era bacata l'installazione del modulo

4) visto che il titolo di questo topic è partito tutto dal problema del flash in blu, e visto che questo è risolto omai da tempo con nvidia-vdpau, stavo pensando di eliminare lo sdoppiamento dei pacchetti e riaccorparli. Che ne pensate?

5) segnalatemi bug delle versioni precedenti (ce ne sono) e consigli per la configurazione di default.


Al momento non ricordo quante siano le differenze tra la serie 310.x e 313.x, ma ricordo che ce ne sono, quindi non so dire se lo slackbuild è interscambiabile.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4253
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: [RISOLTO] flash in blu (driver nvidia proprietari)

Messaggioda tornadomig » dom apr 07, 2013 10:58

ciao 01 e buona domenica!

sul riaccorpamento dei pacchetti sono d'accordissimo. vediamo come viene. e' da provare si' la cosa, ora che sto utilizzando la gpt e btrfs sia su hdd che ssd.
magari sugli ultimi drivers, i 310.44, gia' che ci siamo ;)

grazie!!! :thumbright:
rm -rf / && rm -rf . && rm -rf *
Avatar utente
tornadomig
Linux 2.4
Linux 2.4
 
Messaggi: 481
Iscritto il: gio set 30, 2010 14:17
Nome Cognome: giorgio
Slackware: -current64&14.1
Kernel: 3.10.30
Desktop: KDE-4.11.5
Distribuzione: gentoo, funtoo, arch

Re: [RISOLTO] flash in blu (driver nvidia proprietari)

Messaggioda ZeroUno » ven apr 12, 2013 16:30

finalmente sono riuscito a fare il pacchetto
http://www.z01.eu/repo-slack/slackware6 ... ux/310.44/

questo include anche i vdpau quindi se presente l'altro pacchetto va rimosso.

Il pacchetto include il modulo del kernel per 3.2.29 (slack 14.0) e 3.8.4 (slack current)

i 313.x li ho completamente rimossi dal repository visto che il nuovo ramo beta è il 319.x
Le novità introdotte sono tante ed interessanti, ma proprio perchè sono tante non posso stargli dietro.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4253
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: [RISOLTO] flash in blu (driver nvidia proprietari)

Messaggioda tornadomig » ven apr 12, 2013 20:00

grazie 01!!! che dire, vero slacker in tutto e per tutto :thumbright:

putroppo nel mio caso non mi compilano. nel tipo di installazione che ho fatto col btrfs mi va solo l'installer classico, il .run di nvidia. vabbe' e' solo colpa mia che ho intrallazzato a dovere ;)

a qualcun altro funziona il pacchetto di 01? almeno ringraziare per l'impegno profuso, no? :D
rm -rf / && rm -rf . && rm -rf *
Avatar utente
tornadomig
Linux 2.4
Linux 2.4
 
Messaggi: 481
Iscritto il: gio set 30, 2010 14:17
Nome Cognome: giorgio
Slackware: -current64&14.1
Kernel: 3.10.30
Desktop: KDE-4.11.5
Distribuzione: gentoo, funtoo, arch

Precedente

Torna a Packages

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron