Pagina 1 di 1

[RISOLTO] problema libosinfo

Inviato: mar ago 20, 2019 16:55
da iannez
Ciao ragazzi, stavo provando ad installare kvm e qemu con tutti i vari programmi annessi,
su una macchina che mi porto dietro da un po di tempo e che ho gia upgradato un paio di volte, con slapt-get, da release passate.

ho installato tutto da SBo senza nessun problema di compilazione, non ho usato sbopkg ma
a mano per verificare puntualmente, ma ho due prob, il primo è che il comando osinfo-query os
mi da errore:

# osinfo-query os
Error loading OS data: Error opening file: No such file or directory

per prova ho installato anche il sistema slackware64-14.2 da dvd installazione e
fatto update con slapt-get e poi installati solo questi pacchetti da SBo a mano:

json-glib
osinfo-db-tools
osinfo-db
vala
libosinfo

che sono le dipendenze che servono a libosinfo per installarsi e magicamente (non avevo dubbi),
tutto a funzionato.

un ldd tra il comando osinfo-query tra le due macchine mostra librerie in numero maggiore sul sistema nuovo,
ma queste esistono anche sul sistema nel quale il comando non va.

dove non funziona:

# ldd /usr/bin/osinfo-query
linux-vdso.so.1 (0x00007fff7ab7a000)
libosinfo-1.0.so.0 => /usr/lib64/../lib64/libosinfo-1.0.so.0 (0x00007f713c073000)
libxslt.so.1 => /usr/lib64/../lib64/libxslt.so.1 (0x00007f713be33000)
libxml2.so.2 => /usr/lib64/../lib64/libxml2.so.2 (0x00007f713bace000)
liblzma.so.5 => /lib64/liblzma.so.5 (0x00007f713b8a9000)
libm.so.6 => /lib64/libm.so.6 (0x00007f713b5a0000)
libgio-2.0.so.0 => /usr/lib64/../lib64/libgio-2.0.so.0 (0x00007f713b224000)
libgmodule-2.0.so.0 => /usr/lib64/../lib64/libgmodule-2.0.so.0 (0x00007f713b021000)
libdl.so.2 => /lib64/libdl.so.2 (0x00007f713ae1d000)
libresolv.so.2 => /lib64/libresolv.so.2 (0x00007f713ac02000)
libgobject-2.0.so.0 => /usr/lib64/../lib64/libgobject-2.0.so.0 (0x00007f713a9b1000)
libffi.so.6 => /usr/lib64/../lib64/libffi.so.6 (0x00007f713a7a9000)
libglib-2.0.so.0 => /usr/lib64/../lib64/libglib-2.0.so.0 (0x00007f713a473000)
libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f713a256000)
libc.so.6 => /lib64/libc.so.6 (0x00007f7139e8d000)
libz.so.1 => /usr/lib64/../lib64/libz.so.1 (0x00007f7139c76000)
/lib64/ld-linux-x86-64.so.2 (0x00007f713c2c6000)


dove funziona:

# ldd /usr/bin/osinfo-query
linux-vdso.so.1 (0x00007ffc005d8000)
libosinfo-1.0.so.0 => /usr/lib64/../lib64/libosinfo-1.0.so.0 (0x00007fa9e4760000)
libxslt.so.1 => /usr/lib64/../lib64/libxslt.so.1 (0x00007fa9e4520000)
libsoup-2.4.so.1 => /usr/lib64/../lib64/libsoup-2.4.so.1 (0x00007fa9e4247000)
libxml2.so.2 => /usr/lib64/../lib64/libxml2.so.2 (0x00007fa9e3ee2000)
liblzma.so.5 => /lib64/liblzma.so.5 (0x00007fa9e3cbd000)
libm.so.6 => /lib64/libm.so.6 (0x00007fa9e39b4000)
libsqlite3.so.0 => /usr/lib64/../lib64/libsqlite3.so.0 (0x00007fa9e36e3000)
libicui18n.so.56 => /usr/lib64/../lib64/libicui18n.so.56 (0x00007fa9e3252000)
libicuuc.so.56 => /usr/lib64/../lib64/libicuuc.so.56 (0x00007fa9e2eba000)
libicudata.so.56 => /usr/lib64/../lib64/libicudata.so.56 (0x00007fa9e14d7000)
libgio-2.0.so.0 => /usr/lib64/../lib64/libgio-2.0.so.0 (0x00007fa9e115a000)
libgmodule-2.0.so.0 => /usr/lib64/../lib64/libgmodule-2.0.so.0 (0x00007fa9e0f56000)
libdl.so.2 => /lib64/libdl.so.2 (0x00007fa9e0d52000)
libz.so.1 => /usr/lib64/../lib64/libz.so.1 (0x00007fa9e0b3b000)
libresolv.so.2 => /lib64/libresolv.so.2 (0x00007fa9e0920000)
libgobject-2.0.so.0 => /usr/lib64/../lib64/libgobject-2.0.so.0 (0x00007fa9e06cf000)
libffi.so.6 => /usr/lib64/../lib64/libffi.so.6 (0x00007fa9e04c7000)
libglib-2.0.so.0 => /usr/lib64/../lib64/libglib-2.0.so.0 (0x00007fa9e0190000)
libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fa9dff73000)
libc.so.6 => /lib64/libc.so.6 (0x00007fa9dfbaa000)
/lib64/ld-linux-x86-64.so.2 (0x00007fa9e49a5000)
libstdc++.so.6 => /usr/lib64/../lib64/libstdc++.so.6 (0x00007fa9df82e000)
libgcc_s.so.1 => /usr/lib64/../lib64/libgcc_s.so.1 (0x00007fa9df617000)


cosa posso guardare per capire quel

Error loading OS data: Error opening file: No such file or directory

a cosa si riferisce?

grazie per l aiuto :D

Re: problema libosinfo

Inviato: mar ago 20, 2019 17:48
da ponce
ciao iannez, benvenuto su Slacky!
sono il maintainer di libosinfo su SBo e posto solo per dirti che, per policy di SBo (e anche per mia policy personale :) ), installazioni parziali di Slackware non sono supportate: Slackware non offre la facolta' di risolvere le dipendenze, il tutto e' lasciato alla capacita' e alle competenze di chi gestisce l'installazione, l'amministratore di sistema, che consapevolmente realizza un'installazione parziale solo se ha le capacita' per risolvere in autonomia i problemi risultanti dalle proprie scelte.
capisco il tuo attaccamento a un'installato che ti porti dietro da tempo e spero che tu non fraintenda quanto appena scritto, ma se vuoi evitare problemi del genere in futuro il consiglio e' quello di realizzare un'installazione completa e pulita del sistema operativo e partire di li' per aggiungere quello che vuoi.

non so se qualcunaltro avra' la possibilita' di aiutarti col tuo problema, pero' io faccio un cauto passo indietro ;)
in bocca al lupo!

Re: problema libosinfo

Inviato: mar ago 20, 2019 22:27
da iannez
Ciao Ponce,
è un piacere conoscerti.

hai ragione in toto, infatti nel tempo libero sto facendo macchina pulita da 0 e poi riporto vecchie conf sulla nuova.
è un lavoro lungo perche alcune cose le ho compilate da vanilla per avere multiversioni che girano
insieme, vedi apache24 + varie versioni di php5 php7.

in ogni caso, di solito ed incrociando le dita, riesco sempre a cavare il ragno dal buco, a questo giro no,
persino con il debug di strace non riesco a capire cosa non gli piaccia... e perche tiri fuori l errore
visto che i pacchetti compilano tutti bene verificato portanto output su file e guardando per filo e per segno.

se vi viene una idea per verificare altro sono qui, grazie per il supporto. :D

Re: problema libosinfo

Inviato: mer ago 21, 2019 8:38
da miklos
ciao e benvenuto... la differenza delle librerie è notevole ma quella che per la natura del software a me salta più all'occhio è SQLite.. strano che ...qualora c'avessi beccato..in fase di compilazione nn abbia ricevuto errori.
in ogni caso quoto ponce... fra l'altro diventa anche più complicato per chi volesse dare una mano replicare il problema se non si ha esattamente quantomeno la stessa situazione software...

Re: problema libosinfo

Inviato: mer ago 21, 2019 11:52
da iannez
Ciao ragazzi,
riuscito a farlo funzionare installando su macchina old TUTTI i pacchetti che erano installati sulla nuova.

new# slapt-get --installed | cut -d "[" -f1 | egrep -v *_SBo >>/tmp/PKGOK.txt

e sulla old:

old# for i in `cat PKGOK.txt`; do echo "INSTALLING: $i"; slapt-get --install $i; done | tee -a RESPGK.txt

quindi immagino sia qualcosa che manca e che mi è sfuggito dal debug con strace sul processo.

ora visto che la macchina è virtuale, riprendo snapshot bacato e riprovo ciclo for in installazione
ed tra ogni installazione di pacchetto e altra lancio il comando osinfo-query os, quando riprende a funzionare capirò quale meraviglioso
pacchetto era...

teoria buona speriamo anche pratica, tengo aggiornati. :D

Re: problema libosinfo

Inviato: gio ago 22, 2019 9:13
da iannez
Buongiorno, trovato il pacchetto ( hwdata-0.284-noarch-1 ) STRAMALEDETTIMISSIMO!

come da post precedente la pratica ha funzionato, ovviamente
non era scritto che lo doveva essere, ma visto che siamo su slack
e non su centos mi sono fidato tanto :D

#!/bin/bash

for i in `cat PKG.txt`
do
echo "INSTALLING: $i"
slapt-get --install $i

/usr/bin/osinfo-query os &>> RESPKG.txt
/usr/bin/osinfo-query os 2>/dev/null
if [ $? -eq 0 ]; then
echo "OK PKG: $i"
exit 0
fi


sleep 5
done | tee -a RESPKG.txt

lo sleep si puo levare lo usato per testare gli output dello script.
esce quando installando il pacchetto che gli da qualcosa il comando inizia a funzionare.

provato da 0 su ambiente NUOVO x64-14.2 e senza quel pacchetto ( hwdata-0.284-noarch-1 )
non indicato come dipendenza libosinfo non funzia.
direi come suggerimento di inserirlo nei REQUIRED di libosinfo.

altra cosa... per libvirt.
senza dnsmasq installato prima di compilare da SBo libvirt, libvirt compila bene lo stesso e funzia,
pero da grafica con virt-manager, quando si arriva alla fine della procedura di creazione
della VM virtuale, quando chiede la rete si incavola perche non trova nel path dnsmasq.
quindi anche questa credo che sia una dipendenza REQUIRED per libvirt.

ovviamente se avete tempo fate delle prove per confermare quanto scritto.

grazie per il supporto e W la... SLACKWARE.

metto come risolto. a presto :D

Re: problema libosinfo

Inviato: gio ago 22, 2019 9:16
da ponce
come scrivevo sopra, un prerequisito per installare pacchetti da SBo e' l'installazione completa di Slackware e nella variabile REQUIRED, quindi, non ci va messo niente che non sia gia' disponibile in un'installazione completa di Slackware (dnsmasq e hwdata ne fanno parte).

Re: [RISOLTO] problema libosinfo

Inviato: gio ago 22, 2019 9:48
da iannez
pardon mi era sfuggito il discorso installazione completa.

grazie per il vostro supporto, a presto :D