Repository 32bit  Forum
Repository 64bit  Wiki

Grub + ext4

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Grub + ext4

Messaggioda NikyBiasion » lun set 14, 2009 18:52

Salve, ho compilato grub per slackware64 utilizzando le librerie compat32. però se imposto lo installo impostando root in una partizione ext4 mi da sempre error 2 sullo stage1.5. Presumo il problema sia il tipo di partizione visto che su ext3 va benissimo, ho pure provato il metodo descritto in questo post http://www.linuxquestions.org/questions/slackware-14/slackware64-ext4-grub-installation-trickguide-752713/ ma nulla da fare, stesso errore. Qualcuno di voi è riuscito a farlo funzionare?!?
Avatar utente
NikyBiasion
Linux 1.0
Linux 1.0
 
Messaggi: 66
Iscritto il: mer ott 26, 2005 12:12
Località: Fossalta di Piave (VE)
Slackware: 14.0 x64
Kernel: 3.2.26ck
Desktop: XFCE 4.10

Re: Grub + ext4

Messaggioda 414N » lun set 14, 2009 19:04

Considerando che non va molto d'accordo anche con una root di tipo reiser, non mi meraviglio.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Grub + ext4

Messaggioda submax82 » lun set 14, 2009 22:27

Avatar utente
submax82
Staff
Staff
 
Messaggi: 3202
Iscritto il: mar ago 30, 2005 23:00
Desktop: xfce
Distribuzione: SalixOS

Re: Grub + ext4

Messaggioda NikyBiasion » lun set 14, 2009 22:28

L'avevo visto, ma non sapevo se usarlo o meno... ora provo!!
Avatar utente
NikyBiasion
Linux 1.0
Linux 1.0
 
Messaggi: 66
Iscritto il: mer ott 26, 2005 12:12
Località: Fossalta di Piave (VE)
Slackware: 14.0 x64
Kernel: 3.2.26ck
Desktop: XFCE 4.10

Re: Grub + ext4

Messaggioda submax82 » lun set 14, 2009 22:30

appena avrò il piacere di installare slackware 13 farò il pacchetto perchè mi serve per aggiungere il supporto a kernelpkg, quindi se vuoi il txz fammi un fischio :thumbright:
Avatar utente
submax82
Staff
Staff
 
Messaggi: 3202
Iscritto il: mar ago 30, 2005 23:00
Desktop: xfce
Distribuzione: SalixOS

Re: Grub + ext4

Messaggioda Breier » mar set 15, 2009 6:33

Ho usato per installare Slackware nella mia RAID0 poi dovrei installare GRUB o LILO in una partizione /boot separata.

Creare una partizione ext3 di 100MB e il punto in /boot/ a fstab (sicuro si è spostato il file /boot/ contenuti per la nuova partizione prima di riavviare il computer) e avrai ancora il vostro file-system preferito a root / installa grub, mentre a un vecchio ext3 solo in /boot/

see ya 8)
Avatar utente
Breier
Linux 1.0
Linux 1.0
 
Messaggi: 40
Iscritto il: dom set 13, 2009 4:56
Località: Brazil
Slackware: 13.0
Kernel: 2.6.31.1
Desktop: Xfce-4.6
Distribuzione: Slackware64

Re: Grub + ext4

Messaggioda NikyBiasion » mar set 15, 2009 11:30

:shock: :shock: :shock:
Google translate immagino!!
comunque forse il mio problema è che la partizione era una ext3 poi convertita in ext4 e questo sembra dar fastidio a grub che non riconosce correttamente il filesystem. Altra cosa, il mio sistema è installato in un fakeraid 0!!
Avatar utente
NikyBiasion
Linux 1.0
Linux 1.0
 
Messaggi: 66
Iscritto il: mer ott 26, 2005 12:12
Località: Fossalta di Piave (VE)
Slackware: 14.0 x64
Kernel: 3.2.26ck
Desktop: XFCE 4.10

Re: Grub + ext4

Messaggioda zoros » gio set 17, 2009 14:38

se hai voglia di leggere puoi provare con questa soluzione ... per installare ed avviare una 64 bit (anche su ext4) non servono applicativi a 64 bit ... provare per credere ;)

... però devi adattare lo script in modo che si procuri il pacchetto dmraid a 64 bit ... altrimenti sì che non parte :shock:
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1302
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 13.37
Kernel: 3.2.5
Desktop: KDE-3.5.10


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Yahoo [Bot] e 1 ospite