Pagina 1 di 1

[Risolto] Problema con driver nvidia

Inviato: lun nov 07, 2011 11:22
da pol
Ho aggiornato l'hardware del mio pc, scheda madre gigabyte z68, vga gtx 580, ed una scheda audio asus, ho fatto l'installazione, tutto ok.

Primo problema, con kde è impossibile accedere, quindi ho risolto con xfce,

ho provato ad installare i driver nvidia, la versione 275.36 (ho provato altre versioni), mi da questo errore:

"ERROR: The Nouveau kernel driver is currently in use by your system. This
driver is incompatible with the NVIDIA driver, and must be disabled
before proceeding. Please consult the NVIDIA driver README and your
Linux distribution's documentation for details on how to correctly
disable the Nouveau kernel driver."

Un aiuto ?

Re: Problema con driver nvidia

Inviato: lun nov 07, 2011 11:29
da Plaoo
Devi disinstallare il pkg nouveau, poi se vuoi aggiungi i moduli nella black-list ma penso che siano i driver stessi nvidia che ci pensino.

PS: il pkg dovrebbe chiamarsi xf86-video-nouveau

Re: Problema con driver nvidia

Inviato: lun nov 07, 2011 11:32
da erio
metti in blacklist i driver noveau, di solito e lo stesso installer che ti chiede vuoi disattivarli? tu rispondi si e riavvii poi installi normalmente i driver.mi pare che esiste anche un pacchetto in slackware che fa questo lavoro: http://ftp.heanet.ie/mirrors/ftp.slackw ... blacklist/

Re: Problema con driver nvidia

Inviato: lun nov 07, 2011 12:38
da hashbang
pol ha scritto:Primo problema, con kde è impossibile accedere, quindi ho risolto con xfce,

Molto probabilmente dipende dalla mancanza dei driver nvidia, che inficia l'uso della composizione del desktop.

Changes and Hints.txt ha scritto:Regardless of your chipset (though it seems more common with intel), if KDE
crashes on startup, try disabling the Composite extension (which will also
disable all of the fancy desktop effects). Place the following content in
a file at /etc/X11/xorg.conf.d/disable-composite.conf:
Section "Extensions"
Option "Composite" "Disable"
EndSection


ho provato ad installare i driver nvidia, la versione 275.36 (ho provato altre versioni), mi da questo errore:

"ERROR: The Nouveau kernel driver is currently in use by your system. This
driver is incompatible with the NVIDIA driver, and must be disabled
before proceeding. Please consult the NVIDIA driver README and your
Linux distribution's documentation for details on how to correctly
disable the Nouveau kernel driver."

Un aiuto ?
O segui il consiglio di erio (usando il pacchetto), oppure:

Codice: Seleziona tutto

# echo "blacklist nouveau" >> /etc/modprobe.d/blacklist.conf


In ogni caso, riavvia il computer, prima di installare i driver nvidia.

PS: il simbolo "#" l'ho messo per identificare che quell'operazione la devi svolgere come root.

PPS: Per i driver nvidia, assicurati di avere i sorgenti del kernel in uso.

Re: Problema con driver nvidia

Inviato: lun nov 07, 2011 13:58
da pol
Grazie 1000 a tutti, ho risolto seguendo il vostro consiglio, installando il pkg xf86-video-nouveau.