Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] Problema cuffie usb wireless

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO] Problema cuffie usb wireless

Messaggioda lablinux » mar gen 03, 2012 17:25

Questo è il modello http://www.trust.com/products/productpictures.aspx?artnr=17446.
Quando inserisco il trasmettitore wireless, il sistema lo rileva ma io non posso usarlo, resta muto. Con kmix seleziono il canale, escludo gli altri e nulla, se non escludo gli altri due canali l'audio passa dalla casse del pc.
lsusb non da nulla, nel senso che mostra la nuova periferica ma non specifica nulla (quando ho il pc sottomano invio l'output)

alsaconf non rivela l'usicta audio.

Ho provato con ubuntu 10.04 e funziona.


Idee? Mi sto perdendo in un bicchier d'acqua?
Ultima modifica di lablinux il ven gen 06, 2012 23:25, modificato 1 volta in totale.
Avatar utente
lablinux
Linux 2.6
Linux 2.6
 
Messaggi: 706
Iscritto il: gio nov 27, 2008 12:23
Località: Rho
Slackware: 14 64bit
Desktop: kde4

Re: Problema cuffie usb wireless

Messaggioda Naitso » mar gen 03, 2012 20:39

Che il sistema lo rilevi è una cosa ;) , utilizzarlo è un altro paio di maniche [-o< , dato che con ubuntu funge controlla versione del kernel e modulo utilizzato, poi passi in slackware e fai le modifiche del caso.
EDIT: Ubuntu usa PulseAudio
ciao
Avatar utente
Naitso
Linux 2.0
Linux 2.0
 
Messaggi: 178
Iscritto il: lun nov 10, 2008 15:09

Re: Problema cuffie usb wireless

Messaggioda lablinux » mar gen 03, 2012 23:01

Naitso ha scritto:Che il sistema lo rilevi è una cosa ;) , utilizzarlo è un altro paio di maniche [-o<
:D hai ragione da vendere

Naitso ha scritto:EDIT: Ubuntu usa PulseAudio
esatto, ma ha anche alsa installato

quindi, riporto i dati, ubuntu (10.04 LTS 64 bit con repro prosed attivi) usa il kernel 2.6.32-37, slackware (13.37 64 bit) usa il 2.6.37.62.6.37.6
Ubuntu con
Codice: Seleziona tutto
sudo lsmod |grep snd
prima di inserire la chiavetta
Codice: Seleziona tutto
snd_hda_codec_realtek   279104  1
snd_hda_intel          25805  1
snd_hda_codec          85759  2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep               6924  1 snd_hda_codec
snd_pcm_oss            41394  0
snd_mixer_oss          16299  1 snd_pcm_oss
snd_pcm                87946  3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_seq_dummy           1782  0
snd_seq_oss            31191  0
snd_seq_midi            5829  0
snd_rawmidi            23420  1 snd_seq_midi
snd_seq_midi_event      7267  2 snd_seq_oss,snd_seq_midi
snd_seq                57481  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer              23681  2 snd_pcm,snd_seq
snd_seq_device          6888  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd                    71283  14 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore               8052  1 snd
snd_page_alloc          8500  2 snd_hda_intel,snd_pcm

dopo aver inserito la chiavetta
Codice: Seleziona tutto
snd_usb_audio          92747  2
snd_usb_lib            19193  1 snd_usb_audio
snd_hda_codec_realtek   279104  1
snd_hda_intel          25805  1
snd_hda_codec          85759  2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep               6924  2 snd_usb_audio,snd_hda_codec
snd_pcm_oss            41394  0
snd_mixer_oss          16299  1 snd_pcm_oss
snd_pcm                87946  4 snd_usb_audio,snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_seq_dummy           1782  0
snd_seq_oss            31191  0
snd_seq_midi            5829  0
snd_rawmidi            23420  2 snd_usb_lib,snd_seq_midi
snd_seq_midi_event      7267  2 snd_seq_oss,snd_seq_midi
snd_seq                57481  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer              23681  2 snd_pcm,snd_seq
snd_seq_device          6888  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd                    71283  19 snd_usb_audio,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore               8052  1 snd
snd_page_alloc          8500  2 snd_hda_intel,snd_pcm

ad un occhio attento :D non può sfuggire che vengono caricati due moduli, i primi due della lista

Ora con la Nostra Slackware, prima di inserire la chiavetta
Codice: Seleziona tutto
snd_seq_dummy           1479  0
snd_seq_oss            30116  0
snd_seq_midi_event      5708  1 snd_seq_oss
snd_seq                52486  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          5473  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            40089  0
snd_mixer_oss          17282  1 snd_pcm_oss
snd_hda_codec_hdmi     22985  4
snd_hda_codec_realtek   293594  1
snd_hda_intel          21915  3
snd_hda_codec          71748  3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel
snd_hwdep               6254  1 snd_hda_codec
snd_pcm                73762  4 snd_pcm_oss,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
snd_timer              19671  2 snd_seq,snd_pcm
snd                    58334  18 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
soundcore               5681  1 snd
snd_page_alloc          7297  2 snd_hda_intel,snd_pcm

e ad inserimento avvenuto
Codice: Seleziona tutto
snd_usb_audio          87997  1
snd_usbmidi_lib        19060  1 snd_usb_audio
snd_rawmidi            19983  1 snd_usbmidi_lib                                             
snd_seq_dummy           1479  0                                                             
snd_seq_oss            30116  0                                                             
snd_seq_midi_event      5708  1 snd_seq_oss                                                 
snd_seq                52486  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event                 
snd_seq_device          5473  4 snd_rawmidi,snd_seq_dummy,snd_seq_oss,snd_seq               
snd_pcm_oss            40089  0                                                             
snd_mixer_oss          17282  1 snd_pcm_oss                                                 
snd_hda_codec_hdmi     22985  4
snd_hda_codec_realtek   293594  1
snd_hda_intel          21915  3
snd_hda_codec          71748  3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel
snd_hwdep               6254  2 snd_usb_audio,snd_hda_codec
snd_pcm                73762  5 snd_usb_audio,snd_pcm_oss,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
snd_timer              19671  2 snd_seq,snd_pcm
snd                    58334  23 snd_usb_audio,snd_usbmidi_lib,snd_rawmidi,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
soundcore               5681  1 snd
snd_page_alloc          7297  2 snd_hda_intel,snd_pcm

anche in questo caso vengono caricati dei driver ma sono tre, uno dei quali snd_rawmidi in ubuntu è già caricato.

La differenza che posso notare è snd_usb_lib che non viene caricato in slackware, e cercando di caricarlo manualmente :
Codice: Seleziona tutto
# modprobe snd_usb_lib   
FATAL: Module snd_usb_lib not found.

Potrebbe, visto la versione del kernel differente, aver semplicemente cambiato nome.

Quasi dimeticavo
Codice: Seleziona tutto
dmesg |grep audio

per entrambe i sistemi non ottengo alcun output prima dell'inserimento della chiavetta, ma ottengo
Codice: Seleziona tutto
[  332.052168] usbcore: registered new interface driver snd-usb-audio
dopo l'inserimento, il codice numerico tra parentesi quadra cambia, ma creo sia più un time stamp che qualcosa di funzionale.

ok, ma adesso? Qualche altro dato che posso portarmi alla soluzione?
Avatar utente
lablinux
Linux 2.6
Linux 2.6
 
Messaggi: 706
Iscritto il: gio nov 27, 2008 12:23
Località: Rho
Slackware: 14 64bit
Desktop: kde4

Re: Problema cuffie usb wireless

Messaggioda lablinux » mar gen 03, 2012 23:34

quasi dimenticavo.
Ubuntu
Codice: Seleziona tutto
sudo lspci -v | grep -i audio
00:1b.0 Audio device: Intel Corporation Cougar Point High Definition Audio Controller (rev 05)
01:00.1 Audio device: nVidia Corporation Device 0be9 (rev a1)

e a chiave inserita
Codice: Seleziona tutto
sudo lsusb -v | grep -i audio
      bInterfaceClass         1 Audio
      AudioControl Interface Descriptor:
      AudioControl Interface Descriptor:
      AudioControl Interface Descriptor:
      AudioControl Interface Descriptor:
      AudioControl Interface Descriptor:
      AudioControl Interface Descriptor:
      AudioControl Interface Descriptor:
      bInterfaceClass         1 Audio
      bInterfaceClass         1 Audio
      AudioStreaming Interface Descriptor:
      AudioStreaming Interface Descriptor:
        AudioControl Endpoint Descriptor:
      bInterfaceClass         1 Audio
      bInterfaceClass         1 Audio
      AudioStreaming Interface Descriptor:
      AudioStreaming Interface Descriptor:
        AudioControl Endpoint Descriptor:



slackware
Codice: Seleziona tutto
# lspci -v | grep -i audio
00:1b.0 Audio device: Intel Corporation 6 Series Chipset Family High Definition Audio Controller (rev 05)
01:00.1 Audio device: nVidia Corporation GF106 High Definition Audio Controller (rev a1)

e a chiave inserita
Codice: Seleziona tutto
# lsusb -v | grep -i audio
      bInterfaceClass         1 Audio
      AudioControl Interface Descriptor:
      AudioControl Interface Descriptor:
      AudioControl Interface Descriptor:
      AudioControl Interface Descriptor:
      AudioControl Interface Descriptor:
      AudioControl Interface Descriptor:
      AudioControl Interface Descriptor:
      bInterfaceClass         1 Audio
      bInterfaceClass         1 Audio
      AudioStreaming Interface Descriptor:
      AudioStreaming Interface Descriptor:
        AudioControl Endpoint Descriptor:
      bInterfaceClass         1 Audio
      bInterfaceClass         1 Audio
      AudioStreaming Interface Descriptor:
      AudioStreaming Interface Descriptor:
        AudioControl Endpoint Descriptor:
Avatar utente
lablinux
Linux 2.6
Linux 2.6
 
Messaggi: 706
Iscritto il: gio nov 27, 2008 12:23
Località: Rho
Slackware: 14 64bit
Desktop: kde4

Re: Problema cuffie usb wireless

Messaggioda lablinux » mer gen 04, 2012 18:50

nessuna idea? Sembra un problema irrisolvibile, ho cercato altre discussioni simili e non ho trovato una sola soluzione da provare.
P.S. per scrupolo e per tedia, mi son compilato il kernel 3.2.rc07, ma neppure con quel kernel ho avuto un esito positivo. Sarà una mancaza di alsa? Devo provare ad installare pulseaudio?
Avatar utente
lablinux
Linux 2.6
Linux 2.6
 
Messaggi: 706
Iscritto il: gio nov 27, 2008 12:23
Località: Rho
Slackware: 14 64bit
Desktop: kde4

Re: Problema cuffie usb wireless

Messaggioda rik70 » mer gen 04, 2012 19:45

Cosa restituisce:
Codice: Seleziona tutto
cat /proc/asound/cards

?
rik70
Linux 2.6
Linux 2.6
 
Messaggi: 946
Iscritto il: gio mar 10, 2011 9:21
Slackware: 13.1
Kernel: 3.11.9-smp
Desktop: LXDE

Re: Problema cuffie usb wireless

Messaggioda lablinux » mer gen 04, 2012 23:26

Codice: Seleziona tutto
# cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf6a00000 irq 47
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xf4080000 irq 17


e con la chiavetta
Codice: Seleziona tutto
# cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf6a00000 irq 47
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xf4080000 irq 17
 2 [Headset        ]: USB-Audio - 2.4G Wireless Headset
                      2.4G Wireless Headset at usb-0000:00:1d.0-1.4, full speed


Per completezza giro anche con Ubuntu:
Codice: Seleziona tutto
sudo cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf6a00000 irq 22


e con la scheda
Codice: Seleziona tutto
sudo cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf6a00000 irq 22
 1 [Headset        ]: USB-Audio - 2.4G Wireless Headset
                            2.4G Wireless Headset at usb-0000:00:1d.0-1.4, full speed
Avatar utente
lablinux
Linux 2.6
Linux 2.6
 
Messaggi: 706
Iscritto il: gio nov 27, 2008 12:23
Località: Rho
Slackware: 14 64bit
Desktop: kde4

Re: Problema cuffie usb wireless

Messaggioda lablinux » gio gen 05, 2012 0:03

mumble muble ...
una cosa strana che non avevo notato. Il suono alle cuffie ariva. Come direte voi. Semplicemente quando da kmix alzo il volume al massimo, sento un biit nelle cuffie. Anche quando spengo il canale, sento un biip nelle cuffie
Allegati
kmix.png
kmix.png (76.42 KiB) Osservato 1284 volte
Avatar utente
lablinux
Linux 2.6
Linux 2.6
 
Messaggi: 706
Iscritto il: gio nov 27, 2008 12:23
Località: Rho
Slackware: 14 64bit
Desktop: kde4

Re: Problema cuffie usb wireless

Messaggioda rik70 » gio gen 05, 2012 0:52

Uhm....

dal /proc/asound sembra che la scheda usb sia a posto anche in Slackware.

La discrepanza tra Ubuntu e Slack riguarda invece la scheda audio Intel: Slackware ti vede 2 schede + la usb, mentre ubuntu una (intel) + la usb.

Sembra ci sia un 'errata configurazione della scheda Intel su Slackware: un problema analogo l'ha avuto l'utente Procopio e se n'era discusso da poco.

Nota infatti come Slackware carichi anche il modulo snd_hda_codec_hdmi, mentre su Ubuntu non ce n'è traccia. In sostanza canna il codec durante l'inizializzazione del modulo snd_hda_intel e in dmesg dovresti trovare qualcosa al riguardo. Ubuntu probabilmente di default passa al modulo i parametri corretti: quali?

Buttando un occhio in /sys/module - e in particolare in /sys/module/snd_hda_intel/parameters/ - dovresti trovarli, magari confrontando le voci nelle 2 differenti distro. Quella del modulo snd_hda_intel è sempre una rottura non da poco.

Il problema perciò dovrebbe essere proprio quella "doppia" scheda audio vista da Slackware, anche se la usb - in teoria - dovrebbe funzionare lo stesso.
rik70
Linux 2.6
Linux 2.6
 
Messaggi: 946
Iscritto il: gio mar 10, 2011 9:21
Slackware: 13.1
Kernel: 3.11.9-smp
Desktop: LXDE

Re: Problema cuffie usb wireless

Messaggioda lablinux » gio gen 05, 2012 8:40

Ottimo, questa sera cerco.
La hdmi, credo, sia riferita all'uscita audio sulla porta hdmi. Per quanto riguarda la intel ora mi cerco anche la discussione di Procopio.
Avatar utente
lablinux
Linux 2.6
Linux 2.6
 
Messaggi: 706
Iscritto il: gio nov 27, 2008 12:23
Località: Rho
Slackware: 14 64bit
Desktop: kde4

Re: Problema cuffie usb wireless

Messaggioda rik70 » gio gen 05, 2012 10:23

Al di là della questione della scheda intel (è vero, il modulo snd_*_hdmi sembra legato a un'uscita HDMI, ma la discrepanza con Ubuntu è quantomeno sospetta: 2 schede audio anziché una), la periferica usb dovrebbe/potrebbe funzionare ugualmente.

Partendo dalla situazione precedente, prova da Slackware in questo modo:
Codice: Seleziona tutto
alsamixer -c 2

e vedi se ti fa regolare i volumi, eventuali switch, etc.

Poi utilizza mplayer per fare dei test, usando questo comando:
Codice: Seleziona tutto
mplayer -ao alsa:device=Headset [file_audio/video]

e "butta un orecchio" per vedere se salta fuori qualche suono.
rik70
Linux 2.6
Linux 2.6
 
Messaggi: 946
Iscritto il: gio mar 10, 2011 9:21
Slackware: 13.1
Kernel: 3.11.9-smp
Desktop: LXDE

Re: Problema cuffie usb wireless

Messaggioda lablinux » gio gen 05, 2012 21:53

con
Codice: Seleziona tutto
alsamixer -c 2
mi ha visualizzato quello che mi mostra anche kmix, il canale audio usb. E come con kmix, quando arrivo al massimo del volume sento il biip nelle cuffie.

Con mplayer nulla di fatto
Codice: Seleziona tutto
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 2 ch, s16le, 448.0 kbit/29.17% (ratio: 56000->192000)
Selected audio codec: [ffac3] afm: ffmpeg (FFmpeg AC-3)
==========================================================================
[AO_ALSA] alsa-lib: pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM Headset
[AO_ALSA] Playback open error: No such file or directory
Failed to initialize audio driver 'alsa:device=Headset'
Could not open/initialize audio device -> no sound.
Audio: no sound


Ottengo lo stesso risultato con
Codice: Seleziona tutto
mplayer -ao alsa:device=PCH
Avatar utente
lablinux
Linux 2.6
Linux 2.6
 
Messaggi: 706
Iscritto il: gio nov 27, 2008 12:23
Località: Rho
Slackware: 14 64bit
Desktop: kde4

Re: Problema cuffie usb wireless

Messaggioda lablinux » gio gen 05, 2012 22:19

funziona con
Codice: Seleziona tutto
-ao alsa:device=hw=2

e con
Codice: Seleziona tutto
-ao alsa:device=hw=0
funziona con le casse
Avatar utente
lablinux
Linux 2.6
Linux 2.6
 
Messaggi: 706
Iscritto il: gio nov 27, 2008 12:23
Località: Rho
Slackware: 14 64bit
Desktop: kde4

Re: Problema cuffie usb wireless

Messaggioda rik70 » ven gen 06, 2012 8:57

lablinux ha scritto: E come con kmix, quando arrivo al massimo del volume sento il biip nelle cuffie.


Ma bippa ininterrottamente o si ferma?

lablinux ha scritto:Con mplayer nulla di fatto
Codice: Seleziona tutto
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 2 ch, s16le, 448.0 kbit/29.17% (ratio: 56000->192000)
Selected audio codec: [ffac3] afm: ffmpeg (FFmpeg AC-3)
==========================================================================
[AO_ALSA] alsa-lib: pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM Headset
[AO_ALSA] Playback open error: No such file or directory
Failed to initialize audio driver 'alsa:device=Headset'
Could not open/initialize audio device -> no sound.
Audio: no sound

Ottengo lo stesso risultato con
Codice: Seleziona tutto
mplayer -ao alsa:device=PCH


Perdonami, errore mio: per poter utilizzare il nome del dispositivo occorre un file .asoundrc o /etc/asound.conf. Sorry.

lablinux ha scritto:funziona con
Codice: Seleziona tutto
-ao alsa:device=hw=2

e con
Codice: Seleziona tutto
-ao alsa:device=hw=0
funziona con le casse


Questo che hai fatto era la prova corretta: bisognava passare a mplayer l'ID della scheda audio da utilizzare, non il nome: mi scuso di nuovo.

Quindi la scheda usb funziona?
rik70
Linux 2.6
Linux 2.6
 
Messaggi: 946
Iscritto il: gio mar 10, 2011 9:21
Slackware: 13.1
Kernel: 3.11.9-smp
Desktop: LXDE

Re: Problema cuffie usb wireless

Messaggioda lablinux » ven gen 06, 2012 23:24

no non ti scuso ma ti ringrazio (e ringrazio anche gli altri slackers). La soluzione l'ho raggiunta grazie ai vostri preziosizzimi aiuti
Avatar utente
lablinux
Linux 2.6
Linux 2.6
 
Messaggi: 706
Iscritto il: gio nov 27, 2008 12:23
Località: Rho
Slackware: 14 64bit
Desktop: kde4


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite