Repository 32bit  Forum
Repository 64bit  Wiki

Gigabit ethernet

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Gigabit ethernet

Messaggioda -sf » mar set 25, 2012 20:29

Ciao a tutti, da qualche giorno sto litigando con la mia porta ethernet integrata che dovrebbe andare in gigabit ma si rifiuta di salire oltre i 100mbit..

Da ethtool rilevo:
Codice: Seleziona tutto
bash-4.1# ethtool eth0
Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Advertised pause frame use: No
        Advertised auto-negotiation: Yes
        Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                             100baseT/Half 100baseT/Full
        Link partner advertised pause frame use: No
        Link partner advertised auto-negotiation: Yes
        Speed: 100Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: pumbg
        Wake-on: g
        Current message level: 0x00000033 (51)
                               drv probe ifdown ifup
        Link detected: yes

Da quello che leggo, dovrebbe supportare i 1000mbit in full duplex, proprio come da specifiche della casa madre..

Provo a impostare manualmente con
Codice: Seleziona tutto
ethtool -s eth0 speed 1000 duplex full

ma ottengo l'effetto contrario :?
Codice: Seleziona tutto
bash-4.1# ethtool eth0
Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Advertised pause frame use: No
        Advertised auto-negotiation: Yes
        Speed: 10Mb/s
        Duplex: Half
        Port: MII
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: pumbg
        Wake-on: g
        Current message level: 0x00000033 (51)
                               drv probe ifdown ifup
        Link detected: no

Per n secondi la connessione cade, salvo poi ripristinarsi e tornare a 100mbit.

Seguendo alcuni wiki si consiglia di disattivare la "auto-negotiation", ma non cambia nulla il problema si ripresenta.

Ho infine provato con il comando mii-tool...
Codice: Seleziona tutto
bash-4.1# mii-tool eth0
SIOCGMIIPHY on 'eth0' failed: Operation not supported

ma non ho avuto tempo per approfondire...

Sono collegato ad uno switch gigabit e altri dispositivi viaggiano correttamente a 1gbit/s.
Non uso inoltre nessun gestore per le connessioni, la connessione viene effettuata al boot con dhcpcd.
Non ho provato su altri OS, salvo una debian installata al volo in una partizione vuota e anche li niente; la cosa curiosa e' che l'applet di networkmanger (su debian si intende) mi dice "connessione non gestita" o una cosa simile, quando la connessione invece funziona correttamente.

Idee? Dove sbaglio?

Grazie :)
Avatar utente
-sf
Linux 2.4
Linux 2.4
 
Messaggi: 209
Iscritto il: ven lug 15, 2011 0:20
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE

Re: Gigabit ethernet

Messaggioda -sf » mar set 25, 2012 21:37

Ho fatto un piccolo passo avanti, o almeno credo..
lshw riporta:
Codice: Seleziona tutto
lshw -C network
  *-network               
       description: Ethernet interface
       product: RTL8111/8168B PCI Express Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:07:00.0
       logical name: eth0
       version: 06
       serial: bc:5f:f4:39:4b:03
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8168 driverversion=8.032.00-NAPI duplex=full ip=192.168.0.16 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:82 ioport:c000(size=256) memory:d0004000-d0004fff memory:d0000000-d0003fff

ma il modulo caricato in automatico e': r8169.

Un problema simile e' stato riscontrato da alcuni utenti in un forum debian/ubuntu e ho cercato quindi sul sito del produttore i driver corretti.
Scaricati, installato il modulo nuovo e... non va ugualmente :(

Tuttavia ora se provo a settare manualmente la velocita' non scende piu' a 10mbit/s ma rimane sempre a 100.

Ah si.. ora i led sulla porta ethernet sono accesi :lol:
Avatar utente
-sf
Linux 2.4
Linux 2.4
 
Messaggi: 209
Iscritto il: ven lug 15, 2011 0:20
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti