Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO]problema terratec e slackware 14

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO]problema terratec e slackware 14

Messaggioda TuxInTheMiddle » lun ott 15, 2012 8:19

salve a tutti...sono in possesso di questa vecchiachiavetta per ricevere il digitale terrestre su pc (usb)...stamattina mi è saltato in mente di porvarla su slacky dal momento che l'ho ritrovata in un cassetto dimenticato...solo che ho dei problemi...ho trovato questa pagina web:

http://www.linuxtv.org/wiki/index.php/TerraTec_Cinergy_T_Stick#Install_instructions_for_manufacturer_driver

Dove ho trovato la sezione Z che tempo fa non c'era che pare sia aggiornata e faccia al caso mio...solo che quando (dopo aver clonato con git) provo a dare il ./build mi dà problemi e mi dice che ha bisogno di patchutils (come mi accenna anche la web page di cui sopra...)...bene, allora lo cerco e trovo uno slackbuild...solo che mi da dei problemi quando provo a generare il tgz...per la precisione:
Codice: Seleziona tutto
patchutils-0.3.0/doc/unwrapdiff.1
patchutils-0.3.0/Makefile.am
patchutils-0.3.0/README
checking for a BSD-compatible install... /bin/ginstall -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name...
configure: error: C compiler cannot create executables
See `config.log' for more details.

é solo la parte finale ma nellla prima parte fila tutto liscio...
a questo punto ho dato un'occhiata al config.log in /tmp/SBo(patchutils-0.3.0/...ma non ci ho capito granchè...

Codice: Seleziona tutto
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by patchutils configure 0.3.0, which was
generated by GNU Autoconf 2.61.  Invocation command line was

  $ ./configure --prefix=/usr --sysconfdir=/etc --docdir=/usr/doc/patchutils-0.3.0 --mandir=/usr/man --build=i486-slackware-linux

## --------- ##
## Platform. ##
## --------- ##

hostname = darkstar
uname -m = x86_64
uname -r = 3.2.29
uname -s = Linux
uname -v = #1 SMP Mon Sep 17 13:38:05 CDT 2012

/usr/bin/uname -p = Intel(R) Core(TM) i3-2310M CPU @ 2.10GHz
/bin/uname -X     = unknown

/bin/arch              = x86_64
/usr/bin/arch -k       = unknown
/usr/convex/getsysinfo = unknown
/usr/bin/hostinfo      = unknown
/bin/machine           = unknown
/usr/bin/oslevel       = unknown
/bin/universe          = unknown

PATH: /usr/local/sbin
PATH: /usr/local/bin
PATH: /sbin
PATH: /usr/sbin
PATH: /bin
PATH: /usr/bin


## ----------- ##
## Core tests. ##
## ----------- ##

configure:1780: checking for a BSD-compatible install
configure:1836: result: /bin/ginstall -c
configure:1847: checking whether build environment is sane
configure:1890: result: yes
configure:1923: checking for gawk
configure:1939: found /bin/gawk
configure:1950: result: gawk
configure:1961: checking whether make sets $(MAKE)
configure:1982: result: yes
configure:2211: checking for gcc
configure:2227: found /usr/bin/gcc
configure:2238: result: gcc
configure:2476: checking for C compiler version
configure:2483: gcc --version >&5
gcc (GCC) 4.7.1
Copyright (C) 2012 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:2486: $? = 0
configure:2493: gcc -v >&5
Reading specs from /usr/lib64/gcc/x86_64-slackware-linux/4.7.1/specs
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/libexec/gcc/x86_64-slackware-linux/4.7.1/lto-wrapper
Target: x86_64-slackware-linux
Configured with: ../gcc-4.7.1/configure --prefix=/usr --libdir=/usr/lib64 --mandir=/usr/man --infodir=/usr/info --enable-shared --enable-bootstrap --enable-languages=ada,c,c++,fortran,go,java,lto,objc --enable-threads=posix --enable-checking=release --enable-objc-gc --with-system-zlib --with-python-dir=/lib64/python2.7/site-packages --disable-libunwind-exceptions --enable-__cxa_atexit --enable-libssp --enable-lto --with-gnu-ld --verbose --enable-java-home --with-java-home=/usr/lib64/jvm/jre --with-jvm-root-dir=/usr/lib64/jvm --with-jvm-jar-dir=/usr/lib64/jvm/jvm-exports --with-arch-directory=amd64 --with-antlr-jar=/slack/TMPTMPTMP/gcc-round-two/antlr-runtime-3.4.jar --enable-java-awt=gtk --disable-gtktest --disable-multilib --target=x86_64-slackware-linux --build=x86_64-slackware-linux --host=x86_64-slackware-linux
Thread model: posix
gcc version 4.7.1 (GCC)
configure:2496: $? = 0
configure:2503: gcc -V >&5
gcc: error: unrecognized command line option '-V'
gcc: fatal error: no input files
compilation terminated.
configure:2506: $? = 1
configure:2529: checking for C compiler default output file name
configure:2556: gcc -O2 -march=i486 -mtune=i686   conftest.c  >&5
conftest.c:1:0: error: CPU you selected does not support x86-64 instruction set
configure:2559: $? = 1
configure:2597: result:
configure: failed program was:
| /* confdefs.h.  */
| #define PACKAGE_NAME "patchutils"
| #define PACKAGE_TARNAME "patchutils"
| #define PACKAGE_VERSION "0.3.0"
| #define PACKAGE_STRING "patchutils 0.3.0"
| #define PACKAGE_BUGREPORT ""
| #define PACKAGE "patchutils"
| #define VERSION "0.3.0"
| /* end confdefs.h.  */
|
| int
| main ()
| {
|
|   ;
|   return 0;
| }
configure:2604: error: C compiler cannot create executables
See `config.log' for more details.

## ---------------- ##
## Cache variables. ##
## ---------------- ##

ac_cv_env_CC_set=
ac_cv_env_CC_value=
ac_cv_env_CFLAGS_set=set
ac_cv_env_CFLAGS_value='-O2 -march=i486 -mtune=i686'
ac_cv_env_CPPFLAGS_set=
ac_cv_env_CPPFLAGS_value=
ac_cv_env_CPP_set=
ac_cv_env_CPP_value=
ac_cv_env_LDFLAGS_set=
ac_cv_env_LDFLAGS_value=
ac_cv_env_LIBS_set=
ac_cv_env_LIBS_value=
ac_cv_env_build_alias_set=set
ac_cv_env_build_alias_value=i486-slackware-linux
ac_cv_env_host_alias_set=
ac_cv_env_host_alias_value=
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=
ac_cv_path_install='/bin/ginstall -c'
ac_cv_prog_AWK=gawk
ac_cv_prog_ac_ct_CC=gcc
ac_cv_prog_make_make_set=yes

## ----------------- ##
## Output variables. ##
## ----------------- ##

ACLOCAL='${SHELL} /tmp/SBo/patchutils-0.3.0/missing --run aclocal-1.7'
ALLOCA=''
AMDEPBACKSLASH=''
AMDEP_FALSE=''
AMDEP_TRUE=''
AMTAR='${SHELL} /tmp/SBo/patchutils-0.3.0/missing --run tar'
AUTOCONF='${SHELL} /tmp/SBo/patchutils-0.3.0/missing --run autoconf'
AUTOHEADER='${SHELL} /tmp/SBo/patchutils-0.3.0/missing --run autoheader'
AUTOMAKE='${SHELL} /tmp/SBo/patchutils-0.3.0/missing --run automake-1.7'
AWK='gawk'
CC='gcc'
CCDEPMODE=''
CFLAGS='-O2 -march=i486 -mtune=i686'
CPP=''
CPPFLAGS=''
CYGPATH_W='echo'
DEFAULT_EDITOR=''
DEFS=''
DEPDIR=''
ECHO_C=''
ECHO_N='-n'
ECHO_T=''
EGREP=''
EXEEXT=''
GREP=''
INSTALL_DATA='${INSTALL} -m 644'
INSTALL_PROGRAM='${INSTALL}'
INSTALL_SCRIPT='${INSTALL}'
INSTALL_STRIP_PROGRAM='${SHELL} $(install_sh) -c -s'
LDFLAGS=''
LIBOBJS=''
LIBS=''
LN_S=''
LTLIBOBJS=''
MAKEINFO='${SHELL} /tmp/SBo/patchutils-0.3.0/missing --run makeinfo'
OBJEXT=''
PACKAGE='patchutils'
PACKAGE_BUGREPORT=''
PACKAGE_NAME='patchutils'
PACKAGE_STRING='patchutils 0.3.0'
PACKAGE_TARNAME='patchutils'
PACKAGE_VERSION='0.3.0'
PATH_SEPARATOR=':'
PERL=''
RANLIB=''
SET_MAKE=''
SHELL='/bin/sh'
STRIP=''
VERSION='0.3.0'
ac_ct_CC='gcc'
am__fastdepCC_FALSE=''
am__fastdepCC_TRUE=''
am__include=''
am__leading_dot='.'
am__quote=''
bindir='${exec_prefix}/bin'
build_alias='i486-slackware-linux'
datadir='${datarootdir}'
datarootdir='${prefix}/share'
docdir='/usr/doc/patchutils-0.3.0'
dvidir='${docdir}'
exec_prefix='NONE'
host_alias=''
htmldir='${docdir}'
includedir='${prefix}/include'
infodir='${datarootdir}/info'
install_sh='/tmp/SBo/patchutils-0.3.0/install-sh'
libdir='${exec_prefix}/lib'
libexecdir='${exec_prefix}/libexec'
localedir='${datarootdir}/locale'
localstatedir='${prefix}/var'
mandir='/usr/man'
oldincludedir='/usr/include'
pdfdir='${docdir}'
prefix='/usr'
program_transform_name='s,x,x,'
psdir='${docdir}'
sbindir='${exec_prefix}/sbin'
sharedstatedir='${prefix}/com'
sysconfdir='/etc'
target_alias=''

## ----------- ##
## confdefs.h. ##
## ----------- ##

#define PACKAGE_NAME "patchutils"
#define PACKAGE_TARNAME "patchutils"
#define PACKAGE_VERSION "0.3.0"
#define PACKAGE_STRING "patchutils 0.3.0"
#define PACKAGE_BUGREPORT ""
#define PACKAGE "patchutils"
#define VERSION "0.3.0"

configure: exit 77


spero possiate aiutarmi...



EDIT: RIsolto tutto...ho ovviato il problema scaricando i sorgenti di patchutils e successivamente anche perl-proc-processtable (questo l'ho preso da slackbuils.org)...poi ho continuato a seguire la guida, ho scaricato il firmware e l'ho piazzato in /lib/firmware, dopodichè ho installato w_scan e ho generato il file channels.conf che uso con xine...con mplayer quando vedevo un canale me lo dava a moviola mentre xine funziona benissimo....
TuxInTheMiddle
Linux 1.0
Linux 1.0
 
Messaggi: 25
Iscritto il: ven feb 10, 2012 23:05
Slackware: x86_64 - current
Kernel: 3.8.8
Desktop: fluxbox

Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti

cron