Repository 32bit  Forum
Repository 64bit  Wiki

[RIsolto] Arduino con ttyUSB0 che non esiste

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RIsolto] Arduino con ttyUSB0 che non esiste

Messaggioda rfringuello89 » ven set 20, 2013 18:29

Salve a tutti!
Stò provando a collegare il mio nuovo Arduino (Uno rev. 3) al pc su Slackware. Il problema è che non viene rilevata la connessione seriale-USB dal programma Arduino, presumo sia dovuto al fatto che non ho /dev/ttyUSB0
Anche se provo a "crearlo" (mknod /dev/ttyUSB0 c 188 0) esso non è accessibile.
Premetto che sul kernel non avevo niente di attivo per la porta seriale e ho attivato ciò che ho trovato riguardo USB serial.

Qualcuno può aiutarmi?

grazie
Ultima modifica di rfringuello89 il sab set 21, 2013 8:25, modificato 1 volta in totale.
"When you know Slackware, you know Linux… when you know Red Hat, all you know is Red Hat."
Avatar utente
rfringuello89
Linux 2.4
Linux 2.4
 
Messaggi: 238
Iscritto il: sab feb 21, 2009 18:47
Nome Cognome: Renato Fringuello
Slackware: 64 current
Kernel: 3.13.3
Desktop: kde 4.12.4 [Alien]

Re: Arduino con ttyUSB0 che non esiste

Messaggioda rfringuello89 » sab set 21, 2013 8:24

Risolto attivando anche Device Drivers -> USB support -> USB Modem (CDC ACM) support in quanto il device usa /dev/ttyACM0.
"When you know Slackware, you know Linux… when you know Red Hat, all you know is Red Hat."
Avatar utente
rfringuello89
Linux 2.4
Linux 2.4
 
Messaggi: 238
Iscritto il: sab feb 21, 2009 18:47
Nome Cognome: Renato Fringuello
Slackware: 64 current
Kernel: 3.13.3
Desktop: kde 4.12.4 [Alien]


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti