[Risolto] Installare qt-5 e qt-4

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
boh
Linux 4.x
Linux 4.x
Messaggi: 1027
Iscritto il: ven set 16, 2005 0:00
Slackware: 14.2 (x64)
Kernel: 4.4.111
Desktop: KDE 4.14.32
Località: Milano
Contatta:

[Risolto] Installare qt-5 e qt-4

Messaggioda boh » dom dic 27, 2015 20:19

Ciao a tutti e buone feste! :D

Vorrei provare calibre 2 che necessita della versione 5 delle qt (dipendenze qui).
Allo stesso tempo uso KDE 4.12.5 che si appoggia sulle qt4 (ho installato le qt-4.8.7 (default di slackware 14.1, se non sbaglio)).

Domanda semplice e veloce: c'è qualche controindicazione ad installare le qt5 assieme alle qt4?
Ultima modifica di boh il mer gen 06, 2016 18:04, modificato 1 volta in totale.
"Be yourself. Everyone else is already taken." ~ Oscar Wilde

Avatar utente
robbybby
Linux 4.x
Linux 4.x
Messaggi: 1223
Iscritto il: sab dic 16, 2006 10:48
Slackware: 13.1 / 64 bit
Kernel: 3.3.x
Desktop: KDE 4.4.5
Località: Fra Trantor e Terminus

Re: Installare qt-5 e qt-4

Messaggioda robbybby » dom dic 27, 2015 21:07

Io ho sempre installato Calibre in /opt con le sue istruzioni (da root), e non ho mai avuto problemi:
wget -nv -O- https://raw.githubusercontent.com/kovid ... staller.py | sudo python -c "import sys; main=lambda:sys.stderr.write('Download failed\n'); exec(sys.stdin.read()); main()"
omunque, per ritornare alla dmando qt5 assieme alle qt4: sì, si può fare senza problemi. Per lo meno, o ho installato il sistema di sviluppo qt5, dal loro sito, e tutto funziona senza problemi.
Il tutto su Slackware 14.1.

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2643
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.4.2
Desktop: lxde
Località: Pisa
Contatta:

Re: Installare qt-5 e qt-4

Messaggioda ponce » dom dic 27, 2015 23:09

anche la versione delle qt5 di SBo e' fatta per convivere pacificamente con le qt-4.x gia' presenti in Slackware (e credo anche quella di Alien Bob).

Avatar utente
boh
Linux 4.x
Linux 4.x
Messaggi: 1027
Iscritto il: ven set 16, 2005 0:00
Slackware: 14.2 (x64)
Kernel: 4.4.111
Desktop: KDE 4.14.32
Località: Milano
Contatta:

Re: Installare qt-5 e qt-4

Messaggioda boh » mer gen 06, 2016 18:03

Scusate il ritardo nella risposta, ma ho avuto tempo solo oggi di provare ad installare le qt5.
Tutto è andato liscio, calibre funziona e KDE non si è rotto, qundi siamo a posto :)
Grazie ancora! :D
"Be yourself. Everyone else is already taken." ~ Oscar Wilde