[ RISOLTO ] Problemi dopo aggiornamenti di sicurezza

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
cyberninja
Linux 1.x
Linux 1.x
Messaggi: 159
Iscritto il: gio mar 08, 2007 11:22

[ RISOLTO ] Problemi dopo aggiornamenti di sicurezza

Messaggioda cyberninja » sab mar 05, 2016 21:59

Salve a tutti!
Cercherò di essere conciso. :p
Oggi ho fatto gli aggiornamenti di sicurezza di febbraio segnati sul sito di Pat e improvvisamente Thunderbird e Acrobat Reader hanno smesso di funzionare.
Non ne sono sicuro ma penso dipenda dalle glibc.
L'advisory riguardava la libreria principale ma io, in un impeto di upgradite :D ho aggiornato anche le solib, timezone, i18n, insomma tutte le librerie collegate.
Ho provato a fare un downgrade di tutto ma non è servito. :(
Avete qualche suggerimento?
Per la cronaca: Thunderbird era l'ultima versione scaricata dal sito di Mozilla e Acrobat scaricato da Slackbuild.org.

Grazie mille!

Luca
Ultima modifica di cyberninja il mer mar 09, 2016 16:01, modificato 1 volta in totale.

Avatar utente
targzeta
Iper Master
Iper Master
Messaggi: 6538
Iscritto il: gio nov 03, 2005 14:05
Nome Cognome: Emanuele Tomasi
Slackware: 64-current
Kernel: latest stable
Desktop: IceWM
Località: Carpignano Sal. (LE) <-> Pisa

Re: Problemi dopo aggiornamenti di sicurezza

Messaggioda targzeta » dom mar 06, 2016 13:18

Ma lanciando Thunderbird da riga di comando non hai nessun messaggio di errore?

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà 

cyberninja
Linux 1.x
Linux 1.x
Messaggi: 159
Iscritto il: gio mar 08, 2007 11:22

Re: Problemi dopo aggiornamenti di sicurezza

Messaggioda cyberninja » dom mar 06, 2016 22:18

Ciao!
Scompattato l'archivio nella home e provato a lanciare l'eseguibile direttamente all'interno della directory.
Risposta: File o directory non esistente. :shock:
Uguale per Acrobat.
Ho reinstallato la versione di Thunderbird pacchettizzata ( è vecchia, ma era per provare ) e funziona. :roll:
Non ho la più pallida idea di cosa possa essersi sminchiato. :-k
Tra l'altro ho fatto un paio di controlli.
La patch per glibc era per Slackware 14.1 ( io ho 14.0 ) e veniva dal repository di alienbob ( ora l'ho disabilitato ).
Ho riscaricato e reinstallato l'ultima versione disponibile per 14.0 dal sito di Pat ma niente.
Ma che razza di danno posso aver combinato? #-o
Se non riesco a risolvere in breve tempo credo che rimetterò su un'immagine fatta ( per fortuna ) pochi giorni fa con Clonezilla.

cyberninja
Linux 1.x
Linux 1.x
Messaggi: 159
Iscritto il: gio mar 08, 2007 11:22

Problemi dopo aggiornamenti di sicurezza

Messaggioda cyberninja » mer mar 09, 2016 16:06

Ok, mi autorispondo.
Dopo aver installato l'ultima versione pacchettizzata disponibile per la 14.0 di Thunderbird ( 17.qualcosa... ) ho scaricato il tarball dell'ultimissima release dal sito di Mozilla.
Scompattato e lanciato funziona tutto perfettamente.
Per Acrobat invece non c'è stato niente da fare.
Eliminato dal sistema e passato a Okular.

Tutto è bene ciò che finisce bene. :D