Repository 32bit  Forum
Repository 64bit  Wiki

Problema riconoscimento cellulare

Usate questo forum per richieste di aiuto e consigli sull'hardware montato nelle vostre macchine con GNU/Linux Slackware.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata e la versione del Kernel. Questi dati aiutano le persone che possono rispondere.
2) Citare il tipo di hardware coinvolto in modo dettagliato.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT. Non usare termini gergali come procio, mobo e simili per identificare i componenti hardware.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Problema riconoscimento cellulare

Messaggioda Twenty-Seven » mar feb 19, 2013 0:54

Ciao ragazzi, scrivo per un problema col riconoscimento del cellulare da parte di un portatile (OS Slackware 14.0 64bit con KDE). Quello che devo fare è semplicemente collegare il cellulare per trasferire files, come se fosse una normalissima usb. Il problema è che il dispositivo viene visto ma non parte l' automount.

Se faccio lsusb lo vede:
Bus 002 Device 008: ID 0e8d:0002 MediaTek Inc.

dmesg mi dà:
[ 4293.336146] usb 2-3: new high-speed USB device number 8 using ehci_hcd
[ 4293.451524] usb 2-3: New USB device found, idVendor=0e8d, idProduct=0002
[ 4293.451532] usb 2-3: New USB device strings: Mfr=2, Product=3, SerialNumber=4
[ 4293.451539] usb 2-3: Product: MT6235
[ 4293.451545] usb 2-3: Manufacturer: MediaTek Inc
[ 4293.451550] usb 2-3: SerialNumber: 53548540003120f
[ 4293.452584] scsi12 : usb-storage 2-3:1.0

/var/log/messages dà:
Feb 19 00:24:21 darkstar kernel: [ 4293.336146] usb 2-3: new high-speed USB device number 8 using ehci_hcd
Feb 19 00:24:21 darkstar kernel: [ 4293.451524] usb 2-3: New USB device found, idVendor=0e8d, idProduct=0002
Feb 19 00:24:21 darkstar kernel: [ 4293.451532] usb 2-3: New USB device strings: Mfr=2, Product=3, SerialNumber=4
Feb 19 00:24:21 darkstar kernel: [ 4293.451539] usb 2-3: Product: MT6235
Feb 19 00:24:21 darkstar kernel: [ 4293.451545] usb 2-3: Manufacturer: MediaTek Inc
Feb 19 00:24:21 darkstar kernel: [ 4293.451550] usb 2-3: SerialNumber: 53548540003120f
Feb 19 00:24:21 darkstar kernel: [ 4293.452584] scsi12 : usb-storage 2-3:1.0
Feb 19 00:24:21 darkstar mtp-probe: checking bus 2, device 8: "/sys/devices/pci0000:00/0000:00:1d.7/usb2/2-3"
Feb 19 00:24:21 darkstar mtp-probe: bus: 2, device: 8 was not an MTP device
Feb 19 00:24:22 darkstar usb_modeswitch: switching device 0e8d:0002 on 002/008

Però se faccio fdisk -l non vede niente, solo le due partizioni dell' hard disk.

Col portatile di mio padre che ha Ubuntu il cellulare viene visto e automontato tranquillamente, appena lo inserisco vengono montati due filesystem, uno della memoria interna del cellulare e uno della schedina di memoria. Qualcuno ha idea di come mai con Slackware venga visto ma sia impossibile montarlo?

Grazie
Twenty-Seven
Linux 1.0
Linux 1.0
 
Messaggi: 31
Iscritto il: dom gen 27, 2013 14:59
Slackware: 13.0.0 32bit
Kernel: 2.6.29.6
Desktop: KDE

Re: Problema riconoscimento cellulare

Messaggioda wakkokid » mar feb 19, 2013 17:50

In breve, se è come il mio Galazy nexus, il cellulare non viene visto come una memoria di massa, ma come dispositivo MTP.
Sotto Opensuse, ho dovuto installare libmtp e dei componenti relativi a mtp di kde o dolphin (ora come ora non ricordo quali, mi dispiace, quando ho di nuovo sotto mano il mio portatile darò un'occhiata)
Avatar utente
wakkokid
Linux 2.4
Linux 2.4
 
Messaggi: 338
Iscritto il: gio gen 27, 2005 0:00
Kernel: 2.6.3*
Desktop: Kde4
Distribuzione: Debian

Re: Problema riconoscimento cellulare

Messaggioda Twenty-Seven » mar feb 19, 2013 23:11

Grazie per la risposta. Questa sera ho provato a collegare il cellulare al mio pc di casa (che ha slackware 13.0 a 32bit, kernel 2.6.29.6), e me lo ha automontato tranquillamente. Me lo vede come due dispositivi (memoria telefono + memoria schedina sd) esattamente come ubuntu.

dmesg mi da:

usb 1-7: new high speed USB device using ehci_hcd and address 6
usb 1-7: New USB device found, idVendor=0e8d, idProduct=0002
usb 1-7: New USB device strings: Mfr=2, Product=3, SerialNumber=4
usb 1-7: Product: MT6235
usb 1-7: Manufacturer: MediaTek Inc
usb 1-7: SerialNumber: 53548540003120f
usb 1-7: configuration #1 chosen from 1 choice
scsi11 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 6
usb-storage: waiting for device to settle before scanning
scsi 11:0:0:0: Direct-Access MEDIATEK FLASH DISK 6235 PQ: 0 ANSI: 0 CCS
sd 11:0:0:0: [sdf] 3862528 512-byte hardware sectors: (1.97 GB/1.84 GiB)
sd 11:0:0:0: [sdf] Write Protect is off
sd 11:0:0:0: [sdf] Mode Sense: 03 00 00 00
sd 11:0:0:0: [sdf] Assuming drive cache: write through
sd 11:0:0:0: [sdf] 3862528 512-byte hardware sectors: (1.97 GB/1.84 GiB)
sd 11:0:0:0: [sdf] Write Protect is off
sd 11:0:0:0: [sdf] Mode Sense: 03 00 00 00
sd 11:0:0:0: [sdf] Assuming drive cache: write through
sdf: sdf1
sd 11:0:0:0: [sdf] Attached SCSI removable disk
sd 11:0:0:0: Attached scsi generic sg6 type 0
scsi 11:0:0:1: Direct-Access MEDIATEK FLASH DISK 6235 PQ: 0 ANSI: 0 CCS
sd 11:0:0:1: [sdg] 120000 512-byte hardware sectors: (61.4 MB/58.5 MiB)
sd 11:0:0:1: [sdg] Write Protect is off
sd 11:0:0:1: [sdg] Mode Sense: 03 00 00 00
sd 11:0:0:1: [sdg] Assuming drive cache: write through
sd 11:0:0:1: [sdg] 120000 512-byte hardware sectors: (61.4 MB/58.5 MiB)
sd 11:0:0:1: [sdg] Write Protect is off
sd 11:0:0:1: [sdg] Mode Sense: 03 00 00 00
sd 11:0:0:1: [sdg] Assuming drive cache: write through
sdg:
sd 11:0:0:1: [sdg] Attached SCSI removable disk
sd 11:0:0:1: Attached scsi generic sg7 type 0
usb-storage: device scan complete
usb 1-7: USB disconnect, address 6

A questo punto penso che sia qualche modulo del kernel, presente nella 13.0 ma non nella 14.0, o qualcosa del genere. Spero che qualcuno mi sappia consigliare su dove andare a guardare.
Twenty-Seven
Linux 1.0
Linux 1.0
 
Messaggi: 31
Iscritto il: dom gen 27, 2013 14:59
Slackware: 13.0.0 32bit
Kernel: 2.6.29.6
Desktop: KDE


Torna a Hardware

Chi c’è in linea

Visitano il forum: Exabot [Bot] e 1 ospite