Repository 32bit  Forum
Repository 64bit  Wiki

wireless su extensa 5220 instabile

Scrivete su questo forum se avete problemi o volete dare buoni consigli sui computer portatili (Laptop).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare il modello preciso del laptop in questione.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

wireless su extensa 5220 instabile

Messaggioda emmexx » lun gen 05, 2009 16:26

Ciao a tutti,

ho un problema con la connessione wireless sul mio portatile Acer Extensa 5220.
La scheda e' una bcm4311
Codice: Seleziona tutto
04:00.0 Network controller: Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 01)
        Subsystem: AMBIT Microsystem Corp. Unknown device 0422
        Flags: bus master, fast devsel, latency 0, IRQ 17
        Memory at f8000000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: [40] Power Management version 2
        Capabilities: [58] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
        Capabilities: [d0] Express Legacy Endpoint, MSI 00
        Capabilities: [100] Advanced Error Reporting <?>
        Capabilities: [13c] Virtual Channel <?>
        Kernel driver in use: b43-pci-bridge
        Kernel modules: bcm43xx, ssb


Monto slackware 12.1, con kernel non ricompilato 2.6.24.5-smp
La connessione la effettuo ad un ap Us robotics usrxx5462. Utilizzo WPA con pre shared key.
La connessione avviene, non mi pare ci siano problemi di configurazione. Il problema e' la stabilita' altalenante. Puo' capitare che la connessione rimanga stabile per giornate intere, dopo riavvii e spegnimenti cosi' come puo' succedere che per giorni la connessione continui a cadere. Ad esempio stamattina la connessione e' stata stabile sino alle 12 poi ha cominciato a cadere e la devo ripristinare (quando va bene) o devo chiudere, spegnere, riavviare, per riuscire a connettermi di nuovo (killall wpa_supplicant, rmmod b43, ecc.)
Il nb monta vista e le rare volte in cui lo uso questo problema non si verifica. Saltuariamente ho usato anche altri AP ma non sufficientemente a lungo per sapere che il problema sia la coppia bcm4311 usr5462. Altri dispositivi che ho usato si connettono al mio ap tranquillamente e stabilmente.

Qualche suggerimento?

grazie
maxx

/etc/wpa_supplicant.conf:
Codice: Seleziona tutto
 ctrl_interface=/var/run/wpa_supplicant
 ctrl_interface_group=0
 eapol_version=1
 ap_scan=1
 fast_reauth=1

network={
  scan_ssid=0
  ssid="miaretewlan"
  proto=WPA
  key_mgmt=WPA-PSK #con ndiswrapper
  pairwise=CCMP TKIP
  group=CCMP TKIP WEP104 WEP40
  psk=passwordmoltodifficileinesadecimale
}


comando per wpa_supplicant:
Codice: Seleziona tutto
wpa_supplicant -Bw -Dwext -c/etc/wpa_supplicant.conf -iwlan0


Gli errori che si verificano.
wpa_supplicant:
Codice: Seleziona tutto
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 - ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 5 value 0x1 - Trying to associate with xx:xx (SSID='miaretewlan' freq=2462 MHz)
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 5 value 0x1 - Authentication with xx:xx timed out.
Trying to associate with xx:xx (SSID='miaretewlan' freq=2462 MHz)
ioctl[SIOCSIWAUTH]: Operation not supported


dmesg:
Codice: Seleziona tutto
wlan0: Initial auth_alg=0
wlan0: authenticate with AP xx:xx
wlan0: RX authentication from xx:xx (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP xx:xx
wlan0: RX ReassocResp from xx:xx (capab=0x431 status=0 aid=4)
wlan0: associated
wlan0: switched to short barker preamble (BSSID=xx:xx)
wlan0: disassociate(reason=3)
input: b43-phy0 as /devices/virtual/input/input16
Registered led device: b43-phy0:tx
Registered led device: b43-phy0:rx
Registered led device: b43-phy0:radio
ADDRCONF(NETDEV_UP): wlan0: link is not ready
wlan0: Initial auth_alg=0
wlan0: authenticate with AP xx:xx
wlan0: authenticate with AP xx:xx
wlan0: authenticate with AP xx:xx
wlan0: authentication with AP xx:xx timed out
wlan0: authentication frame received from xx:xx, but not in authenticate state - ignored
wlan0: authentication frame received from xx:xx, but not in authenticate state - ignored
wlan0: authentication frame received from xx:xx, but not in authenticate state - ignored
wlan0: Initial auth_alg=0
wlan0: authenticate with AP xx:xx
wlan0: authenticate with AP xx:xx
wlan0: authenticate with AP xx:xx
wlan0: authentication with AP xx:xx timed out
wlan0: authentication frame received from xx:xx, but not in authenticate state - ignored
emmexx
Linux 1.0
Linux 1.0
 
Messaggi: 18
Iscritto il: lun gen 05, 2009 14:37
Slackware: 12.1
Kernel: 2.6.24.5-smp
Desktop: kde

Re: wireless su extensa 5220 instabile

Messaggioda Darkstar89 » mar gen 06, 2009 0:24

Secondo me faresti meglio ad installare wicd (la vecchia versione) io lo uso, ha un'interfaccia grafica e ha molte altre cose a me funziona bene....
P.S.. Io ho provato ad installare wicd 1.5.x (l'ultima versione) sulla 12.1 e non funzionava! usa quella 1.4.x
:D
Avatar utente
Darkstar89
Packager
Packager
 
Messaggi: 372
Iscritto il: mer dic 17, 2008 19:06
Località: Sassari
Nome Cognome: Francesco
Slackware: 13

Re: wireless su extensa 5220 instabile

Messaggioda emmexx » mer gen 07, 2009 11:12

Darkstar89 ha scritto:Secondo me faresti meglio ad installare wicd (la vecchia versione) io lo uso, ha un'interfaccia grafica e ha molte altre cose a me funziona bene....
P.S.. Io ho provato ad installare wicd 1.5.x (l'ultima versione) sulla 12.1 e non funzionava! usa quella 1.4.x
:D


In effetti anche con wicd non funzionava ma avevo usato la 1.5.0.

Comunque credo che il problema sia a livello di driver. Ad esempio quando la connessione cade e non si riprende il driver non sembra comportarsi correttamente: se spengo e accendo fisicamente la scheda (con l'apposito segnale) il driver non me lo segnala, mentre di solito in dmesg trovo
Codice: Seleziona tutto
b43-phy3: Radio hardware status changed to DISABLED


Provo con wicd e se ancora non va passo a slack 12.2 per vedere se i nuovi driver b43 funzionano meglio.

grazie
maxx
emmexx
Linux 1.0
Linux 1.0
 
Messaggi: 18
Iscritto il: lun gen 05, 2009 14:37
Slackware: 12.1
Kernel: 2.6.24.5-smp
Desktop: kde

Re: wireless su extensa 5220 instabile

Messaggioda emmexx » dom feb 01, 2009 18:28

Credo di avere finalmente capito il problema della bizzarra instabilita' della connessione wireless del mio notebook: muri ed ostacoli. :-(
A quanto pare la connessione cade o rimane stabile per ore semplicemente perche' appoggio il notebook alla scrivania 2-3 centimetri piu' o meno avanti o indietro.
Evidentemente bastano quei pochi centimentri affinche' il router venga "visto" e la connessione non cada. Il router e' posizionato in basso e suppongo quindi che anche lo spessore della scrivania e del notebook facciano da schermo.
Ho anche verificato che se la connessione cade basta sollevare di 40-50 cm il nb e la connessione si riprende.

ciao
maxx
emmexx
Linux 1.0
Linux 1.0
 
Messaggi: 18
Iscritto il: lun gen 05, 2009 14:37
Slackware: 12.1
Kernel: 2.6.24.5-smp
Desktop: kde


Torna a Laptop

Chi c’è in linea

Visitano il forum: Bing [Bot] e 1 ospite