Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] installazione programma

Scrivete su questo forum se avete problemi o volete dare buoni consigli sui computer portatili (Laptop).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare il modello preciso del laptop in questione.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO] installazione programma

Messaggioda deadcandance » gio dic 23, 2010 17:27

salve a tutti...
allora dovrei installare un programma che mi serve per studiare su slackware..il programma in questione è proengineer 3.0.....
ora qualche tempo fa avevo gia installato questo programma su slack 13.1 senza problemi,e siccome poi ho dovuto formattare tutto quanto,ora devo appunto reinstallare...
premettendo che questo funzionava senza alcun problema prima,ed in maniera del tutto fluida,ora quando avvio l'installazione con il comando ./setup mi da il seguente errore:
Codice: Seleziona tutto
failed to display splash dialog


normalmente i pacchetti che avrebbe richiesto per una installazione su una debian erano questi:
Codice: Seleziona tutto
CSH libmotif3 libGTK1.2 xinetd portmap

ma qui in questo caso non mi dice altro oltre che il messaggio sopra riportato...

qualcuno sa darmi qualche consiglio?

grazie ciao
Ultima modifica di deadcandance il dom dic 26, 2010 3:31, modificato 1 volta in totale.
deadcandance
Linux 2.0
Linux 2.0
 
Messaggi: 123
Iscritto il: ven ago 20, 2010 12:23
Slackware: 13
Desktop: xfce4
Distribuzione: debian

Re: installazione programma

Messaggioda freefred » gio dic 23, 2010 18:36

deadcandance ha scritto:salve a tutti...
Codice: Seleziona tutto
failed to display splash dialog


normalmente i pacchetti che avrebbe richiesto per una installazione su una debian erano questi:
Codice: Seleziona tutto
CSH libmotif3 libGTK1.2 xinetd portmap




Scusa la domanda forse ovvia, questi pacchetti li hai anche su Slackware?
Hai installato Motif, o OpenMotif?
Ma la butto li' eh..e' che l'errore sembra dato dal fatto che non riesca a tirarti
su un'interfaccia grafica.

Se ho detto un'assurdita', pazienza:-)

bye
Avatar utente
freefred
Linux 1.0
Linux 1.0
 
Messaggi: 87
Iscritto il: dom set 28, 2008 18:08
Slackware: 13.1
Kernel: 2.6.36.2
Desktop: kde 4.4.3

Re: installazione programma

Messaggioda hashbang » gio dic 23, 2010 18:46

deadcandance ha scritto:normalmente i pacchetti che avrebbe richiesto per una installazione su una debian erano questi:
Codice: Seleziona tutto
CSH libmotif3 libGTK1.2 xinetd portmap
Le hai risolte le dipendenze?

Comunque nella Slackware sono presenti i seguenti pacchetti, quindi dovresti averli in caso contrario controlla in /var/log/packages

csh
gtk 1.2
portmap
inetd (xinetd è una reimplementazione, non so se sia necessaria, in tal caso va compilata)

libmotif3 non c'è. Slackware usa Lesstif, che è un clone. Nella stragrande maggioranza dei casi funziona. In altri casi però servono le vere librerie Motif. Quelle le trovi nel nostro repository a 32 bit col nome di OpenMotif.

ATTENZIONE: OpenMotif non può coesistere con Lesstif. Quindi se vuoi usare OpenMotif dovrai eliminare Lesstif. Nel caso in cui tu scelga l'uso di OpenMotif, potresti incorrere in malfunzionamenti con pacchetti della slackware come xpdf, che sono stati compilati con Lesstif, risolvibili solo con la loro ricompilazione.
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1842
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Re: installazione programma

Messaggioda deadcandance » ven dic 24, 2010 2:38

il problema non credo stia nei pacchetti...anche perchè precedentemente non ho avuto particolarmente problemi,anzi a dire il vero non li ho dovuti installare perchè erano gia presenti...
comunque ho fatto una prova anche su debian e qui il messaggio è un po diverso...
Codice: Seleziona tutto
./setup: 121: /mnt/getpmt.csh: not found

Starting PTC.Setup, please wait ...
ERROR:  /mnt/dsrc//obj/ptcsetup - file is missing.
        Check the name of the CD mount directory.


a quanto pare manca qualcosa...a questo punto vi chiedo,credete che io possa risolvere in qualche modo o devo procurare nuovamente il programma!?

avete qualche consiglio?
grazie per le risposte...
ciao
deadcandance
Linux 2.0
Linux 2.0
 
Messaggi: 123
Iscritto il: ven ago 20, 2010 12:23
Slackware: 13
Desktop: xfce4
Distribuzione: debian

Re: installazione programma

Messaggioda freefred » ven dic 24, 2010 9:12

deadcandance ha scritto:il problema non credo stia nei pacchetti...anche perchè precedentemente non ho avuto particolarmente problemi,anzi a dire il vero non li ho dovuti installare perchè erano gia presenti...


Mah..come dice giustamente Atomix su una Slack pura la libreria libmotif3 non c'e', e l'errore
che ti da' sembra relativo al fatto che non riesce nemmeno appunto a tirarti su lo splash.
Io proverei ad installare OpenMotif, poi al limite lo disinstalli.


comunque ho fatto una prova anche su debian e qui il messaggio è un po diverso...
Codice: Seleziona tutto
./setup: 121: /mnt/getpmt.csh: not found

Starting PTC.Setup, please wait ...
ERROR:  /mnt/dsrc//obj/ptcsetup - file is missing.
        Check the name of the CD mount directory.


a quanto pare manca qualcosa...a questo punto vi chiedo,credete che io possa risolvere in qualche modo o devo procurare nuovamente il programma!?


Il cd viene montato effettivamente in /mnt/dsrc?
C'e' (ma immagino di si') il file /obj/ptcsetup?

Vado pero' un po' a braccio perche' proE l'ho sempre solo visto su windows, e installarlo era sempre
un po' una palla, ma alla fine c'eravamo fatti un doc abbastanza chiaro, e sopratutto alla bisogna avevamo
due consulenti PTC:-)

bye
Avatar utente
freefred
Linux 1.0
Linux 1.0
 
Messaggi: 87
Iscritto il: dom set 28, 2008 18:08
Slackware: 13.1
Kernel: 2.6.36.2
Desktop: kde 4.4.3

Re: installazione programma

Messaggioda deadcandance » ven dic 24, 2010 15:21

giuro che non capisco....
il file che dici c'è ma si trova in /mnt/dsrc/i486_linux/obj/ptcsetup mentre lui riporta questo indirizzo
/mnt/dsrc//obj/ptcsetup
perchè l'indirizzo che riporta è sbagliato?
deadcandance
Linux 2.0
Linux 2.0
 
Messaggi: 123
Iscritto il: ven ago 20, 2010 12:23
Slackware: 13
Desktop: xfce4
Distribuzione: debian

Re: installazione programma

Messaggioda deadcandance » ven dic 24, 2010 17:57

ho individuato il problema...
bisogna installare il pacchetto tcsh oppure csh....solo che non riesco a trovarli per slackware...

a quanto pare da questo messaggio che mi da
Codice: Seleziona tutto
/bin/csh: error while loading shared libraries: libtinfo.so.5: cannot open shared object file: No such file or directory

vuole quella libreria che credo potrò installare solo installando il pacchetto csh o tcsh....solo che non riesco a trovarlo....
deadcandance
Linux 2.0
Linux 2.0
 
Messaggi: 123
Iscritto il: ven ago 20, 2010 12:23
Slackware: 13
Desktop: xfce4
Distribuzione: debian

Re: installazione programma

Messaggioda freefred » sab dic 25, 2010 0:38

deadcandance ha scritto:ho individuato il problema...
bisogna installare il pacchetto tcsh oppure csh....solo che non riesco a trovarli per slackware...

a quanto pare da questo messaggio che mi da
Codice: Seleziona tutto
/bin/csh: error while loading shared libraries: libtinfo.so.5: cannot open shared object file: No such file or directory

vuole quella libreria che credo potrò installare solo installando il pacchetto csh o tcsh....solo che non riesco a trovarlo....


No la csh (C shell) o piu' probabilmente la tcsh dovresti averla installata su una Slackware.
La libtinfo dovrebbe far parte delle ncusrses e forse proE la cerca ancora da sola.
(in rete dicono sia un errore del software, non ne so abbastanza devo dire)

Potresti provare a fare un link simbolico come viene detto in alcuni forum:
Codice: Seleziona tutto
$ cd /lib
$ ln -s libncurses.so.5 libtinfo.so.5
$ ln -s libtinfo.so.5 libtinfo.so

e vedere se proE trova la libreria.

bye
Avatar utente
freefred
Linux 1.0
Linux 1.0
 
Messaggi: 87
Iscritto il: dom set 28, 2008 18:08
Slackware: 13.1
Kernel: 2.6.36.2
Desktop: kde 4.4.3

Re: installazione programma

Messaggioda deadcandance » dom dic 26, 2010 3:31

ciao...
allora sono riuscito a risolvere,ma non so dirvi esattamente come e quale fosse la causa....
in pratica ho disinstallato kde,perchè è un desktop che non mi piace,e mi fa solo uscire pazzo,ed una volta levato dalle scatole l'installazione è partita senza alcun problema...credo dunque che il per risolvere bastava rimuovere qualche pacchetto che che era incluso in kde...il problema ora diventa individuare quale fosse questo pacchetto!!!
grazie per l'aiuto
ciao ciao
deadcandance
Linux 2.0
Linux 2.0
 
Messaggi: 123
Iscritto il: ven ago 20, 2010 12:23
Slackware: 13
Desktop: xfce4
Distribuzione: debian


Torna a Laptop

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti