Slackyd: Rinascita!

Forum dedicato alla programmazione.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il linguaggio di programmazione usato.
2) Se possibile portare un esempio del risultato atteso.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
ZeroUno
Staff
Staff
Messaggi: 4936
Iscritto il: ven giu 02, 2006 14:52
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current
Località: Roma / Castelli
Contatta:

Re: Slackyd: Rinascita!

Messaggioda ZeroUno » mer mag 18, 2011 15:43

io non applico nulla, lo lascio fare all'autore. Io propongo solamente e quando uscirà come release (1.0.1) allora pacchettizzerò (se qualcuno non lo fa prima di me).

Comunque quella che ho fatto è una bozza giusto per far capire cosa intendevo, e per toccare meno possibile il codice. Si può di sicuro far di meglio.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg

Codice: Seleziona tutto

1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111

Avatar utente
shark1500
Linux 2.6
Linux 2.6
Messaggi: 785
Iscritto il: gio apr 03, 2008 14:33
Slackware: current
Kernel: 2.6.27.7-smp
Desktop: kde
Località: Modna

Re: Slackyd: Rinascita!

Messaggioda shark1500 » mer mag 18, 2011 15:52

Sisi, infatti l'ho capito, poi ci guardero` meglio, ad ogni modo se ti senti in grado di fare la patch non ho alcun problema ad applicarla al codice su github con il tuo nome (se ti interessa)

Avatar utente
ZeroUno
Staff
Staff
Messaggi: 4936
Iscritto il: ven giu 02, 2006 14:52
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current
Località: Roma / Castelli
Contatta:

Re: Slackyd: Rinascita!

Messaggioda ZeroUno » mer mag 18, 2011 18:07

Meglio una patch ben fatta che il mio nome da qualche parte.
Vedi la patch dell'md5 o quella del wget. Le originali le ho fatte io, ma quello che è rimasto dentro il codice di mio è solo l'idea, e ne sono contento perchè le parti che avevo scritto io era una accozzaglia disordinata (fondamentalmente non posso dire di conoscere il C come si deve; ma google si ;-), e mi posso vantare di conoscere bene il copia-incolla). E' stata rielaborata l'idea, riscritto il codice ed integrato nei punti più giusti e ordinati.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg

Codice: Seleziona tutto

1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111

Avatar utente
Blallo
Packager
Packager
Messaggi: 3272
Iscritto il: ven ott 12, 2007 11:37
Nome Cognome: Savino Liguori
Slackware: 14.2 / 12.2
Kernel: 4.4.14-smp
Desktop: DWM
Località: Torino / Torremaggiore (FG)
Contatta:

Re: Slackyd: Rinascita!

Messaggioda Blallo » gio mag 19, 2011 23:34

Ho riscontrato un errore: non scarica glibmm

Codice: Seleziona tutto

Download gtkmm-2.24.0-x86_64-1sl.txz [from slacky] ? [y/N] y
>> Required atkmm >= 2.22.4 [by gtkmm-2.24.0-x86_64-1sl.txz]
Download atkmm-2.22.4-x86_64-1sl.txz [from slacky] ? [y/n] y
** Warning: missing glibmm >= 2.27.99.2 required by atkmm
>> Required libsigc++ >= 2.2.9 [by atkmm-2.22.4-x86_64-1sl.txz]
Download libsigc++-2.2.9-x86_64-1sl.txz [from slacky] ? [y/n] y
>> Required cairomm >= 1.9.8 [by gtkmm-2.24.0-x86_64-1sl.txz]
Download cairomm-1.9.8-x86_64-1sl.txz [from slacky] ? [y/n] y
** Warning: missing glibmm >= 2.27.99.2 required by gtkmm
>> Required pangomm >= 2.28.1 [by gtkmm-2.24.0-x86_64-1sl.txz]
Download pangomm-2.28.1-x86_64-1sl.txz [from slacky] ? [y/n] y
** Warning: missing glibmm >= 2.27.99.2 required by pangomm

Problema di mirror o di slackyd?
My DWM configuration: https://github.com/8lall0/dwm

Feel free to use.

Avatar utente
shark1500
Linux 2.6
Linux 2.6
Messaggi: 785
Iscritto il: gio apr 03, 2008 14:33
Slackware: current
Kernel: 2.6.27.7-smp
Desktop: kde
Località: Modna

Re: Slackyd: Rinascita!

Messaggioda shark1500 » ven mag 20, 2011 10:21

Penso che sia un problema di mirror. Ho provato a scaricare le glibmm dal mirror della 13.1 e funziona perfettamente

Avatar utente
zoros
Linux 3.x
Linux 3.x
Messaggi: 1317
Iscritto il: lun mag 28, 2007 22:51
Nome Cognome: Fabio`Zorba`
Slackware: 14.1
Kernel: 3.10.30-smp
Desktop: KDE-3.5(works!)
Località: Gorizia
Contatta:

Re: Slackyd: Rinascita!

Messaggioda zoros » sab mag 28, 2011 21:49

problema: ho installato alcuni txz della 13.1 per errore sulla 13.37 ... slackyd non mi scarica quelli nuovi, exempio

Codice: Seleziona tutto

bash-4.1# slackyd -l audacity

Installed packages "audacity": 1

 -> audacity-1.3.12_beta-i486-3sl

bash-4.1#


Codice: Seleziona tutto

bash-4.1# slackyd -g audacity

Searching audacity-1.3.13: found 1 package.

audacity-1.3.13-i486-3sl.txz [from slacky]

*** audacity-1.3.13-i486-3sl.txz: already installed (audacity-1.3.12_beta-i486-3sl).

All packages available are installed.



devo rimuovere quello installato e poi scarica ... sarebbe più comodo se scarica comunque, così si usa upgradepkg ...
vorrei riavere le mie firme ...

Avatar utente
ZeroUno
Staff
Staff
Messaggi: 4936
Iscritto il: ven giu 02, 2006 14:52
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current
Località: Roma / Castelli
Contatta:

Re: Slackyd: Rinascita!

Messaggioda ZeroUno » sab mag 28, 2011 22:34

Hai provato con il parametro -I ?

matteo@matteo:~$ slackyd -g slackyd

Searching slackyd: found 1 package.

slackyd-0.1.13.3beta-x86_64-1sl.txz [from slacky]

*** slackyd-0.1.13.3beta-x86_64-1sl.txz: already installed (slackyd-1.0-x86_64-1sl).

All packages available are installed.

matteo@matteo:~$ slackyd -I -g slackyd

Searching slackyd: found 1 package.

slackyd-0.1.13.3beta-x86_64-1sl.txz [from slacky]

Download slackyd-0.1.13.3beta-x86_64-1sl.txz [from slacky] ? [y/N]
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg

Codice: Seleziona tutto

1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111

Avatar utente
zoros
Linux 3.x
Linux 3.x
Messaggi: 1317
Iscritto il: lun mag 28, 2007 22:51
Nome Cognome: Fabio`Zorba`
Slackware: 14.1
Kernel: 3.10.30-smp
Desktop: KDE-3.5(works!)
Località: Gorizia
Contatta:

Re: Slackyd: Rinascita!

Messaggioda zoros » sab mag 28, 2011 23:04

sì, funziona, ho messo 4 repository nel mio conf:

Codice: Seleziona tutto

bash-4.1# slackyd -I -g audacity

Searching audacity: found 4 packages.

audacity-1.3.9-i486-1sl.txz [from slacky1]
audacity-1.3.8-i486-1sl.tgz [from slacky2]
audacity-1.3.13-i486-3sl.txz [from slacky]
audacity-1.3.13-i486-1sl.txz [from slacky0]

Found 4 different version of audacity:
 --> audacity-1.3.9-i486-1sl.txz
 --> audacity-1.3.8-i486-1sl.tgz
 --> audacity-1.3.13-i486-3sl.txz
 --> audacity-1.3.13-i486-1sl.txz
Download audacity-1.3.9-i486-1sl.txz [from slacky1] ? [y/N] n
Download audacity-1.3.8-i486-1sl.tgz [from slacky2] ? [y/N] n
Download audacity-1.3.13-i486-3sl.txz [from slacky] ? [y/N] y

Downloading audacity-1.3.13-i486-3sl.txz. [Already downloaded]
* Verify md5 checksum: ok.

thanks ZeroUno

slackyd -h in effetti segnala lo switch -I ... mi sono fidato della pagina di help: http://slacky.eu/~dani/slackyd/ citata in home-community: http://www.slacky.eu/index.php?option=c ... 0&Itemid=1 ... che evidentemente è incompleta così come quella derivata nel wiki :(
vorrei riavere le mie firme ...

Avatar utente
zoros
Linux 3.x
Linux 3.x
Messaggi: 1317
Iscritto il: lun mag 28, 2007 22:51
Nome Cognome: Fabio`Zorba`
Slackware: 14.1
Kernel: 3.10.30-smp
Desktop: KDE-3.5(works!)
Località: Gorizia
Contatta:

Re: Slackyd: Rinascita!

Messaggioda zoros » dom mag 29, 2011 0:19

ripensandoci,

però sono comunque "insoddisfatto", nel mio post precedente:

Codice: Seleziona tutto

...
*** audacity-1.3.13-i486-3sl.txz: already installed (audacity-1.3.12_beta-i486-3sl)

slackyd mi dice che il pacchetto è già installato, malgrado la versione installata sia numericamente inferiore ... ciò crea confusione :roll: ...
vorrei riavere le mie firme ...

Avatar utente
Loris
Admin
Admin
Messaggi: 7666
Iscritto il: lun mar 31, 2003 0:00
Nome Cognome: Loris Vincenzi
Slackware: 14.1
Kernel: 3.10.17
Desktop: Kde 4.10.5
Località: Gradisca D'Isonzo
Contatta:

Re: Slackyd: Rinascita!

Messaggioda Loris » mer giu 08, 2011 13:42

Cosa vi dice il comando?

Codice: Seleziona tutto

slackyd -g perl-tk

il pacchetto è presente nel repository ma non viene trovato :-k
"Ho una testa piuttosto balzana e comunque non sono quello che credete" - Roger Keith Barrett

Avatar utente
Blallo
Packager
Packager
Messaggi: 3272
Iscritto il: ven ott 12, 2007 11:37
Nome Cognome: Savino Liguori
Slackware: 14.2 / 12.2
Kernel: 4.4.14-smp
Desktop: DWM
Località: Torino / Torremaggiore (FG)
Contatta:

Re: Slackyd: Rinascita!

Messaggioda Blallo » mer giu 08, 2011 13:52

anche io non lo trovo :(
My DWM configuration: https://github.com/8lall0/dwm

Feel free to use.

Avatar utente
hashbang
Packager
Packager
Messaggi: 1951
Iscritto il: ven giu 04, 2010 10:27
Nome Cognome: Luca De Pandis
Slackware: Slackware64-current
Kernel: 4.4.12
Desktop: dwm
Distribuzione: Windows 10 Pro
Località: Lecce
Contatta:

Re: Slackyd: Rinascita!

Messaggioda hashbang » mer giu 08, 2011 15:12

Codice: Seleziona tutto

$ slackyd -g perl-tk

Searching perl-tk: found 1 package.

perl-tk-804.029-i486-3sl.txz [from slacky]

Download perl-tk-804.029-i486-3sl.txz [from slacky] ? [y/N]


A me lo trova.... :-k
There's a certain kind of programmer who'll look at any problem and say, 'I know, I will use XML.' Now he has two problems.

Stack is the new term for "I have no idea what I'm actually using". [Erich Schubert]

Avatar utente
Blallo
Packager
Packager
Messaggi: 3272
Iscritto il: ven ott 12, 2007 11:37
Nome Cognome: Savino Liguori
Slackware: 14.2 / 12.2
Kernel: 4.4.14-smp
Desktop: DWM
Località: Torino / Torremaggiore (FG)
Contatta:

Re: Slackyd: Rinascita!

Messaggioda Blallo » mer giu 08, 2011 15:16

ah, ma io sono su 64 bit...
My DWM configuration: https://github.com/8lall0/dwm

Feel free to use.

Avatar utente
shark1500
Linux 2.6
Linux 2.6
Messaggi: 785
Iscritto il: gio apr 03, 2008 14:33
Slackware: current
Kernel: 2.6.27.7-smp
Desktop: kde
Località: Modna

Re: Slackyd: Rinascita!

Messaggioda shark1500 » mer giu 08, 2011 16:49

Anche a me lo trova..loris, sei su 32bit?

Avatar utente
ZeroUno
Staff
Staff
Messaggi: 4936
Iscritto il: ven giu 02, 2006 14:52
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current
Località: Roma / Castelli
Contatta:

Re: Slackyd: Rinascita!

Messaggioda ZeroUno » mer giu 08, 2011 21:18

ZeroUno ha scritto:

Codice: Seleziona tutto

diff -ur src-orig/func.c src/func.c
.....

# slackyd
Usage: ./slackyd <options> <package>

Options:
...
-t: Specify a path to download packages


# slackyd -t /tmp -g ssldump


Ho corretto la patch (un bug che non faceva identificare correttamente il path del pacchetto nella verifica dell'md5).
Allego anche lo slackbuild e il pacchetto per chi lo vuole provare.



Ma alla fine è stato più messo sotto github?

P.S: questo topic piuttosto che in "Programmazione" dovrebbe essere in "Packages"
Allegati
slackyd-1.0p2.tar.gz
(3.88 KiB) Scaricato 158 volte
slackyd-1.0p2-x86_64-1mt.txz.gz
(52.13 KiB) Scaricato 166 volte
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg

Codice: Seleziona tutto

1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111


Torna a “Programmazione”

Chi c’è in linea

Visitano il forum: Nessuno e 0 ospiti