Repository 32bit  Forum
Repository 64bit  Wiki

Downgrade xorg per far funzionare scheda nVidia

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Downgrade xorg per far funzionare scheda nVidia

Messaggioda DarkNeo » mer dic 19, 2012 23:58

Ciao a tutti,
ho installato questo driver NVIDIA-Linux-x86_64-96.43.20-pkg2.run per questa scheda grafica nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x] seguendo la guida di Navajo trovata sul sito. Dando startx mi da questo errore
Codice: Seleziona tutto
================ WARNING WARNING WARNING WARNING ================
This server has a video driver ABI version of 12.0 that is not
supported by this NVIDIA driver.  Please check
http://www.nvidia.com/ for driver updates or downgrade to an X
server with a supported driver ABI.
=================================================================
(EE) NVIDIA: Use the -ignoreABI option to override this check.

Fatal server error:
no screens found


Praticamente come mi ha detto 414N e come successivamente ho scoperto da questo sito http://it.download.nvidia.com/XFree86/Linux-x86_64/96.43.20/README/appendix-b.html devo fare il downgrade di xorg 1.12 ad xorg 1.10. Mi pare di aver capito che slapt-get non prevede l'opzione --downgrade, cosa mi invento e soprattutto di quanti e quali pacchetti devo fare il downgrade?
DarkNeo
Linux 3.x
Linux 3.x
 
Messaggi: 1071
Iscritto il: ven giu 03, 2005 23:00
Località: Matrix
Nome Cognome: Stefano Arbitrio
Slackware: Slackware64 14
Kernel: 3.2.X
Desktop: KDE

Re: Downgrade xorg per far funzionare scheda nVidia

Messaggioda ZeroUno » gio dic 20, 2012 9:12

perchè vuoi installare quella versione di driver e non l'ultima (che tra l'altro trovi su slacky)?
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4297
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: Downgrade xorg per far funzionare scheda nVidia

Messaggioda DarkNeo » gio dic 20, 2012 10:47

Non pensavo ci fossero driver nvidia nel repository64, poi sinceramente ho scaricato ed usato questa perché pensavo fosse l ultima e la più compatibile con la mia scheda grafica. Potresti girarmi per cortesia il link del driver di cui parli?
DarkNeo
Linux 3.x
Linux 3.x
 
Messaggi: 1071
Iscritto il: ven giu 03, 2005 23:00
Località: Matrix
Nome Cognome: Stefano Arbitrio
Slackware: Slackware64 14
Kernel: 3.2.X
Desktop: KDE

Re: Downgrade xorg per far funzionare scheda nVidia

Messaggioda ZeroUno » gio dic 20, 2012 11:18

Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4297
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: Downgrade xorg per far funzionare scheda nVidia

Messaggioda rik70 » gio dic 20, 2012 11:34

Ma la sua scheda non è una GeForce 4?

O sono io che sto sbarellando? :-k
rik70
Linux 2.6
Linux 2.6
 
Messaggi: 980
Iscritto il: gio mar 10, 2011 9:21
Slackware: 13.1
Kernel: 3.11.9-smp
Desktop: LXDE

Re: Downgrade xorg per far funzionare scheda nVidia

Messaggioda rik70 » gio dic 20, 2012 11:39

P.s.

C'è un tizio su ebay che vende delle geforce fx5500 a meno di 30€ (nuove con garanzia).

Io ne ho usato una che avevo della Palit - mi sembra - per un PC con slack14+XBMC-12rc1 e va più che bene con gli ultimi legacy 173.xx.

PP.SS.
Ormai le serie legacy 71 e 96(?? non so) non vengono + aggiornate.

Fare un downgrade di xorg è una macello: che si fa poi, bisogna ricompilarsi anche i gli ambienti grafici?
Ultima modifica di rik70 il gio dic 20, 2012 12:03, modificato 3 volte in totale.
rik70
Linux 2.6
Linux 2.6
 
Messaggi: 980
Iscritto il: gio mar 10, 2011 9:21
Slackware: 13.1
Kernel: 3.11.9-smp
Desktop: LXDE

Re: Downgrade xorg per far funzionare scheda nVidia

Messaggioda DarkNeo » gio dic 20, 2012 11:41

Infatti non sono compatibili con la mia scheda grafica, però ho trovato questi aggiornatissimi http://www.nvidia.it/object/linux-displ ... er-it.html li ho installati e allo startx non danno il problema con ABI quindi sono compatibili. Fatto resta che le mie lacune in ambito informatico non fanno comunque partire la grafica per questo errore:
Codice: Seleziona tutto
[   816.222] (EE) NVIDIA(0): Failed to allocate/map the primary surface!
[   816.223]
Fatal server error:
[   816.223] AddScreen/ScreenInit failed for driver 0
[   816.223]
[   816.223]
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
[   816.223] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   816.223]
[   816.273] Server terminated with error (1). Closing log file.

cosa ho sbagliato?????
DarkNeo
Linux 3.x
Linux 3.x
 
Messaggi: 1071
Iscritto il: ven giu 03, 2005 23:00
Località: Matrix
Nome Cognome: Stefano Arbitrio
Slackware: Slackware64 14
Kernel: 3.2.X
Desktop: KDE

Re: Downgrade xorg per far funzionare scheda nVidia

Messaggioda DarkNeo » gio dic 20, 2012 11:44

Grazie della dritta rik70 ma tanto per l'uso che dovro fare io con questo vecchio computer avere una scheda video più potente sarebbero soldi buttati, anche se 30€ sono veramente pochi.
DarkNeo
Linux 3.x
Linux 3.x
 
Messaggi: 1071
Iscritto il: ven giu 03, 2005 23:00
Località: Matrix
Nome Cognome: Stefano Arbitrio
Slackware: Slackware64 14
Kernel: 3.2.X
Desktop: KDE

Re: Downgrade xorg per far funzionare scheda nVidia

Messaggioda rik70 » gio dic 20, 2012 11:48

DarkNeo ha scritto:Infatti non sono compatibili con la mia scheda grafica, però ho trovato questi aggiornatissimi http://www.nvidia.it/object/linux-displ ... er-it.html li ho installati e allo startx non danno il problema con ABI quindi sono compatibili. Fatto resta che le mie lacune in ambito informatico non fanno comunque partire la grafica per questo errore:
[code][ 816.222] (EE) NVIDIA(0): Failed to allocate/map the primary surface!


Prova ad aggiungere "nopat" come parametro di avvio del kernel.
rik70
Linux 2.6
Linux 2.6
 
Messaggi: 980
Iscritto il: gio mar 10, 2011 9:21
Slackware: 13.1
Kernel: 3.11.9-smp
Desktop: LXDE

Re: Downgrade xorg per far funzionare scheda nVidia

Messaggioda DarkNeo » gio dic 20, 2012 11:49

dove lo aggiungo questo parametro? -_-'
DarkNeo
Linux 3.x
Linux 3.x
 
Messaggi: 1071
Iscritto il: ven giu 03, 2005 23:00
Località: Matrix
Nome Cognome: Stefano Arbitrio
Slackware: Slackware64 14
Kernel: 3.2.X
Desktop: KDE

Re: Downgrade xorg per far funzionare scheda nVidia

Messaggioda DarkNeo » gio dic 20, 2012 11:54

Il mio xorg.conf
Codice: Seleziona tutto
root@Neo:~# cat /etc/X11/xorg.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@swio-display-x64-suse91-02)  Sat Sep  1 03:47:08 PDT 2012


Section "ServerLayout"
    Identifier     "Layout0"
    Screen     0   "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    FontPath        "/usr/lib64/X11/fonts/misc/:unscaled"
    FontPath        "/usr/lib64/X11/fonts/100dpi/:unscaled"
    FontPath        "/usr/lib64/X11/fonts/75dpi/:unscaled"
    FontPath        "/usr/lib64/X11/fonts/misc/"
    FontPath        "/usr/lib64/X11/fonts/Type1/"
    FontPath        "/usr/lib64/X11/fonts/Speedo/"
    FontPath        "/usr/lib64/X11/fonts/100dpi/"
    FontPath        "/usr/lib64/X11/fonts/75dpi/"
    FontPath        "/usr/lib64/X11/fonts/cyrillic/"
    FontPath        "/usr/lib64/X11/fonts/TTF/"
EndSection

Section "Module"

   #Load  "dri"
   #Load  "GLCore"
    Load           "glx"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5 6 7"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       30.0 - 110.0
    VertRefresh     50.0 - 150.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "1280x1024"
    EndSubSection
EndSection
DarkNeo
Linux 3.x
Linux 3.x
 
Messaggi: 1071
Iscritto il: ven giu 03, 2005 23:00
Località: Matrix
Nome Cognome: Stefano Arbitrio
Slackware: Slackware64 14
Kernel: 3.2.X
Desktop: KDE

Re: Downgrade xorg per far funzionare scheda nVidia

Messaggioda rik70 » gio dic 20, 2012 11:59

DarkNeo ha scritto:dove lo aggiungo questo parametro? -_-'


A '/etc/lilo.conf' se usi LILO come bootmanager.

Solitamante si mette dentro append="".

Poi aggiorni lilo con
Codice: Seleziona tutto
lilo -v

da root, riavii e provi a lanciare il server X.
rik70
Linux 2.6
Linux 2.6
 
Messaggi: 980
Iscritto il: gio mar 10, 2011 9:21
Slackware: 13.1
Kernel: 3.11.9-smp
Desktop: LXDE

Re: Downgrade xorg per far funzionare scheda nVidia

Messaggioda DarkNeo » gio dic 20, 2012 12:11

Ok grazie mille ragazzi, il driver è andato è la grafica è partita, (almeno su un pc :))!!). Ma puramente per conoscenza personale cosa ho aggiunto ad append? Cosa vuol dire nopat?
DarkNeo
Linux 3.x
Linux 3.x
 
Messaggi: 1071
Iscritto il: ven giu 03, 2005 23:00
Località: Matrix
Nome Cognome: Stefano Arbitrio
Slackware: Slackware64 14
Kernel: 3.2.X
Desktop: KDE

Re: Downgrade xorg per far funzionare scheda nVidia

Messaggioda rik70 » gio dic 20, 2012 12:35

DarkNeo ha scritto:Cosa vuol dire nopat?


Dalla documentazione del kernel:
Codice: Seleziona tutto
 nopat           [X86] Disable PAT (page attribute table extension of
                  pagetables) support.


Ne so quanto te, ma ad es. coi driver open radeon se disattivi il KMS ottieni una serie di messaggi di errore che riguardano la memoria della scheda video(presumo) ogni volta che viene usata l'accelerazione 3d. Quel parametro fa scomparire il problema.

Altri che capiscono di programmazione potranno risponderti meglio.

Ciao.
rik70
Linux 2.6
Linux 2.6
 
Messaggi: 980
Iscritto il: gio mar 10, 2011 9:21
Slackware: 13.1
Kernel: 3.11.9-smp
Desktop: LXDE

Re: Downgrade xorg per far funzionare scheda nVidia

Messaggioda DarkNeo » gio dic 20, 2012 22:19

Grazie mille, fatto sta che ora funziona!! prima o poi scoprirò perchè :))
DarkNeo
Linux 3.x
Linux 3.x
 
Messaggi: 1071
Iscritto il: ven giu 03, 2005 23:00
Località: Matrix
Nome Cognome: Stefano Arbitrio
Slackware: Slackware64 14
Kernel: 3.2.X
Desktop: KDE


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite