Repository 32bit  Forum
Repository 64bit  Wiki

RISOLTO connessioni inattive su slakware 14.0

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

RISOLTO connessioni inattive su slakware 14.0

Messaggioda andrea470 » mar gen 15, 2013 11:54

Ciao a tutti,
sono appena arrivato sul forum perchè da poco ho installato su un dell-d620 slakware 14.0.
Ho già dei problemi relativi alla connessione internet.
Infatti ne la rete wired ne la wireless ne tantomento la connessione con telefonino si attivano.
Ho visto che il collegamento di networkmanager sul pannello mi dice che "networkmanager is not running, please start it" ma come?
Ho provato a dare ifconfig
Codice: Seleziona tutto
root@andrea:~# ifconfig
eth0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 00:18:8b:da:ee:b2  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 18 

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 16436
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 36  bytes 1968 (1.9 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 36  bytes 1968 (1.9 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

....e iwconfig
root@andrea:~# iwconfig
lo        no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on
         
eth0      no wireless extensions.
 


...questi sono i risultati.

Tenete presente che già alcuni mesi fa avevo tentato l' installazione ma mi aveva dato problemi simili (solo il wireless) e dopo innumerevoli tentativi ero ripassato ad ubuntu che tutt' ora mi gira perfettamente.

dimenticavo, la scheda di rete è una broadcom bc4311, che mi sembra sia supportata.

attendo aiuti, fatemi provare l' ebrezza di slakware! \:D/
Ultima modifica di andrea470 il gio feb 07, 2013 9:53, modificato 1 volta in totale.
andrea470
Linux 1.0
Linux 1.0
 
Messaggi: 23
Iscritto il: lun gen 14, 2013 21:20
Località: Doberdo' del Lago
Nome Cognome: Andrea Trani
Slackware: 14.0
Desktop: kde

Re: connessioni inattive su slakware 14.0

Messaggioda brainvision » mar gen 15, 2013 12:49

Ciao e benvenuto su Slackware!! ;)

dovrebbe bastare fare quello che ti ha suggerito ZeroUno via MP.. ovviamente da root!

Comunque il mio consiglio - ma immagino anche quello degli altri - è di leggere la Slackware4Dummies: ci trovi tutti i principi di Slackware, quello che bisogna fare durante e dopo l'installazione e altri utilissimi consigli! Un must, credimi!
Avatar utente
brainvision
Packager
Packager
 
Messaggi: 756
Iscritto il: ven dic 26, 2008 18:23
Località: bologna (bo)
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10

Re: connessioni inattive su slakware 14.0

Messaggioda ZeroUno » mar gen 15, 2013 13:13

uhmmm... s4d è vecchiotta... ci sono riferimenti a networkmanager?

comunque riporto la risposta data in privato (per gli altri utenti slacky)

Come root dai
chmod +x /etc/rc.d/rc.networkmanager
e poi
/etc/rc.d/rc.networkmanager start

Non so dirti se ti comparirà immediatamente l'iconcina di networkmanager in kde (ammesso che non ci sia già, con una croce rossa sopra, e che tu stia utilizzando kde; con xfce non so risponderti)


edit: X andrea470 : Per S4D si intende questo: https://www.slacky.eu/slacky/Slackware4Dummies
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4253
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: connessioni inattive su slakware 14.0

Messaggioda andrea470 » mar gen 15, 2013 14:55

ok, network manager e' ora attivo e la connessione wired va, ma la wireless no. NM presso il collegamento sul pannello mi da
Codice: Seleziona tutto
Type:
 Wireless 802.11
Connection State:
 Unavailable
IP Address:
 No IP address.
Connection Speed:
 Unknown
System Name:
 wlan0
MAC Address:
 00:19:7E:B7:AE:74
Driver:
 b43
 

la cosa si complica ma questa volta non formatto un bel niente!
ah dimenticavo pure la tastiera fa le bizze.

Comunque ho letto slakware for dummies , davvero molto interessante. La guida mi e' servita per l' installazione. Ci daro' un' occhiata piu' approfondita per vedere se riesco a risolvere il problema.

grazie.
andrea470
Linux 1.0
Linux 1.0
 
Messaggi: 23
Iscritto il: lun gen 14, 2013 21:20
Località: Doberdo' del Lago
Nome Cognome: Andrea Trani
Slackware: 14.0
Desktop: kde

Re: connessioni inattive su slakware 14.0

Messaggioda ZeroUno » mar gen 15, 2013 15:55

ma networkmanager te la da la lista delle wifi disponibili? e cosa ti dice se ne scegli una?
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4253
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: connessioni inattive su slakware 14.0

Messaggioda brainvision » mar gen 15, 2013 18:20

Se vede la wireless basta cliccare col tasto sinistro sull'icona, selezionare la tua rete ed impostare la password.. NM ha menù sia premendo con il destro che con il sinistro, come forse avrai vosto da te..

La s4d è per le basi, non per lo specifico di Network Manager.. :)

comunque questo programma è quello che c'è di default su Ubuntu, quindi dovresti sapere come si usa; però effettivamente dal tuo post non si capisce cosa fai..
Infine, prima che qualcuno ti sgridi, usa il tag per il codice quando serve!! ;)
Avatar utente
brainvision
Packager
Packager
 
Messaggi: 756
Iscritto il: ven dic 26, 2008 18:23
Località: bologna (bo)
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10

Re: connessioni inattive su slakware 14.0

Messaggioda andrea470 » mar gen 15, 2013 22:21

il problema e' che quando premo il tasto scan di NM non viene rilevata nessuna rete. Comunque su xubuntu non penso di avere NM, a vedere la grafica e' piu' simile a WiCd. A me questo NM non e' mai piaciuto , nemmeno quando alcuni anni fa avevo kubuntu!
Ma cosa ne dite se scollego la batteria per qualche minuto?
grazie ancora

Andrea
andrea470
Linux 1.0
Linux 1.0
 
Messaggi: 23
Iscritto il: lun gen 14, 2013 21:20
Località: Doberdo' del Lago
Nome Cognome: Andrea Trani
Slackware: 14.0
Desktop: kde

Re: connessioni inattive su slakware 14.0

Messaggioda brainvision » mar gen 15, 2013 22:41

e a che serve scollegare la batteria???? :D :D

Decisamente su Xubuntu no, non credo ci sia Network Manager, ma io dicevo infatti Ubuntu, nel primo post avevi parlato di Ubuntu..
A parte questo io preferisco mille volte Network Manager rispetto a Wicd: più integrato nell'ambiente grafico e molto molto più personalizzabile; senza contare la cosa più importante, ossia che permette di gestire ogni tipo di connessione, anche quella tramite cellulare..

Se poi preferisci Wicd puoi sempre installartelo tranquillamente: il pacchetto è presente nella dir extra del DVD di installazione della Slackware, o se hai installato in altro modo puoi sempre scaricarlo da uno dei mirror (il pacchetto, intendo). Ricorda che devi fare la stessa cosa anche con Wicd (rendere avviabile il suo demone ed avviarlo effettivamente, oltre poi a disattivare quello di NM).

Infine.. da terminale, come super-utente root, dai il comando
Codice: Seleziona tutto
iwlist wlan0 scan

e vedi se la tua rete è presente o cosa restituisce il comando.. vede almeno una qualche rete??
Avatar utente
brainvision
Packager
Packager
 
Messaggi: 756
Iscritto il: ven dic 26, 2008 18:23
Località: bologna (bo)
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10

Re: connessioni inattive su slakware 14.0

Messaggioda andrea470 » mer gen 16, 2013 9:44

Non lo so, ma leggendo una discussione dicevano che era una delle prove da fare. Forse staccandola si scaricano in totale tutti i circuiti e poi al riavvio il pc deve rifare tutti i collegamenti con le varie porte.
Comunque nemmeno ubuntu 11.10 aveva NM e proprio NM mi dava e mi da tutt' ora dei casini con la connessione umts. Con ubuntu basta collegare il telefonino ed impostarla la prima volta che poi tutto parte. Comunque, non e' questo il problema.
Ritornando a noi ecco l' iwlist:
root@andrea:~# iwlist wlan0 scan
wlan0 Interface doesn't support scanning : Network is down :-k :-k

Dunque se con iwconfig me la vede ma con iwlist mi dice che non riesce a mettersi in moto forse e' qualche problema di driver? :idea:
Poi nella finestra NM del System Setting c'e' l' opzione WiCd preference, e' quello WiCd? Mi sembra che in fase di installazione ho eseguito la full, come da consiglio di s4D.
ah, dimenticavo, ecco l' ultima riga di lspci:
0c:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)
come faccio a vedere se e' supportata?
e soprattutto come faccio a capire che kernel ho? mi sembra ho installato hugesmp o un nome simile...
Grazie ancora.
non abbandonatemi [-o< [-o<
andrea470
Linux 1.0
Linux 1.0
 
Messaggi: 23
Iscritto il: lun gen 14, 2013 21:20
Località: Doberdo' del Lago
Nome Cognome: Andrea Trani
Slackware: 14.0
Desktop: kde

Re: connessioni inattive su slakware 14.0

Messaggioda brainvision » mer gen 16, 2013 10:59

Se hai dato almeno un'occhiata a S4D dovresti sapere che nella dir extra ci sono alcuni pacchetti che non sono compresi nel ramo ufficiale e stabile (quindi tutto ciò ce viene installato) per vari motivi, ma che ogni utente può a sua scelta personale installare. Tra l'altro ti consiglio anche, da quella dir, di installare il pacchetto italiano di aspell e mplayer-plugin.

Quindi l'interfaccia è down, anche se vene riconosciuta.
Per sapere il tuo kernel, dai
Codice: Seleziona tutto
uname -a
ma visto che hai installato la 14 sarà di sicuro il 3.2.29, quasi sicuramente la versione hugesmp (che vuol dire il kernel completo e intero - huge - in versione per macchine multiprocessore - smp. Il problema non è quale versione hai installato, perché se hai fatto la full le hai installate tutte: la cosa importante è piuttosto con quale kernel si avvia la tua slackware, e questo lo modifichi con lilo; ma per ora lascia assolutamente quello che hai; più avanti, se vorrai e quando saprai dove e come mettere mano, lo potrai cambiare con uno più snello..

per la rete.
Prova, sempre da root, ad avviare manualmente la tua scheda con
Codice: Seleziona tutto
ifconfig wlan0 up

e vedi se così ti risulta attiva e ti vede qualche rete.

riguardo NM vs. Wicd. Io ti consiglio di lasciare NM; ci sarà un motivo se in tutto questo tempo Wicd non è mai entrato nel ramo ufficiale di slackware mentre NM esordisce sulla 14 ed è già in questo ramo; poi se proprio non lo sopporti, allora ti ho già detto come fare ad installarlo e dove trovarlo ;)

Infine, non so questa cosa del togliere la batteria, onestamente ci credo poco; ma comunque da allora l'avrai ravviato una volta il computer, no??
Avatar utente
brainvision
Packager
Packager
 
Messaggi: 756
Iscritto il: ven dic 26, 2008 18:23
Località: bologna (bo)
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10

Re: connessioni inattive su slakware 14.0

Messaggioda andrea470 » mer gen 16, 2013 21:41

ok,
eseguo i compiti e poi ti faccio sapere.
comunque il kernel e' il 3.2.29 e il risultato di ifconfig e'
root@andrea:~# ifconfig wlan0 up
SIOCSIFFLAGS: No such file or directory


grazie ancora.
andrea470
Linux 1.0
Linux 1.0
 
Messaggi: 23
Iscritto il: lun gen 14, 2013 21:20
Località: Doberdo' del Lago
Nome Cognome: Andrea Trani
Slackware: 14.0
Desktop: kde

Re: connessioni inattive su slakware 14.0

Messaggioda joe » gio gen 17, 2013 11:59

Aggiungo che con network manager non sono riuscito a collegare ad internet un cellulare via bluetooth.

Sul mio vecchio portatile attualmente non più funzionante, sono riuscito a collegarmi in wifi senza problemi usando wicd-client lanciato da root.
Ma prima avevo dovuto attivare il wifi adapter sul portatile con ndiswrapper e caricando il driver.
Secondo me per prima cosa bisogna assicurarsi che sia attivo il wifi. Per esempio sul mio portatile caricando il modulo (che ora non ricordo a memoria) si accendeva il led blu corrispondente.

Quindi per prima cosa darei un lspci per capire che adapter hai e che modulo eventualmente ti serva per farlo funzionare.
Poi se il driver nativo linux non ci fosse allora proverei con ndsiwrapper...
Detto questo però, vedo già che dal primo post dici che la tua scheda dovrebbe essere supportata nativamente. Per cui quello che ho scritto è da prendere con le molle.
Avatar utente
joe
Master
Master
 
Messaggi: 1927
Iscritto il: ven apr 27, 2007 10:21
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: KDE-4.8.5

Re: connessioni inattive su slakware 14.0

Messaggioda 6C33C » gio gen 17, 2013 19:01

Posso risponderti con l' esperienza sul mio portatile.
Dunque il mio portatile ha una scheda wifi broadcom, per l' esattezza una BCM43225 che secondo questo link > https://help.ubuntu.com/community/WifiD ... er/bcm43xx
è supportata come la tua dal driver b43.
Quando ho installato la 14.0 ho pistolato un pò con il quel driver che però vuole un firmware che può essere estratto con b43-fwcutter.
Qui il link per lo slackbuild > http://slackbuilds.org/repository/14.0/ ... -fwcutter/
Io però non sono riuscito a far funzionare il tutto ( veramente non ci ho perso tanto tempo dietro :D ) e sono passato come avevo sulla 13.37 al driver proprietario broadcom-sta.
Qui il link per lo slackbuild > http://slackbuilds.org/repository/14.0/ ... adcom-sta/.
Installa il pacchetto creato dallo script, crea in /etc/modprbe.d/ un nuovo file e chiamalo b43_blacklist.conf e dentro ci metti questo testo:
Codice: Seleziona tutto
# /etc/modprobe.d/b43_blacklist.conf
    blacklist b43
    blacklist b43legacy
    blacklist bcma
    blacklist ssb

Riavvia e dovrebbe funzionare il tutto.
Spero che ti sia utile.

Edit: Per corettezza ho trovato anche questo link http://codeghar.wordpress.com/2012/07/12/get-broadcom-bcm4311-working-in-ubuntu-12-04/ che ti dice di fare il contrario di quello che ho fatto io :roll: dice di averlo testato su un dell 630.
Ultima modifica di 6C33C il sab gen 19, 2013 10:46, modificato 1 volta in totale.
Avatar utente
6C33C
Packager
Packager
 
Messaggi: 254
Iscritto il: gio ott 12, 2006 15:09
Località: Rimini
Nome Cognome: Giorgio
Slackware: 14.0 x86_64
Kernel: 3.9.7
Desktop: kde 4.10.4 ,razorqt

Re: connessioni inattive su slakware 14.0

Messaggioda useless » ven gen 18, 2013 8:48

Ma... se il driver buono è il b43, perché blacklisti anche quello?! :-k
Avatar utente
useless
Staff
Staff
 
Messaggi: 3896
Iscritto il: sab ott 11, 2003 23:00
Località: A place where the streets have no name

Re: connessioni inattive su slakware 14.0

Messaggioda 6C33C » ven gen 18, 2013 13:16

useless ha scritto:Ma... se il driver buono è il b43, perché blacklisti anche quello?! :-k


Perchè io non ho sfruttato il driver b43 ma il wl cioè quello propietario.
Avatar utente
6C33C
Packager
Packager
 
Messaggi: 254
Iscritto il: gio ott 12, 2006 15:09
Località: Rimini
Nome Cognome: Giorgio
Slackware: 14.0 x86_64
Kernel: 3.9.7
Desktop: kde 4.10.4 ,razorqt

Prossimo

Torna a Slackware

Chi c’è in linea

Visitano il forum: Bing [Bot] e 3 ospiti