PHP7

Forum dedicato alla programmazione.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il linguaggio di programmazione usato.
2) Se possibile portare un esempio del risultato atteso.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2059
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.10.12-ck1
Desktop: lxde
Località: Pisa
Contatta:

Re: PHP7

Messaggioda ponce » lun apr 24, 2017 11:01

conraid ha scritto:Tra l'altro prima ho provato a lanciare lo script nei sorgenti di slackware, senza toccare niente, e mi da errore uf8 nel configure. Non son riuscito a fare copia/incolla, se mai riprovo più tardi.

quello e' perche php.SlackBuild linka ancora la vecchia versione di alpine (ALPINE=2.20) e quindi poi non compila quello che gli serve: se aggiorni il riferimento alla 2.21 poi lo compila correttamente (e non da piu' quell'errore), mi ero scordato di metterlo tra le modifiche da fare :)
Ultima modifica di ponce il lun apr 24, 2017 11:06, modificato 1 volta in totale.

Avatar utente
conraid
Staff
Staff
Messaggi: 12872
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: PHP7

Messaggioda conraid » lun apr 24, 2017 11:04

Ah ok, visto adesso. Thanks.

Avatar utente
conraid
Staff
Staff
Messaggi: 12872
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: PHP7

Messaggioda conraid » lun apr 24, 2017 12:34

Va :(
Anche la 7.1.4
Ma allora che diavolo poteva essere? Forse una versione di c-client.a vecchia? Se ho tempo faccio un po' di prove, ora provo a ricompilare aggiungendo pdo-pgsql

Avatar utente
conraid
Staff
Staff
Messaggi: 12872
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: PHP7

Messaggioda conraid » lun apr 24, 2017 13:26

Mi va anche con l'estensione pgsql. Ora lascio stare, al prossimo aggiornamento faccio altre prove per capire l'inghippo.

Avatar utente
conraid
Staff
Staff
Messaggi: 12872
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: PHP7

Messaggioda conraid » lun apr 24, 2017 15:23

Riprovando a fare un pacchetto per il repository... ora va. Ho anche tolto alcune cose non più supportate, e tolto la patch per fpm (nella versione 7.1 cambia, ma non usandolo ho lasciato il default). Ora va, a questo punto al 99% era qualche casino con alpine e imapd. Avevo fatto un procedimento per compilare il pacchetto senza bisogno di alpine, lo metto dentro come Pat, tanto il mio repository lo uso solo io in pratica :D


Torna a “Programmazione”

Chi c’è in linea

Visitano il forum: Nessuno e 5 ospiti