libmypaint in current

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
dafrasaga
Linux 1.x
Linux 1.x
Messaggi: 146
Iscritto il: mar set 08, 2009 11:39
Slackware: current
Località: Vinci -FI-

libmypaint in current

Messaggioda dafrasaga » mar gen 30, 2018 9:29

Ciao a tutti,
dato che vorrei installare GIMP da git ho dovuto ( per il momento su VM) upgradare alla current dalla 14.2 per avere glib2-2.0 versione 2.54..
In verità ho installato la 2.54 e 2.55 da git sulla 14.2 ma avevo in continuazione errori nella fase di compilazione ...

Adesso in current dopo avere installato babl e gegl da git devo installare una dipendenza di GIMp e cioè https://github.com/mypaint/libmypaint.. La configurazione va a buon fine ma quando tento di conpilare ho:

Codice: Seleziona tutto


    make[2]: Entering directory '/root/git/libmypaint’
    depbase=echo mypaint-brush.lo | sed 's|[^/]*$|.deps/&|;s|\.lo$||';
    /bin/sh ./libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I/usr/local/include/json-c -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -D_POSIX_C_SOURCE=200809L -g -O2 -MT mypaint-brush.lo -MD -MP -MF $depbase.Tpo -c -o mypaint-brush.lo mypaint-brush.c &&
    mv -f $depbase.Tpo $depbase.Plo
    libtool: compile: gcc -DHAVE_CONFIG_H -I. -I/usr/local/include/json-c -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -D_POSIX_C_SOURCE=200809L -g -O2 -MT mypaint-brush.lo -MD -MP -MF .deps/mypaint-brush.Tpo -c mypaint-brush.c -fPIC -DPIC -o .libs/mypaint-brush.o
    mypaint-brush.c: In function ‘mypaint_brush_new’:
    mypaint-brush.c:133:26: error: ‘FALSE’ undeclared (first use in this function); did you mean ‘FILE’?
    self->print_inputs = FALSE;
    ^~~~~
    FILE
    mypaint-brush.c:133:26: note: each undeclared identifier is reported only once for each function it appears in
    mypaint-brush.c:142:29: error: ‘TRUE’ undeclared (first use in this function)
    self->reset_requested = TRUE;
    ^~~~
    mypaint-brush.c: In function ‘mypaint_brush_reset’:
    mypaint-brush.c:225:29: error: ‘TRUE’ undeclared (first use in this function)
    self->reset_requested = TRUE;
    ^~~~
    mypaint-brush.c: In function ‘mypaint_brush_stroke_to’:
    mypaint-brush.c:961:31: error: ‘FALSE’ undeclared (first use in this function); did you mean ‘FILE’?
    self->reset_requested = FALSE;
    ^~~~~
    FILE
    mypaint-brush.c:980:14: error: ‘TRUE’ undeclared (first use in this function)
    return TRUE;
    ^~~~
    mypaint-brush.c: In function ‘obj_get’:
    mypaint-brush.c:1100:44: error: ‘TRUE’ undeclared (first use in this function)
    && (obj_out ? (*obj_out != NULL) : TRUE);
    ^~~~
    mypaint-brush.c: In function ‘update_brush_setting_from_json_object’:
    mypaint-brush.c:1120:16: error: ‘FALSE’ undeclared (first use in this function); did you mean ‘FILE’?
    return FALSE;
    ^~~~~
    FILE
    mypaint-brush.c:1167:12: error: ‘TRUE’ undeclared (first use in this function)

    return TRUE;
    ^~~~
    mypaint-brush.c: In function ‘update_brush_from_json_object’:
    mypaint-brush.c:1177:16: error: ‘FALSE’ undeclared (first use in this function); did you mean ‘FILE’?
    return FALSE;
    ^~~~~
    FILE
    mypaint-brush.c:1193:28: error: ‘TRUE’ undeclared (first use in this function)
    gboolean updated_all = TRUE;
    ^~~~
    mypaint-brush.c: In function ‘mypaint_brush_from_string’:
    mypaint-brush.c:1227:16: error: ‘FALSE’ undeclared (first use in this function); did you mean ‘FILE’?
    return FALSE;
    ^~~~~
    FILE
    make[2]: *** [Makefile:730: mypaint-brush.lo] Error 1
    make[2]: Leaving directory '/root/git/libmypaint’
    make[1]: *** [Makefile:840: all-recursive] Error 1
    make[1]: Leaving directory '/root/git/libmypaint’
    make: *** [Makefile:598: all] Error 2


Sembra che manchino alcune definizioni, ma non so dove..

Avete idee??

GRazi emille

Avatar utente
conraid
Staff
Staff
Messaggi: 13059
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: libmypaint in current

Messaggioda conraid » mar gen 30, 2018 14:21


dafrasaga
Linux 1.x
Linux 1.x
Messaggi: 146
Iscritto il: mar set 08, 2009 11:39
Slackware: current
Località: Vinci -FI-

Re: libmypaint in current

Messaggioda dafrasaga » mar gen 30, 2018 14:39

conraid ha scritto:Prendi la patch da archlinux
https://aur.archlinux.org/cgit/aur.git/ ... libmypaint


Grazie Conraid,
ma non sono tanto ferrato nelle patches..
In definitiva cosa devo fare?? :(

Avatar utente
conraid
Staff
Staff
Messaggi: 13059
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: libmypaint in current

Messaggioda conraid » mar gen 30, 2018 14:50

Prendi il file https://github.com/mypaint/libmypaint/r ... 3.0.tar.xz lo decomprimi in una directory, poi copi la patch nella stessa directory e dai questo comando

Codice: Seleziona tutto

patch -uNp2 -r- -i versioning.patch



Il problema è che ti darà errore perché pensa che hai preso da git, devi togliere qualche riga. Aspetta ti copio quella che ho usato io.

Scarichi quella che ti ho allegato, la copi dove hai il codice e dai

Codice: Seleziona tutto

patch -p1 versioning.patch


dovrebbe andare.

poi dai

Codice: Seleziona tutto

autoreconf -fi

prima del configure

Ho ricompilato poco fa libmypaint per la current (ma la versione 1.3.0 non l'ultima git, che altrimenti la patch non va bene)
Allegati
versioning.patch
(20.19 KiB) Scaricato 20 volte

Avatar utente
conraid
Staff
Staff
Messaggi: 13059
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: libmypaint in current

Messaggioda conraid » mar gen 30, 2018 14:53

Quanto poi compili gimp devi modificare una cosa altrimenti non va

Codice: Seleziona tutto

sed -i "s:\(libmypaint\)\( >= libmypaint_required_version\):\1-1.3\2:g" configure.ac


e poi dai

Codice: Seleziona tutto

autoreconf -fi

prima del configure

Stessa cosa (autoreconf) devi fare in libmypaint mi raccomando

dafrasaga
Linux 1.x
Linux 1.x
Messaggi: 146
Iscritto il: mar set 08, 2009 11:39
Slackware: current
Località: Vinci -FI-

Re: libmypaint in current

Messaggioda dafrasaga » mar gen 30, 2018 15:05

conraid ha scritto:
Stessa cosa (autoreconf) devi fare in libmypaint mi raccomando


quindi in libmypaint dopo avere applicato la patch, prima del configure?

PS. Sei riuscito ad installare gimp da git sulla current??

Avatar utente
conraid
Staff
Staff
Messaggi: 13059
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: libmypaint in current

Messaggioda conraid » mar gen 30, 2018 15:07

Non da git, la 2.9.8
Se vuoi ti metto da qualche parte i pacchetti.

dafrasaga
Linux 1.x
Linux 1.x
Messaggi: 146
Iscritto il: mar set 08, 2009 11:39
Slackware: current
Località: Vinci -FI-

Re: libmypaint in current

Messaggioda dafrasaga » mar gen 30, 2018 15:09

conraid ha scritto:Non da git, la 2.9.8
Se vuoi ti metto da qualche parte i pacchetti.


Ora voglio provare io per farmi esperienza, semmai mi faccio vivo.. ;)

Ma questi problemi ci sono per la nostra distro oppure altro??

Avatar utente
conraid
Staff
Staff
Messaggi: 13059
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: libmypaint in current

Messaggioda conraid » mar gen 30, 2018 15:10

Quale problemi? Considera che le patch e quelle modifiche le ho prese da archlinux, quindi ce l'hanno anche loro i problemi.

dafrasaga
Linux 1.x
Linux 1.x
Messaggi: 146
Iscritto il: mar set 08, 2009 11:39
Slackware: current
Località: Vinci -FI-

Re: libmypaint in current

Messaggioda dafrasaga » mar gen 30, 2018 15:12

Ok, stasera provo e ti faccio sapere ( è quasi un mese che mi ci stò sbattezzando )

dafrasaga
Linux 1.x
Linux 1.x
Messaggi: 146
Iscritto il: mar set 08, 2009 11:39
Slackware: current
Località: Vinci -FI-

Re: libmypaint in current

Messaggioda dafrasaga » mer gen 31, 2018 6:07

Ciao allora ho provato ma non ha funzionato...
ho sempre glki errori che non è definito FALSE e quantaltrro.
Ho controllato i file modificati con diff e le modifiche mi sembra siano state effettuate ( comunque ho dovuto dare patch -p1 < versioning.patch (con il <) e poi fatto il autoreconf.

Evidentemente mi manca qualcos'altro :|

Per la cronaca ho upgradato dalla 14.2 su una VM con slackpkg: prima con update-gpg, poi update, poi upgrade-all, poi install-new e poi clean system.. o ho sbagliato qualcosa oppure non so :?

Forse reinstallare una current di pacca e riprovare ? Domanda: siccome non mi ricordo.. per la current nuova di pacca posso utilizzare un cd di installazione qualunque e fagli puntare ai file della current su un'altra locazione oppure c'è una iso? Non la trovo sotto https://mirrors.slackware.com/slackware/slackware-iso/

Grazie

Avatar utente
conraid
Staff
Staff
Messaggi: 13059
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: libmypaint in current

Messaggioda conraid » mer gen 31, 2018 11:06

Sì, mi son dimenticato un "-i" che è l'opzione per specificare il file

Codice: Seleziona tutto

patch -p1 -i versioning.patch


Ricorda che io ho compilato la 1.3.0 di libmypaint, non la versione di sviluppo in git, magari han qualche bug non ancora risolto.

Riguardo le altre domande.
1) sì, la procedura slackpkg è corretta
2) L'ido puoi creartela da solo, come da spiegazioni nel README http://slackware.uk/slackware/slackware ... README.TXT

altrimenti prendi quella di Alien http://slackware.uk/people/alien-current-iso/

dafrasaga
Linux 1.x
Linux 1.x
Messaggi: 146
Iscritto il: mar set 08, 2009 11:39
Slackware: current
Località: Vinci -FI-

Re: libmypaint in current

Messaggioda dafrasaga » mer gen 31, 2018 13:23

conraid ha scritto:Ricorda che io ho compilato la 1.3.0 di libmypaint, non la versione di sviluppo in git, magari han qualche bug non ancora risolto.


Si ho preso la 1.3.0 sia con checkout in git sia il con https://github.com/mypaint/libmypaint/releases/download/v1.3.0/libmypaint-1.3.0.tar.xz

Mah, non so cosa pensare...
Vediamo se con una installazione vergine funziona...