Problemi a montare una condivisione di rete Samba

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
scorpion77
Linux 1.x
Linux 1.x
Messaggi: 102
Iscritto il: gio gen 20, 2005 0:00
Nome Cognome: Andrea
Slackware: Slackware64 14.1
Desktop: KDE 4.10.5

Problemi a montare una condivisione di rete Samba

Messaggioda scorpion77 » sab giu 09, 2018 16:10

Ciao a tutti,

ho da poco installato Slackware64 14.2 sul mio pc al lavoro. Ho notato che quando mi collego al file server (sempre con Slackware64 14.2) Samba indica come Protocol Version NT1, che è la prima versione di Samba. Volevo collegarmi usando il protocollo Samba versione 3, come Windows 10. Se provo a montare la condivisione aggiungendo vers=3.0 in fstab, ottengo questi errori:

mount error(22): Invalid argument
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)


Ovviamente se non specifico la versione, riesco a montare la condivisione, però viene montata con la versione NT1.

Cosa dovrei fare? Ricompilare il kernel?

Grazie in anticipo.

Scorpion77