segfault di atom su current 64

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
lennynero
Linux 3.x
Linux 3.x
Messaggi: 597
Iscritto il: lun mag 03, 2004 0:00
Nome Cognome: Luigi Picaro
Slackware: 14.2-x64
Kernel: 4.4.14
Desktop: xfce-4.12
Località: Salerno
Contatta:

Re: segfault di atom su current 64

Messaggioda lennynero » mar set 25, 2018 12:34

Mi aggancio al thread, forse un pochino OT, per segnalare un problema (anche) con la versione di SBo (1.30.0 x64) su una slack 14.2 con qualche extra e le multilib (di Alien).
Quando provo ad installare un pacchetto all'interno di Atom ho il seguente errore:

Codice: Seleziona tutto

Fetching featured packages failed.Hide output…
module.js:471
    throw err;
    ^

Error: Cannot find module './lib/_stream_duplex.js'
    at Function.Module._resolveFilename (module.js:469:15)
    at Function.Module._load (module.js:417:25)
    at Module.require (module.js:497:17)
    at require (internal/module.js:20:19)
    at Object.<anonymous> (/usr/share/atom/resources/app/apm/node_modules/npm/node_modules/readable-stream/readable.js:10:18)
    at Module._compile (module.js:570:32)
    at Object.Module._extensions..js (module.js:579:10)
    at Module.load (module.js:487:32)
    at tryModuleLoad (module.js:446:12)
    at Function.Module._load (module.js:438:3)

La versione di nodejs che uso è la 8.9.4, anche se mi pare di capire che ne usa una sua...
Qualcuno ha lo stesso problema? Devo rinunciare ad installare pacchetti esterni?

Avatar utente
conraid
Staff
Staff
Messaggi: 13207
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: segfault di atom su current 64

Messaggioda conraid » mar set 25, 2018 12:42

Prova con

Codice: Seleziona tutto

atom --safe

poi se da ugualmente errore cancella la directory .atom, o meglio rinominala.

E poi

Codice: Seleziona tutto

npm cache clean
rm -rf ~/.npm


E riprova.

Prova anche la versione loro già compilata.

Avatar utente
lennynero
Linux 3.x
Linux 3.x
Messaggi: 597
Iscritto il: lun mag 03, 2004 0:00
Nome Cognome: Luigi Picaro
Slackware: 14.2-x64
Kernel: 4.4.14
Desktop: xfce-4.12
Località: Salerno
Contatta:

Re: segfault di atom su current 64

Messaggioda lennynero » mar set 25, 2018 14:22

Nulla di fatto.

Il file _stream_duplex.js si trova (oltre che in altri progetti di react-native e nuxt) si trova nei path:

/usr/share/atom/resources/app/apm/node_modules/npm/node_modules/request/node_modules/bl/node_modules/readable-stream/lib/_stream_duplex.js
/usr/share/atom/resources/app/apm/node_modules/readable-stream/lib/_stream_duplex.js
/usr/share/atom/resources/app/apm/node_modules/concat-stream/node_modules/readable-stream/lib/_stream_duplex.js

Possibile che debba aggiungerli in qualche PATH(anche se mi sembra stupido)?

Avatar utente
conraid
Staff
Staff
Messaggi: 13207
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: segfault di atom su current 64

Messaggioda conraid » mar set 25, 2018 14:31

Per un problema simile qualcuno su github consigli di fare a mano
https://github.com/Glavin001/atom-beautify/issues/1308
oppure di cancellare tutti i moduli npm e reinstallarli, ma a quel punto ti conviene ricompilarti atom.

Avatar utente
lennynero
Linux 3.x
Linux 3.x
Messaggi: 597
Iscritto il: lun mag 03, 2004 0:00
Nome Cognome: Luigi Picaro
Slackware: 14.2-x64
Kernel: 4.4.14
Desktop: xfce-4.12
Località: Salerno
Contatta:

Re: segfault di atom su current 64

Messaggioda lennynero » mar set 25, 2018 17:38

Il link che mi hai postato si riferisce al file ./_stream_duplex', e pare causato dal modulo beautify, mentre nel mio caso il file è ./lib/_stream_duplex.js' e l'errore sembra dovuto al modulo readable-stream.
In ogni caso l'errore riportato capita anche banalmente con l'esecuzione del comando apm. A questo punto mi viene il sospetto che potrebbe esserci qualche conflitto tra i files installati da atom e quelli di npm(usato per altro, come detto in precedenza). :cry:

Avatar utente
lennynero
Linux 3.x
Linux 3.x
Messaggi: 597
Iscritto il: lun mag 03, 2004 0:00
Nome Cognome: Luigi Picaro
Slackware: 14.2-x64
Kernel: 4.4.14
Desktop: xfce-4.12
Località: Salerno
Contatta:

Re: segfault di atom su current 64

Messaggioda lennynero » mar set 25, 2018 20:22

Credo di aver trovato la causa del problema del package manager di atom(apm). In sostanza il file ./lib/_stream_duplex.js' effettivamente non esiste. Oltre a trovarsi nei 3 path precedentemente segnalati dovrebbe trovarsi anche in:

Codice: Seleziona tutto

/usr/share/atom/resources/app/apm/node_modules/npm/node_modules/readable-stream/lib/_stream_duplex.js

Stranamente in quella directory trovo un file chiamato _stream_duplex.j. Così ho provato a farne una copia in .js e lanciando apm mi veniva fuori un altro file mancante:

Codice: Seleziona tutto

/usr/share/atom/resources/app/apm/node_modules/npm/node_modules/npmlog/node_modules/gauge/plumbing.js

Anche in questo caso ne trovavo solo la versione .j, così ho effettuato una copia anche di quello e ora apm funziona...(anche all'interno della GUI di atom).
Per completezza segnalo che ho trovato altri 5 file con questa estensione monca:

Codice: Seleziona tutto

/usr/share/atom/resources/app/apm/node_modules/npm/node_modules/request/node_modules/caseless/test.j
/usr/share/atom/resources/app/apm/node_modules/npm/node_modules/request/node_modules/isstream/test.j
/usr/share/atom/resources/app/apm/node_modules/npm/node_modules/osenv/node_modules/os-tmpdir/index.j
/usr/share/atom/resources/app/apm/node_modules/concat-stream/node_modules/readable-stream/writable.j
/usr/share/atom/resources/app/apm/node_modules/concat-stream/node_modules/readable-stream/readable.j

Non capisco come possa essere successo, considerando che nel pacchetto di SBo (atom-1.30.0-x86_64-1_SBo.tgz) quei files hanno estensione .js

Avatar utente
conraid
Staff
Staff
Messaggi: 13207
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: segfault di atom su current 64

Messaggioda conraid » mer set 26, 2018 11:46

Strano, però allora uno dei consigli era giusto, cioè reinstallare i moduli npm interni al progetto.

Avatar utente
lennynero
Linux 3.x
Linux 3.x
Messaggi: 597
Iscritto il: lun mag 03, 2004 0:00
Nome Cognome: Luigi Picaro
Slackware: 14.2-x64
Kernel: 4.4.14
Desktop: xfce-4.12
Località: Salerno
Contatta:

Re: segfault di atom su current 64

Messaggioda lennynero » mer set 26, 2018 16:43

Da notare che per tutti e 7 i path indicati la lunghezza (corretta) è 101 caratteri... Sembrerebbe che il processo installpkg tronca i path superiori a 100 caratteri :oops:
Credo sia impossibile, ma non mi spiego come mai nel tgz i path sono completi, ma quando lo installo non vengono "copiati" correttamente quei files.

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2486
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.19.0-rc8
Desktop: lxde
Località: Pisa
Contatta:

Re: segfault di atom su current 64

Messaggioda ponce » mer set 26, 2018 16:59

mi sembra di averlo sentito dire da Alien Bob, ma non sono sicuro di aver capito bene: sembra che ci sia un baco nella versione di tar usata dai pkgtools su slackware 14.2 che tronca i nomi dei file di una lunghezza precisa.

EDIT: ah, guarda, ho trovato il post

https://www.linuxquestions.org/question ... ost5905209

Avatar utente
lennynero
Linux 3.x
Linux 3.x
Messaggi: 597
Iscritto il: lun mag 03, 2004 0:00
Nome Cognome: Luigi Picaro
Slackware: 14.2-x64
Kernel: 4.4.14
Desktop: xfce-4.12
Località: Salerno
Contatta:

Re: segfault di atom su current 64

Messaggioda lennynero » mer set 26, 2018 17:55

ponce ha scritto:mi sembra di averlo sentito dire da Alien Bob, ma non sono sicuro di aver capito bene: sembra che ci sia un baco nella versione di tar usata dai pkgtools su slackware 14.2 che tronca i nomi dei file di una lunghezza precisa.

EDIT: ah, guarda, ho trovato il post

https://www.linuxquestions.org/question ... ost5905209

Grazie mille ponce, se lo conferma anche AlienBob posso sciogliere i miei dubbi (anche se non avevo pensato a tar, dando la colpa a installpkg).
Mi pare di capire che capita(anche con la versione 1.29) con i path di esattamente 100 caratteri..., come nel caso dei 7 files che ho indicato, escludendo lo "/" iniziale.
Il bug, segnalato già nella versione 1.13.2 qui, è di 9 anni fa... Non è molto strano che non ce ne siamo mai accorti? Non è un bug molto grave?

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2486
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.19.0-rc8
Desktop: lxde
Località: Pisa
Contatta:

Re: segfault di atom su current 64

Messaggioda ponce » mer set 26, 2018 20:50

lennynero ha scritto:Il bug, segnalato già nella versione 1.13.2 qui, è di 9 anni fa... Non è molto strano che non ce ne siamo mai accorti? Non è un bug molto grave?

il bug che hai linkato in realta' non e' confermato, se leggi l'email dopo dice che era stato testato e scompattava i file lunghi esattamente 100 caratteri senza troncarli: nota che si riferisce alla versione di tar che hanno riscritto quelli di busybox, non a quella che viene usata in Slackware.

Avatar utente
conraid
Staff
Staff
Messaggi: 13207
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: segfault di atom su current 64

Messaggioda conraid » gio set 27, 2018 10:04

Aggiorno per dire che anche la versione 1.31.0 appena uscita da sempre errore, infatti hanno aggiornato Electron alla 2.0.7 quando solo nella 2.0.8 hanno corretto il bug. La versione di sviluppo naturalmente va, e infatti ho compilato quella per il mio repository.
Ora provo a cambiare versione di Electron negli script, magari come fa SBo usare Electron di sistema. Ma boh, faccio prima a usare la versione di sviluppo.

Avatar utente
lennynero
Linux 3.x
Linux 3.x
Messaggi: 597
Iscritto il: lun mag 03, 2004 0:00
Nome Cognome: Luigi Picaro
Slackware: 14.2-x64
Kernel: 4.4.14
Desktop: xfce-4.12
Località: Salerno
Contatta:

Re: segfault di atom su current 64

Messaggioda lennynero » gio set 27, 2018 11:35

ponce ha scritto:nota che si riferisce alla versione di tar che hanno riscritto quelli di busybox, non a quella che viene usata in Slackware.

Ok, quindi quella segnalazione era riferita alla versione tar busybox, anche se io mi ritrovo comunque quello stesso bug nella versione "normale" (1.29) di slack 14.2-x86_64.
conraid ha scritto:quando solo nella 2.0.8 hanno corretto il bug

quindi il problema deriva da Electron <=2.0.7? Mi sto perdendo:)
conraid ha scritto:anche la versione 1.31.0 appena uscita da sempre errore

Quindi cosa devo installare per fixare il problema?
conraid ha scritto:La versione di sviluppo naturalmente va

A quale versione ti riferisci esattamente?

Avatar utente
conraid
Staff
Staff
Messaggi: 13207
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: segfault di atom su current 64

Messaggioda conraid » gio set 27, 2018 11:42

lennynero ha scritto:
conraid ha scritto:quando solo nella 2.0.8 hanno corretto il bug

quindi il problema deriva da Electron <=2.0.7? Mi sto perdendo:)
conraid ha scritto:anche la versione 1.31.0 appena uscita da sempre errore

Quindi cosa devo installare per fixare il problema?


io parlavo del problema relativo a quello indicato da me al primo post, tu non avendo le glibc aggiornate (se non erro sei con la 14.2) non dovresti aver problemi con qualsiasi versione. Al di là del problema di tar.

lennynero ha scritto:
conraid ha scritto:La versione di sviluppo naturalmente va

A quale versione ti riferisci esattamente?


Io l'ho presa con git e compilata da me.