futuro slackware

Area di discussione libera.

Moderatore: Staff

Regole del forum
1) Rispettare le idee altrui.
2) Evitare le offese dirette.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
lablinux
Linux 4.x
Linux 4.x
Messaggi: 1124
Iscritto il: gio nov 27, 2008 12:23
Desktop: Gnome
Distribuzione: Debian testing
Località: Rho

Re: futuro slackware

Messaggioda lablinux » lun dic 10, 2018 10:19

F4B1CK ha scritto:Se invece ci vogliamo riferire alle versioni dei pacchetti standard (browser, videoscrittura, video editing, ecc. ecc.) ormai devono essere considerati software di terze parti. Non posso pensare che debbano per forza essere in bundle con la distro (una distro che di suo nasce comunque minimale). Preferisco integrare repository di terze parti ed avere anche questi aggiornati.

Sicuro che i repository di terze parti siano sicuri (AlienBob a parte)?

Avatar utente
gigiobagiano
Linux 3.x
Linux 3.x
Messaggi: 530
Iscritto il: dom mar 11, 2007 12:58
Nome Cognome: Filippo
Slackware: 14.2
Kernel: vanilla-4.4.38
Desktop: xfce
Distribuzione: SalixOS
Contatta:

Re: futuro slackware

Messaggioda gigiobagiano » lun dic 10, 2018 11:40

lablinux ha scritto:
F4B1CK ha scritto:Se invece ci vogliamo riferire alle versioni dei pacchetti standard (browser, videoscrittura, video editing, ecc. ecc.) ormai devono essere considerati software di terze parti. Non posso pensare che debbano per forza essere in bundle con la distro (una distro che di suo nasce comunque minimale). Preferisco integrare repository di terze parti ed avere anche questi aggiornati.

Sicuro che i repository di terze parti siano sicuri (AlienBob a parte)?

Quelli di salix e SBo mi sembrano piuttosto sicuri...o hai trovato qualcosa di oscuro?

Su server non userei sinceramente Slackware, ma questo è dettato di più dall'abitudine nell'utilizzare debian per questo scopo.

Avatar utente
lablinux
Linux 4.x
Linux 4.x
Messaggi: 1124
Iscritto il: gio nov 27, 2008 12:23
Desktop: Gnome
Distribuzione: Debian testing
Località: Rho

Re: futuro slackware

Messaggioda lablinux » lun dic 10, 2018 11:51

Niente di oscuro. L'aggiornamento è affidato a chi mantiene i repository e devi ricordari di aggiornare. Se fossero nei repo ufficiali un upgrade risolverebbe (oltre ad avere la garanzia della distro).
Alien (se sbaglio correggetemi) qualche mese fa perse il lavoro e interruppe il suo (impagabile) lavoro per la Slackware e i suoi pacchetti rimasero fermi. E' un caso ed è durato pochissimo tempo, si ricolloco in pochissimo tempo.
E' un caso, ma appoggiandosi a repo esterni (*)c'è questo rischio.
* motivo per cui non mi fido di snap o flatpack

F4B1CK
Linux 2.x
Linux 2.x
Messaggi: 264
Iscritto il: dom gen 11, 2004 0:00
Slackware: current 64 bit
Kernel: 4.4.x
Desktop: KDE 5
Località: Cosenza
Contatta:

Re: futuro slackware

Messaggioda F4B1CK » lun dic 10, 2018 20:33

lablinux ha scritto:
F4B1CK ha scritto:Se invece ci vogliamo riferire alle versioni dei pacchetti standard (browser, videoscrittura, video editing, ecc. ecc.) ormai devono essere considerati software di terze parti. Non posso pensare che debbano per forza essere in bundle con la distro (una distro che di suo nasce comunque minimale). Preferisco integrare repository di terze parti ed avere anche questi aggiornati.

Sicuro che i repository di terze parti siano sicuri (AlienBob a parte)?


Utilizzando, come scrivevo, diverse distro, spesso mi capita di utilizzare repository di terze parti (chiamatele repository, PPA, yum.conf, o come vi pare....sempre di terze parti sono): è ovvio che non si è mai certi al cento per cento della sicurezza del software (tempo fa infettarono un server di Mint e fu distribuita una ISO che conteneva malware), ma con questi dubbi un po' ci si deve convivere, altrimenti esiste sempre il build dai sorgenti. Dipende da cose devi fare e quanto spesso ti serve aggiornare un determinato pacchetto.

Per un desktop, anche con repository esterni, ma mantenuti, mi posso sentire ragionevolmente sicuro.

Avatar utente
gigiobagiano
Linux 3.x
Linux 3.x
Messaggi: 530
Iscritto il: dom mar 11, 2007 12:58
Nome Cognome: Filippo
Slackware: 14.2
Kernel: vanilla-4.4.38
Desktop: xfce
Distribuzione: SalixOS
Contatta:

Re: futuro slackware

Messaggioda gigiobagiano » mar dic 11, 2018 9:11

lablinux ha scritto:Niente di oscuro. L'aggiornamento è affidato a chi mantiene i repository e devi ricordari di aggiornare. Se fossero nei repo ufficiali un upgrade risolverebbe (oltre ad avere la garanzia della distro).
Alien (se sbaglio correggetemi) qualche mese fa perse il lavoro e interruppe il suo (impagabile) lavoro per la Slackware e i suoi pacchetti rimasero fermi. E' un caso ed è durato pochissimo tempo, si ricolloco in pochissimo tempo.
E' un caso, ma appoggiandosi a repo esterni (*)c'è questo rischio.
* motivo per cui non mi fido di snap o flatpack

Ah ok...c'è sempre questa possibilità che non vengano più mantenuti, ma questo lo si può dire anche di alcune distribuzioni o di qualsiasi altro software in cui la comunità che lo gestisce non si è strutturata nel tempo.

Contadino
Linux 0.x
Linux 0.x
Messaggi: 3
Iscritto il: lun lug 29, 2019 16:44
Slackware: 14.2
Kernel: 4.4.14
Desktop: kde

Re: futuro slackware

Messaggioda Contadino » mar lug 30, 2019 10:50

Buongiorno a tutti,

Mi permetto di rispondere a questo thread, a parer mio molto importante, perchè è una sensazione comune che sto leggendo nel tessuto da anni.......

Sono passato alla maggiore età di uso di slackware, ho iniziato nel 1998 e ho visto tutta la metamorfosi della distribuzione.

Ho sempre saputo che
Slackware è pronta quando è pronta
e forse mi sono sempre adeguato a questo pensiero, anche perchè poi quello che usciva non era mai un prodotto approssimativo o spinto da logiche di marketing sul rilascio temporizzato.

Slackware continuerà, nel suo lento incedere, a produrre una distribuzione di qualità, piena di pacchetti per ogni esigenza, magari anche obsoleti (ricordiamoci che in ambito industriale si usa ancora la seriale.... quindi il concetto di obsolescenza cambia dai vari punti di vista dal quale si guarda), da sistemare a proprio uso e consumo.

idefix
Linux 1.x
Linux 1.x
Messaggi: 181
Iscritto il: gio giu 19, 2008 1:48
Nome Cognome: stefano
Slackware: slack64-14.2
Kernel: 4.4.19
Desktop: tde 14.0.3

Re: futuro slackware

Messaggioda idefix » mar lug 30, 2019 14:59

se si ha la paranoia che i pacchetti siano "tarccati" basta farseli da soli.

piu che i pacchetti sarebbe bello uscisse una nuova release.
per compilare adesso dei pacchetti non si puo farli sulla 14.2
ormai datata ma neanche su una current che cambia di continuo....

Avatar utente
Trotto@81
Iper Master
Iper Master
Messaggi: 3556
Iscritto il: sab giu 26, 2004 0:00
Nome Cognome: Andrea
Slackware: Slackware64 14.2 bet
Kernel: default
Desktop: KDE 4.14.14
Località: Monasterace M. (RC)
Contatta:

Re: futuro slackware

Messaggioda Trotto@81 » mar lug 30, 2019 16:01

Come AlienBob mi chiedo perché non inserisca KDE 5 nella distribuzione.

Avatar utente
lablinux
Linux 4.x
Linux 4.x
Messaggi: 1124
Iscritto il: gio nov 27, 2008 12:23
Desktop: Gnome
Distribuzione: Debian testing
Località: Rho

Re: futuro slackware

Messaggioda lablinux » mar lug 30, 2019 16:09

ieri ho installato (virtualbox) la current , kde4 e mi sono intristito. Poi ho provato ad installare libreoffice (6.2) di Alien e il risultato era inguardabilie, le voci del menù non si vedavano finchè ci passavo sopra con il mouse, a questo punto diventavano di un blu inguardabile. Sicuramente è la versione da usare con plasma (kde5).
Ho buttato tutto.
Per avere una current da uso Desktop va installata senza kde ed installare kde5 di alien e libreoffice sempre di Alien (e altri pacchetti che possono servire)

Avatar utente
nyquist
Linux 2.x
Linux 2.x
Messaggi: 266
Iscritto il: sab ago 02, 2008 16:02
Nome Cognome: Cristiano Urban
Slackware: 14.2 multilib
Kernel: 4.4.190
Desktop: KDE
Località: Gonars (UD)
Contatta:

Re: futuro slackware

Messaggioda nyquist » mar lug 30, 2019 22:57

lablinux ha scritto:[...] le voci del menù non si vedavano finchè ci passavo sopra con il mouse, a questo punto diventavano di un blu inguardabile.

Confermo, succede pure a me sulla stable.

Avatar utente
lablinux
Linux 4.x
Linux 4.x
Messaggi: 1124
Iscritto il: gio nov 27, 2008 12:23
Desktop: Gnome
Distribuzione: Debian testing
Località: Rho

Re: futuro slackware

Messaggioda lablinux » mer lug 31, 2019 8:45

[OT]credo che libreoffice di Alien sia compilato per plasma, prova (se haI voglia) libreoffice di slackbuilds[/OT]

roberto67
Packager
Packager
Messaggi: 300
Iscritto il: lun set 14, 2009 18:55
Slackware: 14.2 multilib
Desktop: kde
Contatta:

Re: futuro slackware

Messaggioda roberto67 » mer lug 31, 2019 15:58

nyquist ha scritto:
lablinux ha scritto:[...] le voci del menù non si vedavano finchè ci passavo sopra con il mouse, a questo punto diventavano di un blu inguardabile.

Confermo, succede pure a me sulla stable.


pure a me sulla stable e con kde4. qui la soluzione https://alien.slackbook.org/blog/libreoffice-6-2-5-packages-available/: rimuovere il pacchetto libreoffice-kde-integration e cancellare ~/.config/libreoffice

Avatar utente
nyquist
Linux 2.x
Linux 2.x
Messaggi: 266
Iscritto il: sab ago 02, 2008 16:02
Nome Cognome: Cristiano Urban
Slackware: 14.2 multilib
Kernel: 4.4.190
Desktop: KDE
Località: Gonars (UD)
Contatta:

Re: futuro slackware

Messaggioda nyquist » mer lug 31, 2019 20:22

lablinux ha scritto:credo che libreoffice di Alien sia compilato per plasma, prova (se haI voglia) libreoffice di slackbuilds

Si, volendo potrei fare così. In realtà utilizzo una gestione mista dei pacchetti, la maggior parte da SBo tramite sbotools, mentre per i pacchetti più grossi, fra cui LibreOffice, preferisco affidarmi ai repository di precompilati di Alien tramite slackpkg.

roberto67 ha scritto:pure a me sulla stable e con kde4. qui la soluzione https://alien.slackbook.org/blog/libreo ... available/: rimuovere il pacchetto libreoffice-kde-integration e cancellare ~/.config/libreoffice

Ha funzionato, grazie mille!