[Risolto] Slackware 14.2 Xfce in italiano

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
mitzu_kurimiga
Linux 0.x
Linux 0.x
Messaggi: 11
Iscritto il: dom gen 27, 2013 0:44
Slackware: 14.2
Kernel: 4.4.14-smp
Desktop: xfce 4.12

[Risolto] Slackware 14.2 Xfce in italiano

Messaggioda mitzu_kurimiga » gio gen 24, 2019 19:41

Ciao a tutti
riscontro un problema nel rendere Slackware in italiano. Slackware 14.2 + XFCE Questi i miei lang.sh e lang.csh:
lang.sh

Codice: Seleziona tutto

#!/bin/sh
# Set the system locale.  (no, we don't have a menu for this ;-)
# For a list of locales which are supported by this machine, type:
#   locale -a

# en_US is the Slackware default locale:
#export LANG=en_US
export LANG=it_IT

# 'C' is the old Slackware (and UNIX) default, which is 127-bit
# ASCII with a charmap setting of ANSI_X3.4-1968.  These days,
# it's better to use en_US or another modern $LANG setting to
# support extended character sets.
#export LANG=C

# There is also support for UTF-8 locales, but be aware that
# some programs may possibly misbehave under UTF-8.  In those
# cases, you can set LANG=C before starting them.  Note that
# there are some UTF-8 locales that do not contain UTF-8 or
# utf8 in the locale name, so to test if a locale is UTF-8,
# use this command:
#
# LANG=<locale> locale -k charmap
#
# UTF-8 locales will include "UTF-8" in the output.
#
#export LANG=en_US.UTF-8
export LANG=it_IT.UTF-8

# Another option for en_US:
#export LANG=en_US.ISO8859-
it_IT@euro

# One side effect of the newer locales is that the sort order
# is no longer according to ASCII values, so the sort order will
# change in many places.  Since this isn't usually expected and
# can break scripts, we'll stick with traditional ASCII sorting.
# If you'd prefer the sort algorithm that goes with your $LANG
# setting, comment this out.
export LC_COLLATE=C

# End of /etc/profile.d/lang.sh


lang.csh

Codice: Seleziona tutto

#!/bin/csh
# Set the system locale.  (no, we don't have a menu for this ;-)
# For a list of locales which are supported by this machine, type:
#   locale -a

# en_US is the Slackware default locale:
#setenv LANG en_US
setenv LANG it_IT

# 'C' is the old Slackware (and UNIX) default, which is 127-bit
# ASCII with a charmap setting of ANSI_X3.4-1968.  These days,
# it's better to use en_US or another modern $LANG setting to
# support extended character sets.
#setenv LANG C

# There is also support for UTF-8 locales, but be aware that
# some programs may possibly misbehave under UTF-8.  In those
# cases, you can set LANG=C before starting them.  Note that
# there are some UTF-8 locales that do not contain UTF-8 or
# utf8 in the locale name, so to test if a locale is UTF-8,
# use this command:
#
# LANG=<locale> locale -k charmap
#
# UTF-8 locales will include "UTF-8" in the output.
#
#setenv LANG en_US.UTF-8

# Another option for en_US:
#setenv LANG en_US.ISO8859-1

# One side effect of the newer locales is that the sort order
# is no longer according to ASCII values, so the sort order will
# change in many places.  Since this isn't usually expected and
# can break scripts, we'll stick with traditional ASCII sorting.
# If you'd prefer the sort algorithm that goes with your $LANG
# setting, comment this out.
setenv LC_COLLATE C

# End of /etc/profile.d/lang.csh


Gli stessi file li ho su altre due installazioni di Slackware (fisso e portatile) che risultano in lingua italiana, mentre sul secondo portatile riscontro questo problema.
Idee?
Ultima modifica di mitzu_kurimiga il ven gen 25, 2019 13:48, modificato 1 volta in totale.

Avatar utente
lablinux
Linux 4.x
Linux 4.x
Messaggi: 1107
Iscritto il: gio nov 27, 2008 12:23
Desktop: Gnome
Distribuzione: Debian testing
Località: Rho

Re: Slackware 14.2 Xfce in italiano

Messaggioda lablinux » ven gen 25, 2019 9:03

problema di tastiera o di traduzione?

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2579
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.1.4
Desktop: lxde
Località: Pisa
Contatta:

Re: Slackware 14.2 Xfce in italiano

Messaggioda ponce » ven gen 25, 2019 10:24

per quel che riguarda le traduzioni, su Slackware 14.2 sono installate di default le seguenti localizzazioni

Codice: Seleziona tutto

$ locale -a | grep it_IT
it_IT
it_IT.utf8
it_IT@euro

quindi sono sufficienti due linee senza commento, ad esempio, in /etc/profile.d/lang.sh (lo dico perche' vedo che ne hai impostate diverse, anche in conflitto tra loro)

Codice: Seleziona tutto

export LANG=it_IT@euro
export LC_COLLATE=C

al posto di it_IT@euro, se ti ci trovi meglio, puoi anche provare una delle altre due disponibili.

Se le mofiche non si applicaaseri potrebbe essere perché in realtà sovrascrivi la variabile d'ambiente nei file di configurazione della shell del tuo utente, puoi verificarlo, per esempio, da un terminale con

Codice: Seleziona tutto

set | grep LC_
set | grep LANG


per la tastiera sotto X puoi invece seguire queste semplici istruzioni: ti consiglio comunque di leggerti tutta la pagina del wiki disponibile a quel link, dovrebbe chiarirti le idee.

Avatar utente
mitzu_kurimiga
Linux 0.x
Linux 0.x
Messaggi: 11
Iscritto il: dom gen 27, 2013 0:44
Slackware: 14.2
Kernel: 4.4.14-smp
Desktop: xfce 4.12

Re: Slackware 14.2 Xfce in italiano

Messaggioda mitzu_kurimiga » ven gen 25, 2019 13:20

Risolto come mi è stato suggerito.
Ho commentato:
export LANG=it_IT.UTF-8 in lang.sh
Non capisco però per sugli altri pc non da problemi...
Per la tastiera era già tutto ok.
Grazie. :thumbright: