La ricerca ha trovato 2358 risultati

da rik70
mer 18 mag 2022, 7:38
Forum: Slackware64
Argomento: Dual boot Porteus 5.0 con lxle configurazione Grub o Lilo
Risposte: 3
Visite : 261

Re: Dual boot Porteus 5.0 con lxle configurazione Grub o Lilo

Ok. La soluzione più "semplice" è creare una "entry" da dare in pasto al nuovo grub.cfg che andrai a generare da Ubuntu, utilizzando lo script che hai in '/etc/grub.d/40_custom'. Per far questo ti servono una serie di informazioni. Prima di tutto devi localizzare in quale partizione si trovano le im...
da rik70
lun 16 mag 2022, 20:26
Forum: Slackware64
Argomento: Slackware 15 - Pachetti driver nVidia proprietari
Risposte: 9
Visite : 196

Re: Slackware 15 - Pachetti driver nVidia proprietari

Sì alla fine è la cosa giusta da fare: contattare l'autore del pacchetto. Qui concludiamo la discussione dicendo che forse avevamo visto giusto. Leggo nello SlackBuild dei driver 510: # libOpenCL.so is now included in 15.0 (in ocl-icd), # so we don't need this one. rm -f $PKG/usr/lib${LIBDIRSUFFIX}/...
da rik70
lun 16 mag 2022, 15:16
Forum: Slackware64
Argomento: Slackware 15 - Pachetti driver nVidia proprietari
Risposte: 9
Visite : 196

Re: Slackware 15 - Pachetti driver nVidia proprietari

mi sembra che nelle nuove versioni dei driver (non ho controllato da quali) si tenda a mantenere la libOpenCL di ocl-icd e che da una certa versione in poi non ci sia piu' nemmeno lo script nvidia-switch: bisognerebbe sentire i maintainer dei vari script che pacchettizzano i driver nvidia, sarebbe ...
da rik70
lun 16 mag 2022, 14:49
Forum: Slackware64
Argomento: Slackware 15 - Pachetti driver nVidia proprietari
Risposte: 9
Visite : 196

Re: Slackware 15 - Pachetti driver nVidia proprietari

1) I driver nvidia funzionano poi al 100% se usiamo il libOpenCL stock di slackware? Il pacchetto crea il file '/etc/OpenCL/vendors/nvidia.icd' e forse - dico forse - potrebbe bastare. A quel punto basterebbe modificare lo SlackBuild ed eliminare la parte che installa la libreria OpenCL proprietari...
da rik70
lun 16 mag 2022, 11:05
Forum: Slackware64
Argomento: Post_Aggiornamento 14.2 > 15.0 - video codecs
Risposte: 18
Visite : 318

Re: Post_Aggiornamento 14.2 > 15.0 - video codecs

La faccenda nvidia-switch va tenuta presente e approfondita. Sulla slack15 ci sono le opencl, che vengono sovrascritte dai pacchetti dei driver nvidia, ma non vengono gestite - pare - dallo script nvidia-switch. E ffmpeg "linka" a quelle librerie. Ho aperto una discussione apposita, a beneficio di c...
da rik70
lun 16 mag 2022, 10:40
Forum: Slackware64
Argomento: Slackware 15 - Pachetti driver nVidia proprietari
Risposte: 9
Visite : 196

Slackware 15 - Pachetti driver nVidia proprietari

Prendendo spunto dagli ultimi argomenti trattati nel forum, mi chiedevo: sarebbe il caso, a vantaggio di chi utilizza i driver proprietari nvidia, proporre ai mantainer SBo una modifica allo script nvidia-switch in modo da includere anche le librerie OpenCL? Sbaglio o prima della Slackware 15 OpenCL...
da rik70
lun 16 mag 2022, 9:03
Forum: Slackware64
Argomento: Post_Aggiornamento 14.2 > 15.0 - video codecs
Risposte: 18
Visite : 318

Re: Post_Aggiornamento 14.2 > 15.0 - video codecs

P.s.
Poi, per completezza, dai uno sguardo al file 'install/doinst.sh' all'interno del pacchetto 'nvidia-legacy340-driver', e vedrai tu stesso dove stava il problema.
E mi sa che quelle librerie nvidia-switch non le rimuove. Deve seguire, dunque, una disinstallazione del pacchetto.
da rik70
lun 16 mag 2022, 6:27
Forum: Slackware64
Argomento: Post_Aggiornamento 14.2 > 15.0 - video codecs
Risposte: 18
Visite : 318

Re: Post_Aggiornamento 14.2 > 15.0 - video codecs

mi auguro che sia qualche problema sul mio sistema dovuto a rimasugli della slack 14.2. E' certo che sia andata così. L'aggiornamento va fatto solo dopo aver "pulito" il sistema da pacchetti esterni, in primis quelli che vanno a sovrascrivere le librerie di sistema. Pensa solo alla quantità di coll...
da rik70
sab 14 mag 2022, 21:06
Forum: Slackware64
Argomento: [RISOLTO] Errore dopo aggiornamento da 14.2 a 15.0 per libnvidia-glsi.so.340.108
Risposte: 11
Visite : 203

Re: [RISOLTO] Errore dopo aggiornamento da 14.2 a 15.0 per libnvidia-glsi.so.340.108

Ora per principio devo farli compilare... E mi sembra giusto 8) Poi perché mai terresti i nouveau? Perché gli nvidia non li aggiornano dal 2019. Se per disgrazia ti serve supporto al 3D con qualcosa? Perché non funziona il 3D coi nouveau? Chiedo eh, perché è da molto che non bazzico con nvidia. È u...
da rik70
sab 14 mag 2022, 18:05
Forum: Slackware64
Argomento: [RISOLTO] Errore dopo aggiornamento da 14.2 a 15.0 per libnvidia-glsi.so.340.108
Risposte: 11
Visite : 203

Re: [RISOLTO] Errore dopo aggiornamento da 14.2 a 15.0 per libnvidia-glsi.so.340.108

*Ps.

Io comunque, al posto tuo, se non ti danno problemi terrei i nouveau.
da rik70
sab 14 mag 2022, 17:56
Forum: Slackware64
Argomento: [RISOLTO] Errore dopo aggiornamento da 14.2 a 15.0 per libnvidia-glsi.so.340.108
Risposte: 11
Visite : 203

Re: [RISOLTO] Errore dopo aggiornamento da 14.2 a 15.0 per libnvidia-glsi.so.340.108

Dirai, perché manca la patch "0006"? Perché nell'applicarla dà un'errore e esce FAILED. È quella per il kernel 5.14. Devi sostituire tutte le patch. Scarica https://aur.archlinux.org/cgit/aur.git/snapshot/nvidia-340xx-lts.tar.gz e scompattalo nella root dei sorgenti del pacchetto. Poi nello SlackBu...
da rik70
sab 14 mag 2022, 13:48
Forum: Slackware64
Argomento: [RISOLTO] Errore dopo aggiornamento da 14.2 a 15.0 per libnvidia-glsi.so.340.108
Risposte: 11
Visite : 203

Re: [RISOLTO] Errore dopo aggiornamento da 14.2 a 15.0 per libnvidia-glsi.so.340.108

Nel caso qualcosa non vada ancora, reinstalla con slackpkg quantomeno tutti i pacchetti 'l' e 'x'. Il comando: slackpkg reinstall l/* x/* oppure dillo tu a me. Poi dai di nuovo slackpkg upgrade-all ** Per la versione che usi dei driver nvidia serve questa serie di patch, esclusa la prima: https://au...
da rik70
ven 13 mag 2022, 7:53
Forum: Gnu/Linux in genere
Argomento: LinageOS sul PC con virt-manager
Risposte: 43
Visite : 1132

Re: LinageOS sul PC con virt-manager

Ho pensato: sta vedere che a rompere era proprio un qualche tipo di bug del WM ostile a java o similare. _JAVA_AWT_WM_NONREPARENTING=1 studio.sh Su una sessione wayland, in caso di errore e/o schermata bianca, bisogna usare le variabili QT_QPA_PLATFORM=xcb _JAVA_AWT_WM_NONREPARENTING=1 Eh guarda un...
da rik70
gio 12 mag 2022, 7:59
Forum: Gnu/Linux in genere
Argomento: LinageOS sul PC con virt-manager
Risposte: 43
Visite : 1132

Re: LinageOS sul PC con virt-manager

E come diamine hai fatto? Ci sono le build. Guarda tu stesso: zulu, adopten, etc. Eh se ne riparla sì! Uhm... qui o mi tocca scrivere una guida? :) E' più semplice a farsi che a dirsi, una volta individuati gli intoppi. Ma poi, in teoria dovrebbe funzionare anche sulla slack 14.2, a meno che non ci...
da rik70
mar 10 mag 2022, 21:10
Forum: Gnu/Linux in genere
Argomento: LinageOS sul PC con virt-manager
Risposte: 43
Visite : 1132

Re: LinageOS sul PC con virt-manager

Se riesci a emulare win10 sul tuo sistema, non vedo ostacoli a emulare pure Android. Certo, CPU e soprattutto memoria fanno la differenza. Penso anch'io che debba quantomeno aggiornare la distro. Quanto ad A.Studio, confermo che l'ultima versione 'AndroidStudio2021.2' gira senza problemi su Slackwar...