Pagina 1 di 1

Kernel panic: aiuto!

Inviato: dom 11 dic 2005, 9:29
da nowhere
Stamattina al normale avvio di Slack, la brutta sorpresa: kernel panic!!
Vi posto i messaggi d'errore presi dalla modalità testuale di avvio:

Linux IP Multicast router 006 plus PIM-SM
NET4: Unix domain sockets 1.0 SMP for Linux Net 4.0
-----
FAT:bogus logical sector size 137
UMSDOS: msdos_read_super failed, mount aborted.
FAT:bogus logical sector size 137
FAT:bogus logical sector size 137
sh-2021: reiserfs_read_super: can not find reiserfs on ide0(3,6)
Kernel panic:VFS:UNable to mount root fs on 03:06

Premetto che non ho toccato nulla (mai) delle partizioni, del file system, o di file di config importanti. Negli ultimi giorni ho smanettato solo un po per provare a installare le gDesklets e poi con i temi e gli stili di Fluxbox...

Ho un portatile Toshiba, Dual boot: XP SP2 e Slack 10.1 kernel bare.acpi 2.4.29
Partizionamento linux sul disco (unico da 40 Gb circa):

/dev/hda5/ fat32 partizione scambio dati
/dev/hda6/ ext3 root
/dev/hda7/ swap partizione di swap
/dev/hda8/ home Partizione utente

Cosa posso fare per risolvere il problema? Mi viene da piangere al pensiero di perdere tutto...mesi e mesi di configurazioni e sacrifici per far funzionare le varie cose...e voi lo sapete bene.

P.S.dal messaggio d'errore non capisco molto, solo che ci deve essere un settore logico del disco corrotto..
Il fatto che non trovi il file system reiser su hda (3:6 che vuol dire, è mica la partizione di root?) come può essere possibile?

Ho bisogno del vostro aiuto, grazie!

P.S. chiedo scusa per "l'urlo" di aiuto nel titolo del post, dettato dalla disperazione...

Inviato: dom 11 dic 2005, 9:47
da Sonic
Scusa la partizione / su che filesystem l'hai montata? Ext3 o Reiserfs?
Ti sei fatto un dischetto di avvio per sicurezza?
Comunque non ti preoccupare puoi sempre recuperare tutto con una distro live come knoppix.

Inviato: dom 11 dic 2005, 10:44
da nowhere
La partizione / era stata creata con fs Ext3 e mai modificata.
Il problema è proprio li, ho avviato con un LiveCD ed effettivamente non riesco a montare la partizione in questione: filesystem unknown.
Vi posto alcuni output di comandi dati:

root@1[etc]# fdisk /dev/hda6
Device contains neither a valid DOS partition table, nor Sun, SGI or OSF disklabel
Building a new DOS disklabel. Changes will remain in memory only,
until you decide to write them. After that, of course, the previous
content won't be recoverable.

The number of cylinders for this disk is set to 1029.
There is nothing wrong with that, but this is larger than 1024,
and could in certain setups cause problems with:
1) software that runs at boot time (e.g., old versions of LILO)
2) booting and partitioning software from other OSs
(e.g., DOS FDISK, OS/2 FDISK)
Warning: invalid flag 0x0000 of partition table 4 will be corrected by w(rite)

root@1[etc]# fdisk -l

Disk /dev/hda: 40.0 GB, 40007761920 bytes
255 heads, 63 sectors/track, 4864 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 2177 17486721 7 HPFS/NTFS
/dev/hda2 2178 4864 21583327+ f W95 Ext'd (LBA)
/dev/hda5 2178 2432 2048256 b W95 FAT32
/dev/hda6 2433 3462 8273443+ 83 Linux (qui la segnala come part. Linux, ma ad esempio con tool grafici (gparted ad es.) viene riportato fs unknown)
/dev/hda7 3463 3589 1020096 82 Linux swap
/dev/hda8 3590 4864 10241406 83 Linux

root@1[etc]# mount -t ext3 /dev/hda6 /mnt/hda6
mount: wrong fs type, bad option, bad superblock on /dev/hda6,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

Inviato: dom 11 dic 2005, 11:25
da Paoletta
puoi usare e2fsck per vedere se riesci a correggere gli errori presenti nel filesystem...

da una live,senza tentare di montare la partizione, dai
#e2fsck -v -y /dev/hda6
e vedi che errori riesce a correggere

Inviato: dom 11 dic 2005, 15:02
da nowhere
Grazie Paoletta, davvero!
RIsolto con e2fsck, di cui non conoscevo neanche l'esistenza...mazza che 'gnurant...
Non ti posto l'output del comando perchè veramente troppo lungo. In sintesi comunque ha riscontrato diversi errori (ref count errati su diversi inode, free blocks count wrong, directories count wrong, ecc). Al successivo reboot il fs è stato montato.
Mi resta da capire cosa diavolo sia successo...

Comunque grazie mille, di cuore.

Ciao

Inviato: dom 11 dic 2005, 20:25
da Paoletta
prego!

P.S. se tu avessi avuto reiserfs non so se sarebbe stato così facile...ma per fortuna hai ext3

Inviato: dom 11 dic 2005, 20:36
da strummer
ciao Paoletta,
ti volevo chiedere una cosa, visto che spesso sento dire che ext3è meglio di reiserfs e non essendo molto preparato in materia di filesystem, potrei sapere perchè?
grazie

Inviato: dom 11 dic 2005, 20:38
da Firetux
strummer, cerca nel forum...ci sono molti topic a riguardo

Inviato: dom 11 dic 2005, 20:39
da Paoletta
ext3 è molto più stabile di reiserfs...che comunque è il futuro, per quanto riguarda i filesystem;

Inviato: dom 11 dic 2005, 20:40
da strummer
ok, grazie per ora, cercherò nel forum per saperne di più!
ciao