Pagina 1 di 1

Installazione mysql Errore

Inviato: mer 28 dic 2005, 10:40
da tylyo
ho scaricato i paccheti da slacky con swaret
apache pare funzionare
cosi come php
ma durante la prcedura di configurazione del mysql ho riscontrato il seguente problema:

>mysql_install_db..... ok
>chown -R mysql:mysql /usr/share/mysql
>chown -R mysql:mysql /usr/share/mysql/data .... (non esiste)
>mysqld_safe & ... (il demone parte)

>mysqladmin -u root password 'asd'
mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'root'@'localhost' (using password: NO)'

dove sbaglio ?

Inviato: mer 28 dic 2005, 11:09
da GuRpS
>chown -R mysql:mysql /usr/share/mysql/data .... (non esiste)

Bhe' questo imho e' superfluo...tanto hai dato il -R prima quindi tutto cio' che c'e' in /usr/share/mysql e' gia' chown-nato

per il resto....io sulla guida LAMP che c'e' su slacky avevo trovato che si dovesse fare:

Codice: Seleziona tutto

cp /etc/my-medium.cnf /etc/my.cnf
mysql_install_db
chown -R mysql:mysql /var/lib/mysql
mysql_safe &

mysqladmin -u root password "tuapassword"

killi tutto mysqld

fai ripartire con

mysql_safe --user=mysql &
E personalmente a me va tutto...

Inviato: mer 28 dic 2005, 11:13
da tylyo
si ma a me da errore in:

>mysqladmin -u root password 'asd'
mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'root'@'localhost' (using password: NO)'

Inviato: mer 28 dic 2005, 11:50
da GuRpS
ehhh ma tu salit il chown a /var/lib/mysql ...

Forse e' per quello...

Inviato: mer 28 dic 2005, 11:56
da tylyo
Stesso errore anche se eseguo
chown -R mysql:mysql /var/lib/mysql

Inviato: mer 28 dic 2005, 16:48
da tylyo
Anche reinstallando incontro gli stessi problemi, qualcuno mi può spiegare dove sbaglio o cosa devo fare per far funzionare mysql?

Inviato: gio 29 dic 2005, 11:23
da tylyo
[RISOLTO]

ho controllato l'owner della directory di root e, non so per quale motivo risultava l'user

Codice: Seleziona tutto

-rwxr-xr-x  1 tylyo root 72229632 2005-12-25 12:21
quindi correggendolo

Codice: Seleziona tutto

> chown -R root:root /root
tutto ha funzionato come si deve
:wink: :wink: :wink: :wink: :wink: :wink: :wink: