Pagina 1 di 1

Lamp on Slackware

Inviato: gio 19 gen 2006, 12:59
da Litie
Ho necessità di installare un server locale per farci girare dei gestionali in php.

Letta la s4d e le guide del caso procedo alla configurazione di Apache, e fino quì tutto ok.I problemi arrivano con MySQL; con ordine,eseguo:
#cp /etc/my.medium.conf /etc/conf
#mysql_install_db
#cd /var/lib
#chown -R mysql mysql
#chgrp -R mysql mysql
#mysqld_safe & /* parte il processo e non compare il prompt,clicco su INVIO* e ricompare # */
# mysqldmin -u root password 'lamiapass'
dopo l'ultimo comando ottengo
#mysqladmin -u root password 'lamiapass'
mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'root'@'localhost' (using password: NO)'
ma digitando
root@pavia:/bin# mysql -p
Enter password:******
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 7 to server version: 4.1.14-log

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql>
ciò significa che MySQL è configurato correttamente???

Per la cronaca,più volte ho seguito la procedura d'installazione ...

facendo altri tentativi ottegno
#root@pavia:/bin# /etc/rc.d/rc.mysqld stop
STOPPING server from pid file /var/run/mysql/mysql.pid
060119 12:57:47 mysqld ended

#root@pavia:/bin# /etc/rc.d/rc.mysqld start
root@pavia:/bin# Starting mysqld daemon with databases from /var/lib/mysql

#root@pavia:/bin# mysqld_safe --user=mysql &
[3] 5443
root@pavia:/bin# A mysqld process already exists
in sostanza vorrei far funzionare un gestionale php in locale e mi sto bloccando col MySQL....porca eva :evil:

Inviato: gio 19 gen 2006, 13:06
da twister
Il comando è
mysql -u root -p
poi ti chiede la pass

Codice: Seleziona tutto

 mysql -u root -p                    
Enter password: 
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 2 to server version: 4.1.14-log

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql> 

Inviato: gio 19 gen 2006, 18:46
da Litie
Ne sto uscendo matto.... :cry: :cry: :cry:

Ho seguito tutta la guida e letto mille 3d...in pratica ora lamp sembra funzionare ,infatti
root@pavia:/home/Litie/Desktop# mysql -u root -p
Enter password:******
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 144 to server version: 4.1.14-log

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql> SHOWS DATABASE;
+----------+
| Database |
+----------+
| gazie |
| geco |
| mysql |
| nuke |
| test |
+----------+
5 rows in set (0.00 sec)

mysql>
ma non c'è nulla da fare,ho scaricato nuke e altri sistemi php 'geco' e 'gazie'...li metto nella dir giusta /var/www/htdocs ma quando mi connetto a

*http://localhost/phpnuke/admin.pho
vedo una paginazza pianca

*http://localhost/geco/admin.php
schermo bianco con scritta Impossibile connettersi a MySql


ma perchèèè???

Inviato: gio 19 gen 2006, 18:47
da Litie
ho installato e configurato phpmyadmin....

Inviato: gio 19 gen 2006, 19:17
da Luci0
... un grazie per le dritte .. no ?? :(

comunque per gazie leggi la documentazione ben fatta, non dovresti avere grossi problemi
per opengeco non so !!

Inviato: gio 19 gen 2006, 19:20
da alessiodf
Litie ha scritto:ho installato e configurato phpmyadmin....
non si è capito..Apache ti funge o no? prova da firefox a fare http://localhost
se vedi il logo di apache va tutto ok! Le pagine bianche che vedi sono sicuramente errori negli script in php che vai a leggere...se non configuri apache in modo che ti faccia notare gli errori degli script, ti tira fuori solo le pagine banche in casi di errori sul codice PHP :D

Inviato: gio 19 gen 2006, 19:46
da Litie
Si scusatemi tutti....sono stato un cafone :oops: :oops:

Ma stavo impazzendo prima....ora mi funziona quasi tutto LAMP .phpnuke va alla grande,gazie e geco devo sistemarli però sono sulla strada giusta!!!!

In pratica facevo erroracci di gestione del MySQL non avendo ben chiaro i suoi comandi principale;ho risolto i problemi di accesso alle pagine php settando bene i config.php del nuke,geco e gazie...

Vi ringrazio tutti per l'aiuto e le dritte :D
Vi sono in debito di una birra...

Ps:Sto giocando con GAZIE ma ho problemi di accesso nella pagina iniziale,quella di login.In pratica di chiede username e password,allora vado ad inserire dati fittizi x l'accesso nella tabella gaz_admin del db gazie.In pratica creo l'utente,vado alla pagina di login e mi dice che i valori inseriti sono errati...eppure sto attentissimo nella digitazione!!!!boh,voi sapete come entrare ???

Inviato: ven 20 gen 2006, 10:20
da Luci0
Per gazie leggi bene la documentazione c' é una nota dell' autore per questo tipo di problemi e ovrebbe essere un problema di versione di Mysql ...

Inviato: ven 20 gen 2006, 10:42
da Litie
Grazie a tutti...finalemnte ho risolto :D :D :D

Per gazie basta cercare la pagina install.html che si trova in /gazie/doc ,aprire e seguire i comandi;in automatico viene creato il DB gazie con relativi codici d'accesso!Per non avere problemi di connessione a MySQL bisogna cercare il file config.php in /gazie/inc e settare correttamente i parametri
<?php
//versione software
$versSw = "2.0.5";
//libreria della lingua presente nella dir language con nome language.inc.php
$language = "italian";
//array con le descrizioni della valuta utilizzata
$money = array("euro","&#128;","EUR");
//nome DBMS usato per la libreria specifica (MySQL=mysql.lib, SQLite=sqlite.lib, ecc)
//per il momento disponibile solo la libreria mysql.lib
$NomeDB = "mysql";
// Parametri di accesso: server, db, utente, passwd e prefisso per le tabelle
$Host = "localhost";
$Database = "gazie";
$User = "root";
$Password = "XXXXXXX"; /* <------ metti quì la tua PW d'accesso a MySQL *//
$table_prefix = "gaz";
?>
Grazie a tutti!!!!

PS:Carino gazie :D