Pagina 1 di 2
US RObotics 56 KB
Inviato: lun 29 mag 2006, 22:13
da samiel
Immagino che i post sul tema non manchino,
ma causa ristrutturazione della casa
sono rimasto senza ADSL e sono tornato al vecchio modem 56KB,
per cui navigo lentisssssssssssssimo...
Per la fretta, ho impostato la connessione direttamente con KPPP,
ma quando tento di connettermi il modem resta in attesa.
C'è qualcosa da cambiare nella stringa di inizializzazione?
Ho un US Robotics Fax Modem 56KB.
Grazie
M.
Inviato: lun 29 mag 2006, 22:51
da syaochan
Che sia il classico ATX3?

Inviato: lun 29 mag 2006, 22:54
da Paoletta
Inviato: mar 30 mag 2006, 10:45
da samiel
Allora... col 2.6 da me compilato non funge, ma col 2.4 di defult sì,
per cui si tratta di qualche errore di compilazione. Ma è la prima volta
che mi connetto con un modem, per cui evidentemente mi manca
qualche passaggio. Col 2.4 però il modem, pur componendo il numero
telefonico del provider, non si connette di fatto e non pinga nulla.
Questo pomeriggio rismanetto. Anche se ogni volta, per postare qui,
devo uscire d Slack e avviare Windows.... che stress!!
Thanx
M.
Inviato: mar 30 mag 2006, 15:34
da samiel
Avevo seguito i passaggi del breve how-to indicatomi da Paoletta;
ho provato semplicmente a sostituire la stringa di connessione.
Sembra che il modem si colleghi, ma non riesco a navigare.
Non pingo nulla e sia Firefox sia Lynx non aprono nessuna pagina.
Ci sono dari particolari da mettere in resolv.conf o altrove?
Beh, intanto vi scrivo da Windows eheheh...
M.
Inviato: mar 30 mag 2006, 15:38
da nicop
Ciaoo samiel anche io ho lo stesso modem criceto!!sono riuscito a collegarmi impostando la connessione con pppsetup perchè kppp mi restituiva un errore (la prima volta mi ha dato un errore con codice 2,risolto questo errore , mi dava un errore con codice 1...mi sono stufato ed ho usato pppsetup!!!)vabbè...
comunque per farsi si che funzionasse in modo stabile ho dovuto provare un po di comandi AT.
Ti posto i miei file di configurazione così puoi vedere :
file options
defaultroute
noipdefault
modem
/dev/ttyS0
115200
crtscts
passive
asyncmap 0
name "telecom"
File pppscript
TIMEOUT 60
ABORT ERROR
ABORT BUSY
ABORT "NO CARRIER"
ABORT "NO DIALTONE"
"""ATZ" OK "ATM1L1" OK -----> questi sono i comandi AT
"atdt7020187187"
TIMEOUT 75
CONNECT
L'unico problema che ancora nn riesco a risolvere è il seguente :
una volta stabilita la connessione lanciando ppp-go da root per poter navigare mi tocca aggiungere l'interfaccia ppp0 come gateway a mano lanciando il comando
route add default ppp0
Spero ti esserti d'aiuto...ciaooo
P.S. se riesci a collegarti con kppp e a fare aggiungere in automatico ppp0 come gateway me lo fai sapere???
Inviato: mar 30 mag 2006, 18:57
da samiel
Grazie dei suggerimento. Ho provato in velocità,
ma ppp-go mi dice "inizialization script failed"
e il comando route che mi hai suggerito ha come
output "SIOCADDRT: No such device".
Devo ancora lavorarci sopra....
M.
Inviato: mar 30 mag 2006, 21:04
da samiel
Adesso ho modificato tutto con pppsetup.
Nicop, tu che metodo di autenticazione hai usato?
PAP, CHAP o lo script? E in quest'ultimo caso,
che hai fatto esattamente?
Grazie
M.
Inviato: mar 30 mag 2006, 21:12
da nicop
Per quando riguarda il comando route è logico che ti da quell'output questo perchè il comando va lanciato dopo che la connessione è avvenuta e l'interfaccia ppp0 creata....
Per l'altro errore invece ,credo che sia dovuto ai parametri di connessione ...
tipo ..hai cambiato il numero di telefono???
il numero che deve comporre è riportato nel file pppscript ed esattamente in questa voce
"atdt7020187187"questo numero è relativo a teleconomy internet che è una particolare offerta di telecom,se usi il collegamento a consumo di telecom devi inserire il numero 7020001033.....un'altra voce che devi cambiare è la seguente
name "telecom" si trova alla fine del file options al posto di telecom ci metti il tuo nome utente...infine questo mi ero dimenticato ti posto anche il file pap-secret dove ci devono stare le tue credeziali per collegarti :
questo è il mio :
# Secrets for authentication using PAP
# client server secret IP addresses
"telecom" * "telecom"
tu devi sostituire il primo "telecom" con il tuo nome utente ed il secondo "telecom" conla tua password di accesso.
nota bene tra il campo nome utente e l'asterisco lo spazio viene dato dalla pressione del tasto TAB idem tra l'asterisco e il campo password...cosa stupida ma altrimenti nn funziona!!!!!
Prova a fare queste modifiche...ciaooo
Inviato: mar 30 mag 2006, 21:42
da nicop
comunque io ho utilizzato l'autenticazione PAP....
Inviato: mar 30 mag 2006, 21:52
da samiel
Ce l'ho fatta, sto postando da Slack!
Hai ragione comunque, bisogna dare ogni volta
il comando route. Adesso vedo se scopro
come renderlo permanente. Ma i dati
che restituisce route -n dove stanno scritti?
M.
Inviato: mer 31 mag 2006, 1:17
da nicop
innanzitutto volevo dire che mi fa piacere che ti sono stato d'aiuto,io grazie a questo forum ho imparato tante cose su slackware,per quando riguarda il comando route -n sinceramente nn lo so proprio dove scrive i dati...vabbè comunque chi riesce a scoprire prima il modo di rendere il comando permanente posta la soluzione.....ciaooo
Inviato: ven 2 giu 2006, 14:44
da samiel
Allora... sto studiando il caso. Le soluzioni
sono molto diverse a seconda della configurazione
del tuo pc. Hai un router? Una scheda di rete?
O usi solo il modem per connetterti? In questo caso,
basta eliminare la voce:
# Default gateway IP address:
# GATEWAY="192.168.0.1"
in /etc/rc.d/inet1.conf
e l'instradamento viene effettuato in modo corretto
senza dover ogni volta usare route...
M.
Inviato: ven 2 giu 2006, 17:22
da nicop
samiel ha scritto:Allora... sto studiando il caso. Le soluzioni
sono molto diverse a seconda della configurazione
del tuo pc. Hai un router? Una scheda di rete?
O usi solo il modem per connetterti? In questo caso,
basta eliminare la voce:
# Default gateway IP address:
# GATEWAY="192.168.0.1"
in /etc/rc.d/inet1.conf
e l'instradamento viene effettuato in modo corretto
senza dover ogni volta usare route...
M.
Grazie della dritta ho risolto andando a commentare la voce GATEWAY,ti devo correggere però,il file dove andare a commentare la voce nn è inet1.conf ma rc.inet1.conf....
ciaooo
Inviato: ven 2 giu 2006, 17:40
da samiel
Lapsus calami,
o meglio "tastierae"
M.