Pagina 1 di 1
Kernel 2.6.17.1
Inviato: ven 23 giu 2006, 15:59
da Riddick
Sto provando a compilare un 2.6.17.1 per il mio laptop Toshiba Portege M100.
Quando la faccio avviare da lilo,
VFS mi da un Kernel panic perche non trova il root che li ho detto (root=/dev/hda1).
Poche linee prima di fare questo c'e scritto
hda TOSHIBA MODEL NUMBER
Perche succede questo? Il mio disco e' reiserfs e reiserfs e' compilato nel kernel e
non e' un modulo...
Riddick
Inviato: ven 23 giu 2006, 16:49
da whites11
che stringa di errore ti da esattamente?
Inviato: ven 23 giu 2006, 19:49
da Riddick
Mi Dice:
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
Che cosa ho fatto di sbagliato?
Inviato: ven 23 giu 2006, 20:19
da DD0p
Sicuro che quando hai compilato il kernel l'hai messo reiserfs come built in?
Inviato: ven 23 giu 2006, 20:21
da chrix
hai per caso creato la initrd ?
ti rimando a " man mkinitrd"
Inviato: ven 23 giu 2006, 20:31
da Riddick
non la ho creata... ma tutti I miei 2.6 partono senza
ma cerchero' di farla... per bootare diversi kernels mi servono diversi initrd?
Grazie,
Riddick
Inviato: ven 23 giu 2006, 20:39
da chrix
per lo meno per kernel della serie 2.6.x,
si: devi avere diversi initrd per ogni visto che la initrd è specifica alla versione del kernel
consulta la pagina di manuale: man mkinitrd per informazioni dettagliate.
Inviato: ven 23 giu 2006, 20:40
da whites11
se hai inserito il supporto reiser built-in l'initrd non c'entra!
verifica di averlo fatto (succede anche ai migliori di sbagliare) poichè l'errore è quello classico della mancanza del modulo!!!
Inviato: ven 23 giu 2006, 20:42
da Riddick
confermo che reiserfs e compilato nel kernel e non come modulo.
All'inizio pensavo che non lo avevo fatto ma lo ho fatto.
Secondo me il problema e da altre parti...
Riddick
Inviato: sab 24 giu 2006, 10:18
da whites11
il disco è un normale ide (non sata) giusto? altrimenti potrebbe essere un problema di moduli per il controller sata
Inviato: sab 24 giu 2006, 15:33
da Riddick
boh... ora sembra funzionare... ho copiato il .config dal mio 2.6.16.1 che funzionava
allora ora funziona tutto bene (e senza initrd)
Riddick