Pagina 1 di 1

Configurare PHP + APACHE + MYSQL

Inviato: dom 9 lug 2006, 12:17
da sonzo
ragazzi, ho scaricato i packeges di php apache e mysql.

Pero' non riesco a visualizzare i files php, o meglio vedo solo il sorgente del php e non mi interpreta il linguaggio.

Ho configurato httpd.conf inserendo queste stringhe:

LoadModule php5_module /usr/lib/apache2/libphp5.so

AddType application/x-httpd-php .php

libphp5.so si trova in quella dir, l'ho trovata con un FIND :D

Ma nonostante tutto non va e non capisco come mai!!!!!

Io ho provato anche a fare un apachectl stop

Se pero' faccio un http://127.0.0.1 vedo la mia pagina html.
Come mai? teoricamente non dovrebbe non vedersi visto che è bloccato il server?

Boh.. sono nelle vostre mani grazie!!

Ciao.

Inviato: dom 9 lug 2006, 12:31
da sonzo
Io ho provato anche a fare un apachectl stop

Se pero' faccio un http://127.0.0.1 vedo la mia pagina html.
Come mai? teoricamente non dovrebbe non vedersi visto che è bloccato il server?
Niente lasaciate perdere questo perchè... ho cancellato la cache del browser e ora va tutto bene ;)

Comunque il problema del php rimane!
:D
A presto

Inviato: dom 9 lug 2006, 13:12
da airex
la pagina php che vuoi "vedere" ha l'estensione .php vero?
Intanto che ci sei controlla cosa dicono i file di log di apache, spesso se ci sono problemi li qualcosa viene detto :wink:

Inviato: dom 9 lug 2006, 14:50
da manolo
Hai abilitato php in apache.conf?

Inviato: dom 9 lug 2006, 21:42
da Darathorn
hai aggiunto index.php in directoryindex ?

Inviato: lun 10 lug 2006, 11:24
da sonzo
Ragazzi risolto, prima non mi dava Powered By PHP ora si!

Ma nonostante questo non va comunque :(

Vi posto qualche output:

# telnet 127.0.0.1 80
Trying 127.0.0.1...
Connected to 127.0.0.1.
Escape character is '^]'.
HEAD / HTTP/1.0

HTTP/1.1 200 OK
Date: Mon, 10 Jul 2006 09:17:35 GMT
Server: Apache/2.0.58 (Unix) DAV/2 PHP/5.1.4
X-Powered-By: PHP/5.1.4
Connection: close
Content-Type: text/html

Connection closed by foreign host.

Quindi sembra OK. Gli error sono:

# tail error_log
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/extensions/no-debug-non-zts-20050922/pdo_firebird.so' - libfbclient.so.1: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/extensions/no-debug-non-zts-20050922/pdo_odbc.so' - libodbc.so.1: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/extensions/no-debug-non-zts-20050922/pdo_pgsql.so' - libpq.so.4: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/extensions/no-debug-non-zts-20050922/pdo_sqlite.so' - libsqlite3.so.0: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/extensions/no-debug-non-zts-20050922/pgsql.so' - libpq.so.4: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/extensions/no-debug-non-zts-20050922/sqlite.so' - libsqlite.so.0: cannot open shared object file: No such file or directory in Unknown on line 0
[Mon Jul 10 10:27:52 2006] [notice] Apache/2.0.58 (Unix) DAV/2 PHP/5.1.4 configured -- resuming normal operations
[Mon Jul 10 10:28:21 2006] [error] [client 127.0.0.1] File does not exist: /var/www/htdocs/favicon.ico
[Mon Jul 10 10:28:27 2006] [error] [client 127.0.0.1] File does not exist: /var/www/htdocs/favicon.ico
[Mon Jul 10 10:28:31 2006] [error] [client 127.0.0.1] File does not exist: /var/www/htdocs/favicon.ico

Che dite ? sembra ok.

Provate a dirmi cosa avete voi nel vs file httpd.conf!
Che mi dite? COnsigli? Opinioni?

Ciao

Inviato: lun 10 lug 2006, 11:28
da sonzo
Ops dimenticavo.. sembra OK.. beh tranne gli errori di PHP.

Come mai quegli errori? Che devo fare?

Inviato: lun 10 lug 2006, 11:43
da aschenaz
Se non ti serve proprio il php5, io, al posto tuo, disinstallerei tutto e installerei Apache, Php e MySql dal cd di slackware 10.2. Così sei sicuro che funziona.
Scusa la soluzione un po' spartana... :)
Ciao,
nino

Inviato: lun 10 lug 2006, 12:10
da sonzo
Uhm.. ma da CD? con cosa? Installpkg?

Io volevo provare così!!!!!

Che mi dite?

Inviato: lun 10 lug 2006, 12:23
da aschenaz
sonzo ha scritto:Uhm.. ma da CD? con cosa? Installpkg?
Proprio così!
Dal primo CD:
MySql sta nella directory ap;
Apache e PHP stanno nella directory n.
Ciao,
nino

Inviato: lun 10 lug 2006, 12:42
da sonzo
uhm.. scusa l'ignoranza avvio il CD
e poi entro via shell come # e faccio un installpkg?

Inviato: lun 10 lug 2006, 13:52
da aschenaz
sonzo ha scritto:... avvio il CD
e poi entro via shell come # e faccio un installpkg?
Si:
prima, però, disinstalla i pacchetti che hai installato (con removepkg),
poi monta il cd,
diventa root e

Codice: Seleziona tutto

installpkg /mnt/cdrom/slackware/ap/mysql-[versione].tgz...
Fa' lo stesso con Apache e Php.

Ciao,
nino

Inviato: mar 11 lug 2006, 11:35
da sonzo
Ho fatto, rimosso i pacchetti e tutto.. ma niente non gira. Ho inserito i LoadModules etc etc ma niente mi dice che non trova alcuni moduli. Come mai??????

Inviato: mar 11 lug 2006, 12:02
da aschenaz
sonzo ha scritto:Ho fatto, rimosso i pacchetti e tutto.. ma niente non gira. Ho inserito i LoadModules etc etc ma niente mi dice che non trova alcuni moduli. Come mai??????
Apache parte?
Che moduli non trova?

Inviato: mar 11 lug 2006, 14:47
da sonzo
Grazie per tutto ragazzi....

Ho risolto installando la versione 2 di Apache e la 5; che fino a 2 giorni fa non andava..

Sono stato ore sul file httpd.conf etc etc... Mi sono rotto il cranio e ho risolto.

Ho rimossi i pacchetti, e li ho reinstallati e ora sembra andare tutto.

Ringrazio.

Ciao