Pagina 1 di 1

aggiornare php [risolto]

Inviato: lun 11 set 2006, 22:54
da bbg5ne
cosa devo fare per aggiornare php oltre all'upgradepkg del pacchetto?
ho correntemente istallato la versione 4.0 di php!
grazie :roll:

Inviato: lun 11 set 2006, 23:08
da dapuzz
credo niente più, perchè mi sembra che apache carichi il modulo giusto a seconda di cosa trova. Anzi, ora che ricordo c'era una libreria da aggiornare, libmm mi sembra ma non mi ricordo bene.
Dopo aver upgradato comunque fai un restart ad apache e se dà qualche errore all'avvio ce lo incolli qui e vediamo che fare :)

Inviato: lun 11 set 2006, 23:25
da bbg5ne
eccolo:

Codice: Seleziona tutto

syntax error on line 277 of /etc/apache/httpd.conf:
Cannot add module via name 'mod_php5.c': not in list of loaded modules
/usr/sbin/apachectl start: httpd could not be started

Inviato: lun 11 set 2006, 23:28
da bbg5ne
ho modificato una cosa ed ecco l'errore su libmm ma che roba è?

Codice: Seleziona tutto

Cannot load /usr/libexec/apache/libphp5.so into server: libmm.so.14: cannot open shared object file: No such file or directory
/usr/sbin/apachectl start: httpd could not be started
:roll:

risoltoooooooooooooooooooooooooooooooooooooooooooooooooooo

Inviato: mar 12 set 2006, 0:45
da bbg5ne
per la serie "me la canto e me la suono" :lol:
:idea:
in pratica ho aggiornato sia su httpd.conf, sia su mod_php.conf tutte le diciture di php4 in php5 e poi ho istallato l'ulttima versone di mm, scaricabile anche da qui:
http://www.ossp.org/pkg/lib/mm/
;)

Inviato: mar 12 set 2006, 10:04
da bbg5ne
mi ero dimenticato un altra cosa... prima di aggiornare mm ho anche copiato il file php.ini-dist presa dal package in

Codice: Seleziona tutto

/usr/local/lib/php.ini
, mi pare ora di non essermi dimenticato nulla.... :roll:

Inviato: mar 12 set 2006, 10:38
da bbg5ne
mi sa comunque che l'ultimo procedimento p inutile...anche se l'ho letto sul readme di php, comunque durante l'aggiornamento il php.ini viene messo in /etc/apache e apache fa riferimento a quello per la configurazione!!! ;)

Inviato: mar 12 set 2006, 10:44
da dapuzz
ieri me ne sono andato a dormire presto e ti ho lasciato tutto solo a risolvere i problemi :D Credo di capire però che non hai scaricato i pacchetti ufficiali! per questo hai avuto quel problema con in mod_php.conf
C'è php-5.1.6 in extra/php5 e mm, in slackware/l

Inviato: mar 12 set 2006, 10:47
da bbg5ne
strano perchè php l'avevo preso da slackware.it cercando sul motote di ricerca dei package php, ma mm non me lo trovava, l'ho dovuto compilare...ma l'importante è che ora funziona! :)

Inviato: mar 12 set 2006, 10:50
da dapuzz
I paccheti ufficiali non installano in usr/local
http://www.slackware.it/pb/search.php?v ... q=libmm.so
Usa sempre questo sito e andrai una bomba. ;)