Pagina 1 di 1

RISOLTO problemi hostname

Inviato: lun 16 ott 2006, 20:49
da linus.bash
Ciao,

nella shell vedo l'host attuale che vorrei cambiare...allora uso il comando hostname + nome...funziona bene ma dopo il riavvio ritorna l'hostname precedente...come si fa?


grazie.

Inviato: lun 16 ott 2006, 21:02
da tgmx
Io di solito modifico:

/etc/HOSTNAME

Inviato: lun 16 ott 2006, 21:21
da linus.bash
tgmx ha scritto:Io di solito modifico:

/etc/HOSTNAME
ma quando lo fai poi va tutto bene? mi ricordo che con la 10.2 avevo modificato quel file ma ricevuto infiniti errori soprattutto su apache...che dite riprovo? magari sarò + fortunato :?

Inviato: lun 16 ott 2006, 21:31
da Darathorn
linus.bash ha scritto: ma quando lo fai poi va tutto bene? mi ricordo che con la 10.2 avevo modificato quel file ma ricevuto infiniti errori soprattutto su apache...che dite riprovo? magari sarò + fortunato :?
io per sicurezza lo inserisco anche in /etc/hosts

Codice: Seleziona tutto

bash-3.1$ cat /etc/hosts 

# For loopbacking.
127.0.0.1               localhost            caladan
192.168.1.1             ecaz.herbert.dune    ecaz
192.168.1.2             dune                 dune
192.168.1.3             caladan.herbert.dune caladan
192.168.1.4             kaitain.herbert.dune kaitain
192.168.1.4             kaitain.*******.***   kaitain

bash-3.1$ 

e controlla il name dentro il config di apache, si trova in /etc/apache/httpd.conf

Inviato: lun 16 ott 2006, 21:41
da tgmx
linus.bash ha scritto:
tgmx ha scritto:Io di solito modifico:

/etc/HOSTNAME
ma quando lo fai poi va tutto bene? mi ricordo che con la 10.2 avevo modificato quel file ma ricevuto infiniti errori soprattutto su apache...che dite riprovo? magari sarò + fortunato :?
Ho sempre fatto così e non ho mai avuto problemi. Se non mi ricordo male, anche tramite netconfig si può impostare il nuovo hostname e di fatto non fa altro che modificare /etc/HOSTNAME

Inviato: lun 16 ott 2006, 22:32
da linus.bash
ok ora ho messo il nome in netconfig e poi hostname..ora riavvio...

Inviato: lun 16 ott 2006, 22:56
da linus.bash
Come pensavo...uff...

allora con netconfig ho dato il nome host "linus" e il domain "localhost"...dopo il riavvio vedo linu in shell ma apache non funziona.

Poi vado in httpd.conf e modifico il servername che non era configurato (#) e metto "localhost" ma con http://127.0.0.1 oppure http://localhost apache non funziona...

che faccio???

Inviato: lun 16 ott 2006, 23:02
da linus.bash
Risolto :

Codice: Seleziona tutto

127.0.0.1		localhost
127.0.0.1		linus 
bhe il file host non si è modificato da solo...ho dovuto usare le mani :shock: :lol:

Inviato: lun 16 ott 2006, 23:43
da albatros
Beh, c'era da aspettarselo...

$ less /etc/hosts

#
# hosts This file describes a number of hostname-to-address
# mappings for the TCP/IP subsystem. It is mostly
# used at boot time, when no name servers are running.
# On small systems, this file can be used instead of a
# "named" name server. Just add the names, addresses
# and any aliases to this file...
#
# By the way, Arnt Gulbrandsen <agulbra@nvg.unit.no> says that 127.0.0.1
# should NEVER be named with the name of the machine. It causes problems
# for some (stupid) programs, irc and reputedly talk. :^)
#

# For loopbacking.
127.0.0.1 localhost

Inviato: mar 17 ott 2006, 1:04
da tgmx
Giusto, andava modificato anche hosts.

Però utilizzando netconfig, dovrebbe pensare lui a tutto...

Inviato: mar 17 ott 2006, 7:20
da linus.bash
tgmx ha scritto:Giusto, andava modificato anche hosts.

Però utilizzando netconfig, dovrebbe pensare lui a tutto...
infatti :roll:

Inviato: mar 17 ott 2006, 15:35
da albatros
Non trovo così tanto sciocco che hostname non modifichi /etc/hosts se proprio in quel file viene sconsigliato di farlo perché alcuni programmi potrebbero avere dei problemi...

Strano che poi apache ti dia errore nel dare http://localhost...