Pagina 1 di 1

qualche problema con udev

Inviato: mer 25 ott 2006, 12:06
da pennega
ciao a tuttti ragazzi...
ho un piccolo problama con udev: non riesco a fargli capire come deve chiamare i miei dischi e penne usb... premetto che sto usando dbus,hal e tutto l'ocorrente per usare l'automount...

ho creato il file /etc/udev/rules.d/00-myrules.rules e dentro ci ho messo
##*** Configuration fyle for my devices

SUBSYSTEM=="block", GROUP="disk"

##usb disk driver

BUS=="scsi", SYSFS{vendor}=="SAMSUNG ", SYSFS{model}=="SP1203N ", NAME="usbdisk"

##usb penn driver

SUBSYSTEM=="block", SYSFS{model}=="Store _n_ Go ", NAME="usbpenn"
le informazioni inserite le ho prese tramite il comando

Codice: Seleziona tutto

udevinfo -a -p /sys/block/sda/ 
ma quando inserisco uno dei device interessati, questo continua ad essere riconosciuto cone sda* ...

ecco l'output di /var/log/message

Codice: Seleziona tutto

Oct 25 11:58:07 kafka kernel: usb 1-1: new high speed USB device using ehci_hcd and address 11
Oct 25 11:58:07 kafka kernel: usb 1-1: configuration #1 chosen from 1 choice
Oct 25 11:58:07 kafka kernel: scsi7 : SCSI emulation for USB Mass Storage devices
Oct 25 11:58:07 kafka udevsend[16424]: starting udevd daemon
Oct 25 11:58:07 kafka udevsend[16429]: starting udevd daemon
Oct 25 11:58:07 kafka udevsend[16450]: starting udevd daemon
Oct 25 11:58:08 kafka udevsend[16469]: starting udevd daemon
Oct 25 11:58:09 kafka udevsend[16424]: unable to connect to event daemon, try to call udev directly
Oct 25 11:58:09 kafka udevsend[16429]: unable to connect to event daemon, try to call udev directly
Oct 25 11:58:09 kafka udevsend[16450]: unable to connect to event daemon, try to call udev directly
Oct 25 11:58:10 kafka udevsend[16469]: unable to connect to event daemon, try to call udev directly
Oct 25 11:58:12 kafka kernel:   Vendor: VBTM      Model: Store 'n' Go      Rev: 1.02
Oct 25 11:58:12 kafka kernel:   Type:   Direct-Access                      ANSI SCSI revision: 00
Oct 25 11:58:12 kafka kernel: SCSI device sda: 2013184 512-byte hdwr sectors (1031 MB)
Oct 25 11:58:12 kafka kernel: sda: Write Protect is off
Oct 25 11:58:12 kafka kernel: SCSI device sda: 2013184 512-byte hdwr sectors (1031 MB)
Oct 25 11:58:12 kafka kernel: sda: Write Protect is off
Oct 25 11:58:12 kafka kernel:  sda:<7>usb-storage: queuecommand called
Oct 25 11:58:12 kafka kernel: sd 7:0:0:0: Attached scsi removable disk sda
Oct 25 11:58:12 kafka kernel: sd 7:0:0:0: Attached scsi generic sg0 type 0
Oct 25 11:58:12 kafka udevsend[16502]: starting udevd daemon
Oct 25 11:58:12 kafka udevsend[16506]: starting udevd daemon
Oct 25 11:58:12 kafka udevsend[16514]: starting udevd daemon
Oct 25 11:58:12 kafka udevsend[16517]: starting udevd daemon
Oct 25 11:58:14 kafka udevsend[16541]: starting udevd daemon
Oct 25 11:58:15 kafka udevsend[16502]: unable to connect to event daemon, try to call udev directly
Oct 25 11:58:15 kafka udevsend[16506]: unable to connect to event daemon, try to call udev directly
Oct 25 11:58:15 kafka udevsend[16514]: unable to connect to event daemon, try to call udev directly
Oct 25 11:58:15 kafka udevsend[16517]: unable to connect to event daemon, try to call udev directly
Oct 25 11:58:15 kafka udevsend[16541]: unable to connect to event daemon, try to call udev directly
mi lasciano un pò perplesso le righe del tipo Oct 25 11:58:15 kafka udevsend[16541]: unable to connect to event daemon, try to call udev directly

qualche idea ???

Inviato: mer 25 ott 2006, 20:32
da slux
BUS=="scsi", SYSFS{vendor}=="SAMSUNG ", SYSFS{model}=="SP1203N ", NAME="usbdisk"
Forse dico un'eresia ma anzichè "scsi" hai provato con "usb" nella voce BUS ???
Io faccio proprio così....

Inviato: mer 25 ott 2006, 20:40
da pennega
si si ho provato varie cose ma non vuole chiamarmi la penna e l'hh usb come voglio... ho provato anche a dirgli di creare il link ma non fà manco quello...

Inviato: mer 25 ott 2006, 23:03
da absinthe
pennega ha scritto:si si ho provato varie cose ma non vuole chiamarmi la penna e l'hh usb come voglio... ho provato anche a dirgli di creare il link ma non fà manco quello...
anche io questa sera ho provato a fare la stessa cosa ponendo un file chiamato 10-my.rules dentro /etc/udev/rules.d però udev non ne voleva sapere... credevo di dover rilanciare tutto il sistema hotplug (cosa non necessaria con l'udev della 10.2)... purtroppo per mancanza di tempo ho ripiegato sui link persistenti creati da udev dentro /dev/disk/by-id e non ho ancora risolto l'inghippo...

... non ho trovato neppure il tempo per s4d: tu hai dato un occhio?

M

Inviato: mer 25 ott 2006, 23:09
da pennega
si ho gurdato su S4D... ma non dice nulla di diverso, poi tra l'altro ci sono alcune imprecisioni che ho segnalato nel 3D di S4D

Inviato: gio 26 ott 2006, 9:40
da Paoletta
io uso regole del genere...

Codice: Seleziona tutto

ACTION=="add",KERNEL=="sd?1", SYSFS{vendor}=="Sony    ",SYSFS{model}=="Storage Media  ",SYSFS{start}=="50",SYSFS{size}=="255950",SYMLINK+="
usbdisk",RUN+="/bin/su paoletta -c '/bin/mount /mnt/usbdisk'"
dai un'occhiata a

Codice: Seleziona tutto

/usr/share/doc/udev-097/docs/writing_udev_rules/

Inviato: gio 26 ott 2006, 11:47
da pennega
non sò che dire... non vuole funzionare... ormai ci perdo le speranze...comunque il file che mi hai consigliato l' ho letto e riletto

Inviato: ven 27 ott 2006, 13:40
da pennega
le regole che ho scritto in realtà sono corrette, il problema è la penna usb, infatti con l'hdd esterno e il masterizzatore tutto funziona... ecco le regole che ho scritto

Codice: Seleziona tutto

##*** Configuration fyle for my devices

SUBSYSTEM=="block", GROUP="disk"

##usb disk driver

SUBSYSTEM=="block", BUS=="scsi", SYSFS{vendor}=="SAMSUNG ", SYSFS{model}=="SP1203N         ",NAME="usbdisk" 

##usb penn driver

SUBSYSTEM=="block", BUS=="scsi", SYSFS{vendor}=="VBTM    ", SYSFS{model}=="Store _n_ Go    ",NAME="usbpen" 

##Masterizzatore DVD ext

SUBSYSTEM=="block", BUS=="scsi", SYSFS{vendor}=="LITE-ON ", SYSFS{model}=="DVDRW SHM-165P6S",NAME="extdvd" 

Inviato: dom 29 ott 2006, 23:37
da urka58
Prova
ACTION=="add", DEVPATH=="/devices/*", ENV{PHYSDEVBUS}=="?*", WAIT_FOR_SYSFS="bus"
ACTION=="add", SUBSYSTEM=="scsi", WAIT_FOR_SYSFS="ioerr_cnt"
in testa al tuo file oppure togli i blocchi BUS=="xxx".
Dovrebbe funzionare
Ciao

Inviato: mer 15 nov 2006, 9:04
da absinthe
ehm... onestamente non capisco come ma adesso le regole vanno benone!
ve lo dico nel caso qualcuno si imbattesse in questo thread. non ho cambiato assolutamente niente! ho solo ricopiato il mio file 10-my.rules in /etc/udev/rules.d e a sto giro ha rilevato perfettamente tutto: penne usb e hd (la stampante non ho provato anche perchè ancora non mi funziona la stampa con cups :$).
per inciso vi posto le regole:

Codice: Seleziona tutto

utente@laptop:~$ cat /etc/udev/rules.d/10-my.rules
#-----------------------------------------------------------

#
#       my rules
#

#usb hard-disk
BUS=="scsi", SYSFS{vendor}=="HDS72808", SYSFS{model}=="0PLAT20", NAME="TEAC%n"
#usb pen
BUS=="scsi", SYSFS{vendor}=="LEXAR", SYSFS{model}=="JUMPDRIVE SPORT", NAME="LEXAR%n"
#256mb usb pen
BUS=="scsi", SYSFS{vendor}=="KINGMAX", SYSFS{model}=="USB Flash Disk", NAME="KINGMAX%n"
#pin printer
BUS=="usb", SYSFS{manufacturer}=="Hewlett-Packard",SYSFS{product}=="officejet 7100 series",NAME="%k",SYMLINK+="hpoj7100"
#-----------------------------------------------------------