Pagina 1 di 1

kernel panic..perchè?

Inviato: lun 15 gen 2007, 20:16
da Ermes1
salve a tutti. ho bisogno di un aiuto: l'altro giorno ho installato slack 11 su un pc. l'ho installata innanzitutto col kernel di default 2.4.33.3 su fs reisers. e funzionava bene. poi ho deciso di installare il kernel 2.6.17.13. l'ho fatto dai pacchetti precompilati ma quando vado ad avviarla ho il seguente messaggio:

no filesystem could mount root, tried : ext2
kernel panic - not syncing : vfs : unable to mount root fs on unknown block(3,6)

che significa? come risolvo?

Inviato: lun 15 gen 2007, 20:24
da samiel
Verosimilmente significa che hai tralasciato di creare l'initrd.
Vedi le indicazioni in S4d, § 19.1.1

M.

Inviato: lun 15 gen 2007, 21:03
da Ermes1
si è probabile in effetti non l'ho fatto: non mi sono mai rovato a dover installare / su reiser.

bene ora funziona era quello!! comunque ho delle domande ora!!

sempre su S4D c'è scritto che è non è consigliabile installare anche gli headers, ma se non li si installa quelli del 2.4 possono creare problemi?

poi vorrei segnalare degli errori su S4D.

1)reiserfs è scritto con la maiuscola (il che porta all'errore utenti niubbi come me) :D

2)nel esempio in cui si mostra come creare l'initrd per reiserfs c'è il kernel 2.6.10 invece che 2.6.17.13

3)infine sempre in quell'esempio c'è scritto /dev/hdan invece di /dev/hdxn

spero di essere stato utile!! devo avvertire qualcuno di persona?

grazie mille comunque!

Inviato: lun 15 gen 2007, 22:15
da samiel
Per gli headers,vale la regola di mantenere quelli
con cui sono state compilate le glibc. Per cui
meglio mantenere quelli del 2.4. Salvo casi particolari
di pacchetti che richiedono il 2.6, tutto funziona bene,
anzi meglio, perché alcuni pacchetti non aggiornatissimi
invece non compilano ancora col 2.6.

Per gli errori, grazie della segnalazione, adesso verifico.
Dovevi avvertire me, e lo hai fatto.... :-)

M.

Inviato: lun 15 gen 2007, 22:37
da Ermes1
eccellente... ciao :D :D