Pagina 1 di 1

nfs su slack 12

Inviato: gio 26 lug 2007, 19:58
da g4b0
Ciao a tutti,
finchè agvevo la slack 11 (aggiornata a current) sul client questa riga mi montava la diectory NFS e funzionava bene (a parte il fatto cher non la caricava al boot):

Codice: Seleziona tutto

192.168.0.100:/mp3 /mnt/mp3 nfs auto,users,exec,tcp,rsize=8192,wsize=8192,timeo=14,intr 0 0
Ora mi da questo output:

Codice: Seleziona tutto

root@slack12:/home/g4b0# mount /mnt/mp3
mount: 192.168.0.100:/mp3 failed, reason given by server: Permission denied
Sul server non ho fatto nessuna modifica, che può essere???

Inviato: gio 26 lug 2007, 20:35
da DanBadJar
Forse è banale, ma sul client hai fatto paritre /etc/rc.d/rc.rpc ?

Inviato: gio 26 lug 2007, 20:45
da g4b0
sisi

comunque ecco qua:

Codice: Seleziona tutto

root@slack12:/home/g4b0# /etc/rc.d/rc.rpc start
root@slack12:/home/g4b0# mount /mnt/mp3/
mount: 192.168.0.100:/mp3 failed, reason given by server: Permission denied
root@slack12:/home/g4b0# ps aux | grep rpc
bin       3076  0.0  0.0   1760   480 ?        Ss   18:59   0:00 /sbin/rpc.portmap
nobody    3080  0.0  0.0   1828   696 ?        Ss   18:59   0:00 /sbin/rpc.statd
root      7651  0.0  0.0   2004   636 pts/1    R+   20:44   0:00 grep rpc

Inviato: ven 27 lug 2007, 0:08
da Dani
Copia l'output di exportfs, cat /etc/hosts.allow e anche cat /etc/hosts.deny :D

Inviato: ven 27 lug 2007, 0:09
da bloodlust
che messaggi di errore hai sul server?

Inviato: ven 27 lug 2007, 9:22
da g4b0
Dani ha scritto:Copia l'output di exportfs, cat /etc/hosts.allow e anche cat /etc/hosts.deny :D
Ecco qua:

Codice: Seleziona tutto

root@sun:/home/g4b0# more /etc/exports
# See exports(5) for a description.
# This file contains a list of all directories exported to other computers.
# It is used by rpc.nfsd and rpc.mountd.

#/multimedia       192.168.0.2(rw,async) 192.168.1.3(rw,async) 192.168.1.2(rw,async)
/multimedia        192.168.0.2(rw,async)
/mp3               192.168.0.2(rw,async)
root@sun:/home/g4b0# more /etc/hosts.allow
#
# hosts.allow   This file describes the names of the hosts which are
#               allowed to use the local INET services, as decided by
#               the '/usr/sbin/tcpd' server.
#
# Version:      @(#)/etc/hosts.allow    1.00    05/28/93
#
# Author:       Fred N. van Kempen, <waltje@uwalt.nl.mugnet.org
#
#

lockd: 192.168.1.2 , 192.168.1.3, 192.168.0.2, 192.168.1.155
rquotad: 192.168.1.2 , 192.168.1.3, 192.168.0.2, 192.168.1.155
mountd: 192.168.1.2 , 192.168.1.3, 192.168.0.2, 192.168.1.155
statd: 192.168.1.2 , 192.168.1.3, 192.168.0.2, 192.168.1.155

# End of hosts.allow.
root@sun:/home/g4b0# more /etc/hosts.deny
#
# hosts.deny    This file describes the names of the hosts which are
#               *not* allowed to use the local INET services, as decided
#               by the '/usr/sbin/tcpd' server.
#
# Version:      @(#)/etc/hosts.deny     1.00    05/28/93
#
# Author:       Fred N. van Kempen, <waltje@uwalt.nl.mugnet.org
#
#

lockd:ALL
mountd:ALL
rquotad:ALL
statd:ALL

# End of hosts.deny.
root@sun:/home/g4b0#                                                 

Inviato: ven 27 lug 2007, 9:29
da g4b0
bloodlust ha scritto:che messaggi di errore hai sul server?
Dove logga nfsd? Non sono riuscito a trovarlo..

Inviato: ven 27 lug 2007, 13:01
da Dani
g4b0 ha scritto: Ecco qua:
Non intendevo il contenuto di etc/exportfs, ma l'output del comando "exportfs", lanciato da root.
Comunque googlando ho letto che in hosts.allow deve essere presente anche l'ip del server, controlla che nel tuo caso sia così !
Aggiungi anche in etc/hosts.allow "portmap: ip_client, ip_server !
I log dovrebbero essere in /var/log/nfsd/

[Risolto] nfs su slack 12

Inviato: ven 27 lug 2007, 16:18
da g4b0
Risolto!!! Non avevo riavviato nfsd dopo aver modificato /etc/exports 8) 8)

Grazie comunque a tutti