Pagina 1 di 1
[RISOLTO] Problemi con Hylafax 5.1.7
Inviato: mar 31 lug 2007, 17:11
da DanBadJar
Premetto che è la prima volta che approccio a una configurazione di un server fax.
Ho installato Hylafax scaricandolo qui da Slacky, l'ho configurato (spero) con tutti i parametri necessari tramite faxsetup e il pc è in grado di dialogare correttamente col modem.
Ma se dò un:
ottengo uno spiazzante
Non ho trovato problemi analoghi sul forum. Qualche idea?
Grazie
Inviato: mar 31 lug 2007, 18:15
da galvy
sembrerebbe che il demone del faxserver non sia attivo.... se fai nmap 127.0.0.1 che risultato ottieni?????
Inviato: mar 31 lug 2007, 19:45
da Luci0
Devi rendendere eseguibile lo script di controllo /etc/rc.d/rc.hylafax e lo fai partire con...
Inoltre conviene modificare gli script
/etc/rc.d/rc.M per l'avvio
e
/etc/rc.d/rc.0
per lo spegnimento
buon lavoro ....
Inviato: mar 31 lug 2007, 21:57
da DanBadJar
Lo script /etc/rc.hylafax era già reso avviabile, però non partiva.
Sono stato costretto ad avviarlo "a mano" inserendolo in /etc/rc.local
Così finalmente ho la 4559 aperta e hylafax è in ascolto.
Proverò ad inviare e ricevere, poi posto se ho difficoltà.
Grazie mille per ora, rapidissimi come sempre.

Inviato: mar 31 lug 2007, 22:29
da Luci0
Come dicevo conviene modificare ... rc.M e rc.0 piuttosto che rc.local ecco come potresti fare ... in rc.M
Codice: Seleziona tutto
..................
# Start Samba (a file/print server for Win95/NT machines).
# Samba can be started in /etc/inetd.conf instead.
if [ -x /etc/rc.d/rc.samba ]; then
. /etc/rc.d/rc.samba start
fi
# Start the Hylafax server
if [ -x /etc/rc.d/rc.hylafax ]; then
. /etc/rc.d/rc.hylafax start
fi
# Start the GPM mouse server:
if [ -x /etc/rc.d/rc.gpm ]; then
. /etc/rc.d/rc.gpm start
fi
..........
e in modo analogo in rc.0 ... ovviamente usando lo stop ...

Inviato: lun 6 ago 2007, 17:50
da DanBadJar
Ok, sto andando avanti in questa avventura disperata.
Ho fatto l'upgrade alla versione 5.1.7 , usando il pacchetto di slacky.
Attualmente sembra che io abbia degli errori di autenticazione.
Se provo a dare un:
ottengo un errore:
Ho notato inoltre che il comando
faxadduser non funziona, o almeno non come dovrebbe. Mi aspetto infatti che mi modifichi il file
/var/spool/hylafax/hosts.hfaxd aggiungendo utenti e invece niente.
Il file contiene:
La cosa strana è che il comando:
non restituisce nessun errore!
Ho inoltre provato ad accedere al server da diversi clients per windows, ma niente, l'errore è sempre il medesimo:
Login failed: 530 Login incorrect
Idee?
Grazie
Inviato: lun 6 ago 2007, 20:09
da Luci0
Prova da root a vedere cosa esce ...
Inviato: lun 6 ago 2007, 20:17
da DanBadJar
Stessa cosa. Stesso risultato sia da user che da root.

Inviato: gio 9 ago 2007, 11:54
da DanBadJar
Procedendo con l'odissea ho scoperto che il comando
faxadduser non era in grado di aggiungere utenti perchè non avevo i permessi di scrivere sul file
/var/spool/hylafax/etc/hosts.hfaxd
ma non mi postava neanche qualche errore in output...mah...
Cambiati i permessi ho rilanciato il comando e aggiunto tutti i miei utenti del caso, ora ho il file di questo tipo:
Codice: Seleziona tutto
localhost
127.0.0.1
172.30
^daniele@::QLZkuBLhGJqoE
^luca@::5FbkT8s0RRlUU
^root@::0GOXw7ZvJhbhA
Ebbene signori, il risultato non cambia! Riavviato il demone e l'errore è sempre quello, sia dai server che dai clients.
Che altro devo settare? In che direzione posso andare? Si vedesse almeno qualche sirena...
Inviato: gio 9 ago 2007, 12:24
da Luci0
Mi ricordo di aver trovato gli stessi problemi e di averli risolti ,
studiando quello che fa ksendfax , a causa della mancanza di documentazione su sendfax, .... devi aggiungere alcuni switch ... ma ovviamente non ricordo quali e devi leggere le man page ma ricordo che non erano aggiornate ... come non é aggiornata documentazione per la procedura di configurazione degli utenti..
Ricordo di aver installato KsendFax in locale e studiando le opzioni che imposta (... che tra l' altro non funzionano) e provandole su sendfax son riuscito a farlo funzionare ...
Ho usato un centralino e un fax per fare i test ...
... per ora il mio supporto si limita a queste dritte perché il tempo a disposizione é sempre poco ... spero di poterti aiutare .. anche perché ho hylafax installato su questo PC che attivo per la ricezione e appena posso faccio dei test ....
... Ciao

Inviato: gio 9 ago 2007, 13:18
da Luci0
Il comando da dare é ...
sendfax -f utente_hylafax -d numero file_da_inviare
e comunque a me non restituisce l' errore che ti esce a te ...
Codice: Seleziona tutto
livia@gablin:/home/gabriele$ sendfax -d 123457 /etc/printcap
Malformed (null) sender name or mail address
Comunque io ho installato Hylafax+ 5.1.3 dai sorgenti .... é probabile che ci sia qualche problema nel pacchetto ...
Inviato: gio 9 ago 2007, 13:21
da DanBadJar
Ok, almeno so un po' dove documentarmi.
Appena faccio altri test li posto qui in topic.
Grazie Luci0, sei gentilissimo.
Inviato: gio 9 ago 2007, 15:39
da Luci0
Ho installato su una 12.0 fresca il pacchetto Hylafax 5.1.7, ho configurato il server e il modem seriale con faxsetup ... ho seguito le istruzioni che trovi in /usr/doc/hylafax/README.Slackware e ho provato ad inviare un fax ... e sono riuscito ad ottenere che il modem tenta di comporre il numero ... forse stai sbagliando qualcosa ... altri test non ne ho fatti ma credo che all' ingrosso l' installazione sia corretta..
...

Inviato: ven 10 ago 2007, 17:02
da DanBadJar
Nel file README.Slackware ho trovato solo alcune cose da cambiare in
/etc/inittab, ovvero ho dovuto inserire la riga:
Mentre googlando un po' avevo trovato da impostare:
Il risultato è sempre lo stesso. Continua a restituirmi:
Meglio se vado in ferie! Evviva le sirene...
Re: Problemi con Hylafax 5.1.7
Inviato: mar 8 apr 2008, 15:22
da DanBadJar
Torno sull'argomento qualche mese dopo il post iniziale per dirvi che ho risolto, col pacchetto di slacky e versione 5.2.3.
Unico problema è che all'esecuzione di faxsetup si hanno alcuni errori relativi a files non trovati. E' necessario crearli a mano.
Per il resto tutto funziona.
Grazie a tutti!