Pagina 1 di 1

Ancora una volta swaret dietro proxy [RISOLTO]

Inviato: sab 20 ott 2007, 15:05
da legionario
Ciao a tutti!!
Lo so che l'argomento e' gia' stato trattato piu' volte ma ho bisogno di superare il proxy con swaret per scaricare gli aggiornamenti. Ho seguito le indicazioni degli altri post ma non ho ottenuto risulati. Secondo voi puo' essere un problema di protocollo di autenticazione del server proxy?
Ho inserito in swaret.conf

Codice: Seleziona tutto

 WGET_PROXY=http://dominio\utente:password@proxy:porta 
ho provato anche senza mettere il dominio ma niente...no va...

qualche suggerimento?

Inviato: sab 20 ott 2007, 17:43
da albatrosla
Io utilizzo swaret attraverso un proxy http con simple authentication e utilizzo la seguente stringa:

Codice: Seleziona tutto

WGET_PROXY=http://username:password@host:port
Quindi uguale alla tua. Che errore restituisce swaret? Dà un authentication failed?

Inviato: sab 20 ott 2007, 21:29
da legionario
Veramente non mi restituisce nessun errore...semplicemente non mi scarica niente. Piu' precisamente inizia lo scaricamento visualizzando la barretta che ruota in senso orario e, dopo un po', dice failed.

Codice: Seleziona tutto

root@105RN:~# swaret --update
swaret 1.6.3-2
[ http://sunsite.cnlab-switch.ch/ftp/mirror/slackware/slackware-current ]
### Scarico il File CHECKSUMS... FALLITO!
### Scarico il File FILELIST... FALLITO!
.......
.......
Questo e' quello che ho attivato nel mio swaret:

Codice: Seleziona tutto

 VERSION=current
LANGUAGE=ITALIANO
ROOT=http://sunsite.cnlab-switch.ch/ftp/mirror/slackware/slackware-$VERSION
ROOT=http://www.slackware.no/slackware/slackware-$VERSION
ROOT=http://www.slackware.at/data/slackware-$VERSION
ROOT=http://ftp.planetmirror.com/pub/slackware/slackware-$VERSION
REPOS_ROOT=Slacky%http://www.slacky.eu/repository/slackware-12.0
REPOS_ROOT=Slackware%http://darkstar.ist.utl.pt/slackware/addon/slacky/slackware-12.0/
REPOS_ROOT=Slacky_uglyplace%http://slacky.uglyplace.org/repository/slackware-12.0/
DEP_ROOT=http://swaret.sourceforge.net
RANDOMR=0
ROLLBACK=0
ROLLBACKMAX=3
USEPKGDESC=0
EXCLUDE=kernel alsa lilo
EXCLUDE=swaret
EXCLUDE=aaa_
EXCLUDE=MANIFEST.bz2$
EXCLUDE=.*dl$ .*PACKAGER$ .*MYBUILD$
DEPENDENCY=1
DSEARCHLIB=1
DSEARCHM=0
MD5CHECK=1
GPGCHECK=0
DESC=0
CACHE_DIR=/var/swaret
LOG=1
LOG_FILE=/var/log/swaret
WARNINGS=1
INFORMATION=1
NIC=eth0
PROGRESS=0
TIMEOUT=35
RETRIES=5
PASSIVE_FTP=1
WGET_PROXY=http://utente:password@proxy:porta
Ho pensato che, forse, swaret comunica su una porta diversa dalla 80, pertanto il proxy me la blocca. Almeno e' un'ipotesi...

Inviato: dom 21 ott 2007, 10:56
da albatrosla
No, swaret comunica sulla 80 con i repository http e sulla 21 con quelli ftp. Quindi non è quello il problema. Inoltre, se non ti dà errori di autenticazione, significa che il nodo proxy non è un problema. Prova, piuttosto, a cambiare repository: ce ne sono parecchi che mi danno problemi del genere, anche perchè talvolta hanno cambiato le path nel tempo...

Inviato: dom 21 ott 2007, 11:05
da legionario
Non e' che potresti mandarmi uno dei tuoi repository che sicuramente funzionano? Se il problema e' tutto li' allora e' meno grave di quanto pensassi...

Comunque mi confermi che non c'e' nessun errore nel swaret.conf vero?

Grazie per l'aiuto

Inviato: dom 21 ott 2007, 12:09
da legionario
Ho fatto un tentativo che mi induce a ritenere che i Repositories non c'entrino niente, anche perche' e' impossibile che tutti quelli che ho inserito siano inattivi. Infatti, anche inserendo una password sbagliata swaret non mi restituisce nessun messaggio di errore di autenticazione, ma il solito output ripetuto tante volte quanti sono i tentativi di scaricare i vari elementi:

Codice: Seleziona tutto

~# swaret --update
swaret 1.6.3-2

[ http://sunsite.cnlab-switch.ch/ftp/mirror/slackware/slackware-current ]
### Scarico il File CHECKSUMS... FALLITO!
### Scarico il File FILELIST... FALLITO!
### Scarico il File PACKAGES dei Pacchetti... FALLITO!
### Scarico il File PACKAGES dei Pacchetti Extra... FALLITO!
### Scarico il File ChangeLog... FALLITO!
.........
.........
Quale potrebbe essere il problema? SIcuramente swaret qualche problemino ce l'ha visto che omette di segnalare la mancata autenticazione da parte del proxy...

Inviato: dom 21 ott 2007, 22:48
da legionario
Da quanto ho capito dopo alcune ricerche wget, e quindi swaret, sembrerebbe non supportare l'autenticazione NTLM dei proxy...
E' una supposizione sbagliata? Questo vuol dire che non ho speranze di passare il proxy con swaret?

Inviato: sab 15 dic 2007, 2:04
da legionario
Riesumo dopo parecchio tempo questo post per comunicare che il problema si puo' risolvere installando ntlmaps da sorgenti, configurare opportunamente il file di configurazione inserendo i dati relativi al proxy, al tipo di autenticazione, al dominio, allo user e passwd. Quindi in swaret.conf bisogna inserire i dati relativi non al proxy aziendale ma ad ntlmaps. Infine si fa partire ntlmaps (tramite python)e si avvia swaret. La procedura in realta' e' molto semplice...
Spero possa essere di aiuto a qualcuno...