Pagina 1 di 1

HTTPD non parte.....dopo cambio struttura HD

Inviato: gio 15 nov 2007, 17:50
da riotten
ciao,
ho dovuto a causa di una formattazione su hda cambiare la struttura dell'hard disk...........tutto ok parte perfettamente l'OS senza problemi.....l'unica cosa è che HTTPD non ha nessuna voglia di partire.....
per la precisione:

Codice: Seleziona tutto

httpd: apr_sockaddr_info_get() failed for SERVER
httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName

presumo sia da cambiare qualche impostazione sul file di configurazione...ma quale???
oppure è il caso di reinstallarlo di sana pianta?

P.S: ho provato anche

Codice: Seleziona tutto

root@SERVER:/home/nouser# domainname 127.0.0.1
ma niente


ultima cosa è possibile che HTTPD succhi circa 100mb di ram?




.

Inviato: gio 15 nov 2007, 19:34
da whites11
servirebbe un output più prolisso.
prova a leggere i file in /var/log/apache

Inviato: gio 15 nov 2007, 20:30
da riotten
vi posto gli ultimi 3giorni di error_log

Codice: Seleziona tutto

[Mon Nov 12 22:16:48 2007] [notice] Apache/2.2.4 (Unix) DAV/2 PHP/5.2.3 configured -- resuming normal operations
[Tue Nov 13 14:02:27 2007] [error] [client 192.168.0.4] PHP Warning:  gethostbyaddr() [<a href='function.gethostbyaddr'>function.gethostbyadd$
[Tue Nov 13 14:03:04 2007] [error] [client 192.168.0.4] PHP Warning:  gethostbyaddr() [<a href='function.gethostbyaddr'>function.gethostbyadd$
[Tue Nov 13 14:05:03 2007] [error] [client 192.168.0.4] File does not exist: /srv/httpd/htdocs/favicon.ico
[Tue Nov 13 14:05:09 2007] [error] [client 192.168.0.4] PHP Warning:  gethostbyaddr() [<a href='function.gethostbyaddr'>function.gethostbyadd$
[Tue Nov 13 14:14:50 2007] [error] [client 192.168.0.4] PHP Warning:  gethostbyaddr() [<a href='function.gethostbyaddr'>function.gethostbyadd$
[Tue Nov 13 14:15:18 2007] [error] [client 192.168.0.4] PHP Warning:  gethostbyaddr() [<a href='function.gethostbyaddr'>function.gethostbyadd$
[Wed Nov 14 16:08:27 2007] [error] [client 192.168.0.4] File does not exist: /srv/httpd/htdocs/favicon.ico
[Wed Nov 14 16:08:32 2007] [error] [client 192.168.0.4] PHP Warning:  gethostbyaddr() [<a href='function.gethostbyaddr'>function.gethostbyadd$
[Wed Nov 14 16:16:45 2007] [error] [client 192.168.0.4] File does not exist: /srv/httpd/htdocs/favicon.ico
[Wed Nov 14 16:19:19 2007] [error] [client 192.168.0.4] PHP Warning:  gethostbyaddr() [<a href='function.gethostbyaddr'>function.gethostbyadd$
[Thu Nov 15 00:56:11 2007] [error] [client 192.168.0.4] File does not exist: /srv/httpd/htdocs/favicon.ico
[Thu Nov 15 00:56:26 2007] [error] [client 192.168.0.4] PHP Warning:  gethostbyaddr() [<a href='function.gethostbyaddr'>function.gethostbyadd$
[Thu Nov 15 01:08:55 2007] [error] [client 192.168.0.4] PHP Warning:  gethostbyaddr() [<a href='function.gethostbyaddr'>function.gethostbyadd$
[Thu Nov 15 15:15:05 2007] [notice] caught SIGTERM, shutting down
[Thu Nov 15 15:22:50 2007] [alert] (EAI 3)Temporary failure in name resolution: mod_unique_id: unable to find IPv4 address of "SERVER"
Configuration Failed
[Thu Nov 15 19:03:48 2007] [alert] (EAI 2)Name or service not known: mod_unique_id: unable to find IPv4 address of "SERVER"
Configuration Failed
[Thu Nov 15 19:05:14 2007] [alert] (EAI 2)Name or service not known: mod_unique_id: unable to find IPv4 address of "SERVER"
Configuration Failed
[Thu Nov 15 19:05:47 2007] [alert] (EAI 2)Name or service not known: mod_unique_id: unable to find IPv4 address of "SERVER"
Configuration Failed


Inviato: gio 15 nov 2007, 21:55
da whites11
prova ad eseguire il comando

Codice: Seleziona tutto

hostname
cosa torna?

Inviato: gio 15 nov 2007, 22:06
da riotten

Codice: Seleziona tutto

nouser@SERVER:~$ hostname
SERVER

Inviato: ven 16 nov 2007, 10:42
da conraid
riotten ha scritto:

Codice: Seleziona tutto

nouser@SERVER:~$ hostname
SERVER
ServerName in httpd.conf come l'hai configurato?

Inviato: ven 16 nov 2007, 12:05
da riotten
ho riconfigurato il servername (mettendo Servername 192.168.0.1:80) ......adesso il servizio parte senza errori ma da LAN, HTTPD non è raggiungibile.

Inviato: ven 16 nov 2007, 12:15
da conraid
riotten ha scritto:ho riconfigurato il servername (mettendo Servername 192.168.0.1:80) ......adesso il servizio parte senza errori ma da LAN, HTTPD non è raggiungibile.
Bisognerebbe guardare le altre impostazioni.
Comunque io imposterei un HOSTNAME completo
per esempio server.example.com
in questo modo Apache dovrebbe prenderti il ServerName senza specificarlo esplicitamente. Lasciando la riga commentata insomma.

Naturalmente va modificato anche il file hosts

Inviato: mar 20 nov 2007, 10:02
da riotten
ciao, scusate se non ho risposto prima ma non ho avuto tempo....
ho modificato l'hostname ora è del tipo xxx.yyy.it
ma il problema si vede non è solo quello

Codice: Seleziona tutto

root@SERVER:/home/nouser# httpd
httpd: apr_sockaddr_info_get() failed for xxx.yyy.IT
httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
in più se lancio

Codice: Seleziona tutto

root@SERVER:/home/nouser# httpd -k stop
httpd (no pid file) not running
mi viene questo messaggio.....

qualche aiuto?

Inviato: mar 20 nov 2007, 10:31
da conraid
Hai modificato l'hostname del pc?
se ora dai

Codice: Seleziona tutto

hostname -f
ti ritorna
xxx.yyy.it?

Dopo mettilo pure nella direttiva ServerName in httpd.conf e modifica il file hosts, altrimenti non sa che ip ha il tuo hostname

Quell'errore che ti da è relativo al domain name, te lo dice chiaramente.

Il secondo invece ti indica che httpd non era in esecuzione, se invece lo era allora è un problema di permessi nel creare il file pid, oppure lo cerca dove non dovrebbe, oppure è finito lo spazio, etc...

Comunque ferma apache o con
#/etc/rc.d/rc.httpd stop

o con

apachectl stop

idem per avviarlo

Hai provato a disintallare il pacchetto e reinstallarlo?

Inviato: mar 20 nov 2007, 11:36
da riotten
perfetto, ora httpd funziona perfettamente, ma ho lasciato commentata la riga ServerName in thhpd.conf....è il caso debba rimetterla?

Inviato: mar 20 nov 2007, 12:00
da conraid
riotten ha scritto:perfetto, ora httpd funziona perfettamente, ma ho lasciato commentata la riga ServerName in thhpd.conf....è il caso debba rimetterla?
Se trova il nome da solo no.
Quando è commentata Apache cerca di stabilire il nome della macchina. Se tutto è configurato solitamente ci riesce :-)